Wrong password at the lock screen

Yesterday I installed a new HDD on my pc, had it set up as a mounted drive and then went on to my day… Now today I woke up, started my pc, tried to log in and got an error saying the password was wrong, I thought it had something to do with the new HDD, because it was the only thing I messed with, I unplugged it and the PC booted in emergency mode, in the emergency mode my password was accepted just fine, I deleted the line on the fstab file that made the whole thing with the HDD, but when a rebooted the machine, the lock screen still said my password was wrong.

NumLock? Capslock?

Double checked it like a thousend times, the password is right! It even worked at he emergency mode, so there’s no way I’ve forgotten it.

While booted in emergency mode, use the passwd command to change your own user’s password.

Make sure it’s not the root user, nor sudo.

See if that helps the next time you reboot.

Changed it to 123, didn’t work, also, I’m commenting and uncommenting the line that sets up the HDD thing trough the manjaro usb installer, is there a keypress to open emergency mode without all this hassle?

Wait, what’s going on?

The HDD sounds like a separate issue. It won’t affect your user’s password and/or login issue of the Display Manager.

What’s your system info? Which desktop environment are you using?


You can add noauto as a mount option in the fstab entry.

As for manually entering emergency mode, you can hold down Left Shift, and intercept the Grub menu. Hit the E key to “edit” the Grub line. Add a 3 to the options.

Wait, wait, wait. When you’re in emergency mode, you’re using the root user.

That’s why I said above:

EDIT: If you’re logged in as root, you can specify which user to change the password:

passwd rosso

As an example.

I wanted to upload a picture, but since I can’t, I’ll try to explain it, I used the passwd “myuser” command, changed it to 123 rebooted the system, but it didn’t work. I’m using manjaro as the desktop enviroment. As a way to get into and out of the emergency mode I was using that line about the HDD, commenting and uncommenting it, using the manjaro installer to go into the etc folder.

I apologize, but I’m more confused now.

Not to sound rude, but you might be mixing up terms and concepts. Based on my interpretation, I might have been going down a different path to try to help you resolve this.

Manjaro is not a desktop environment.

Examples of desktop environments are: KDE, Xfce, GNOME, Mate, and etc.

You are not being rude at all, my english and my knowlegde about this kind of thing is really limited. Now let me try to rephrase all of this…
I can get in and out of the emergency mode, I know FOR SURE both the root password and the user password, and I can use the root password just fine in the emergency mode. Now, when I try to login in the lock screen, it says my user password is wrong. The eviroment I’m using is Xfce.

Okay, here’s a test. When you get to the Xfce login screen, switch to an unused TTY:

CTRL + ALT + F2

In this new TTY2, try to login as your normal user.

Does it accept your user’s password?


EDIT: To get back to the TTY for the Xfce login screen, it’s likely to be F1 (or F7).

1 Like

It asks me the name of the user, I write it, then it asks me the password, I write it, the it says “Login incorrect” I tried all passwords, the root, the old one and the new one.

Okay, in this TTY2, login as root, and then repeat the above steps with the passwd command for the primary user.

While logged in as root under TTY2:

passwd rosso

Use a good password for this test. Don’t use “123”.

Something like:
myPass.1234

to login as root, I use the “root” username, all lowercase, and the same password that works in the emergency mode, it says “login incorrect”

You can’t even login as root under TTY2?

I didn’t mess with anything related to passwords since I installed the O.S. It was working fine yesterday. I also didn’t install any dodgy stuff.

So to confirm:

You cannot login as root or your primary user when switched to TTY2?

Yes. Now can I fix it, or should I just format the computer? It will take AGES for me to get all the stuff set up like I had.

This is definitely fixable.
Just a short interjection:
keyboard layout issue, perhaps?
Make sure that what you think you type is what the system actually sees.
When you write the username in TTY for example - try and confirm that the characters that you type (for your password) actually appear.
It’s a possibility at this point …

If I type the password in the user name, it appears as it should, it has no special characters, just roman characters, it’s just a normal word.