Wrong disk space detected by Dolphin after repartitioning

Hello everyone,
I have a small problem with Dolphin. I increased the size of my /home, which is in a separated partition, from ~90 gb to ~200 gb, since it was almost full. Dolphin does not calculate the correct size of the partition, and thus does not allow to copy additional files since it claims there is no space available.
The KDE partition manager sees the new home partition correctly, so I suppose it is just a problem of Dolphin.
Do you have an idea or what it should be?

Did you reboot or reload the partitions after you increased it?

When you change partiontable you need the system to reload the partitiontable. It’s poosible commandline but a system restart is recommended.

Don’t know if this works with KDE

sudo partprobe

How did you resize the partition? If it’s ext4, then you need to claim the remaining space with resize2fs /dev/sdX (with X being your home partition).

This should be done online, so please mount this partition first.

1 Like

I answer to everybody:

  • yes I rebooted a few times since I did the partitioning a few days ago
  • I did not reload the partitions; I didn’t know I had to do it manually
  • I resized it with kde partition manager from live usb, since the /home partition must be unmounted and I could not do it with manjaro booted. It’s ext4.

Can I use resize2fs while the /home is mounted? or should I go through live usb again?

The reason is definately a problem with your partition table.

I cannot say for kparted - the KDE partition manager - but if you boot your system on a live media and use gparted to resize - I know for at fact the partition table is written correctly.

Over time - that past 4 years - now that is most likely me being bisased - participating on the Manjaro Forum I have come to the conclusion that KDE - although very, very popular - but not that reliable or stable.

I went into live usb and tried to use resize2fs. The outputs says to run e2fsck first. I did it, but again, it says to run e2fsck again. So I’m stuck. I paste below the output from the terminal

sudo e2fsck -f /dev/sda4 && sudo resize2fs /dev/sda4
e2fsck 1.46.2 (28-Feb-2021)
Pass 1: Checking inodes, blocks, and sizes
Pass 2: Checking directory structure
Pass 3: Checking directory connectivity
Pass 4: Checking reference counts
Pass 5: Checking group summary information
/dev/sda4: 4765043/6406144 files (0.1% non-contiguous), 22576920/25600000 blocks
resize2fs 1.46.2 (28-Feb-2021)
Please run ‘e2fsck -f /dev/sda4’ first.

Is it caused by those 0.1% non-contiguous files? (don’t know what it means to be honest)

Use online resize2fs, meaning with a mounted sda4

it worked with the mounted partition… not sure why it didn’t by live usb but ok. problem solved.
Thank you to everyone

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.