Wlr_renderer=vulkan

where to set wlr_renderer=vulkan, environment, greetd or other place?

start with command line, WLR_RENDERER=vulkan sway, error…
‘vk_ext_queue_family_foreign not found’ but this extend is vulkan1.0 ?
ps. wlroots-git/sway-git/mesa-git/wayland.

Increase your chances of solving your issue:

so, rebuild wlroots-git & sway-git and set WLR_RENDERER=vulkan, work.

$ uname -a
Linux archlinux 5.17.0-rc1-1-MANJARO-ARM-RPI #1 SMP PREEMPT Mon Jan 24 18:44:06 UTC 2022 aarch64 GNU/Linux

./config/sway/config #file config
disable xwayland # wayland without X11

is it possible this configuration?

WLR_RENDERER=vulkan sway
i get the same error message: vk_ext_queue_family_foreign not found

wayland packages installed:

$ pacman -Qs wayland
local/dmenu-wayland-git 4.2.1.r51.304c8e9-1
Wayland port of a generic menu for X
local/dwl-git 0.2.1.r31.d4e08c0-1
Simple, hackable dynamic tiling Wayland compositor (dwm for Wayland)
local/egl-wayland 2:1.1.9+r3+g582b2d3-1
EGLStream-based Wayland external platform
local/glfw-wayland 3.3.6-1
A free, open source, portable framework for graphical application development (wayland)
local/grim 1.3.2-1
Screenshot utility for Wayland
local/kwayland 5.90.0-1 (kf5)
Qt-style Client and Server library wrapper for the Wayland libraries
local/kwayland-server 5.23.5-1 (plasma)
Wayland server components built on KDE Frameworks
local/libva 2.12.0-0.1
Video Acceleration (VA) API for Linux
local/libva1 1.8.3-3
Video Acceleration (VA) API for Linux
local/mako 1.6-2
Lightweight notification daemon for Wayland
local/qt5-wayland 5.15.2+kde+r44-1 (qt qt5)
Provides APIs for Wayland
local/qt6-wayland 6.2.2-1 (qt6)
Provides APIs for Wayland
local/sway-git r6866.cd1ee0e1-1
Tiling Wayland compositor and replacement for the i3 window manager
local/swaybg-git r113.e10d02c-1
Wallpaper tool for Wayland compositors
local/wayland 1.20.0-1
A computer display server protocol
local/wayland-protocols 1.24-1
Specifications of extended Wayland protocols
local/wlroots-git 0.16.0.r5337.da2491d4-1
Modular Wayland compositor library (git version)
local/xorg-xwayland 21.1.2-1 (xorg)
run X clients under wayland

sorry, my fault. forgot to re-login><
*error message: vk_ext_queue_family_foreign not found
will try sway-1.7

have tried sway-1.7 got same error.
maybe vulkan-1.1 not support some vk_extension for Pi?

found some vk_ext in mesa-git features.txt.

VK_EXT_private_data DONE (anv, lvp, radv, tu, v3dv)
VK_EXT_provoking_vertex DONE (anv, lvp, radv, tu, v3dv)
VK_EXT_queue_family_foreign DONE (anv, radv, vn) <—