Wireguard Support

I’ve checked the arch-linux instructions on setting up Wireguard - but honestly I’m stuck at the beginning…

First - Can’t seem to be able to install any wireguard gui client… I did install wireguard-tools, which I guess installed (?) and arch-linux writeup said to install qomui (which doesn’t install)…

This is the documentation I’m using - perhaps it is out of date?: Archlinux Wireguard

Any pointers to documentation or support would be great!

(note: what I’m REALLY trying to solve is putting my home laptop on wireguard - same as my android phone - so I can use KDE Connect when on wireguard)…

Network Manager already support Wireguard. Just go to your network settings and create new Wireguard connection.

1 Like

Are you using a VPN service provider, or are you hosting your own VPN?

If it’s the former, then the provider (Mullvad, Surfshark, etc) will offer their own GUI software, scripts, and/or config generator.

in case you got your connection setting as a wireguard-profile, then import it into the network-manager using

$ sudo nmcli connection import type wireguard file <path-to-wireguard-profile>

the profile should now be available under your network connections icon in system tray.

I also have wireguard both on android and Kde. Kde connect simply don’t work with wireguard. You have to disconnect wireguard temporarely to use Kde connect.

Seems to be a general VPN issue, not just wireguard.

See below bug report:


My thougth is there is no connection between wireguard implemented in the kernel and Kde connect, therefore it would not work at the same time. I can be wrong.

For kde connect to work you need to be on the same network.

As soon as you connect your system to a VPN wireguard or otherwise - your network changes to the VPN network and you are disconnected from the network your phone is connected to.

That is expected behaviour.

1 Like

Add another IP on your NIC, that’s not in WIreguard’s AllowedIPs list? :man_shrugging:

I was hoping (going to test) that by putting both devices (android/manjaro laptop) on the same vpn network - that would work. (I am using my own VPN)

Likely it won’t but wanted to test it. Also - would like to have wireguard vpn working when not at home and using my pc

This image was perfect - thanks!

Hello, please tell me how to fill in the fields, and in what order, is there a configuration file

PrivateKey = GEQhuqw3sU6de4mVMYx7/Ktn1CjmWyk0Fhu9I0IidG4=
Address =

PublicKey = SExW6JS9O54ErXQIXUPOiHNyBu3QAz0H6FtbIbwkBig=
PresharedKey = dc3/MuVtNCWzKH0+0MlpTPZr+6zd1xUwZ7mhHTh7WCk=
AllowedIPs =, ::/0
PersistentKeepalive = 0
Endpoint =

I tried in different ways, it does not connect, although everything is fine on Androyd and Windows

That looks like you have a wireguard myvpn.conf file.
Put it in /etc/wireguard and the connection will appear as selectable.
Or you can use something like wg-quick up myvpn

Now I connected it via nano /etc/wireguard/wg0-client.conf , and via file import, all the settings are in place, and before everything was launched via nano /etc/wireguard/wg0-client.conf , but the speed was low. Now it connects, but there is no speed, there is some movement, a few kilobytes, while Open VPV is configured and connects everything perfectly and gives out, just like without VPN. In general, at a dead end so far, what is it and how to deal with it)

Huh? That would just open the file with the nano text editor.

PS. Yet another way of doing it would be:

systemctl start wg-quick@wg0-client

)) no, I wrote almost incomprehensibly, like this from a label, and the second connection is through import, but there is no speed