Wired connection keeps dropping

Hello all, new to Manjaro, so apologies if I don’t get something simple.

Issue: After a few minutes after logging in, my network stops working, I can ping everything, discord voice chat still runs fine so it’s getting internet, but I can’t browse the web or download files. It happens every time after about 10 minutes of running fine.

A restart fixes it for another ten minutes.

I’ve tried 5.x kernels and 6.x kernels with no luck, I’ve gone to the network manager conf file and set enabled=true but it just keeps happening.

All other computers (10) work fine, no issues on wireless or wired connections.

Someone mentioned about changing my driver from r8169 to r8168, I’ve downloaded it but don’t know how to change that or even if it is the right method.

Any help is appreciated!

Plain IP or Domain? Could be that the DNS-Server is overloaded. Probably a loose contact?

My home network, no domain or anything. DNS server is fine, the computer was running Windows fine just the other day so I know it’s not hardware related.

The router should also be automatically assigning the DNS server as we have a pihole setup

Well … thats the point of the question.

Can you ping ?
Can you ping google.com or drill google.com ?

If you can reach the ip, but not the domain … it would indicate a DNS problem.

You just say that:

but it gets dropped on the local network? Then the culprit must be this:

Since discord works, it can’t be a driver issue. If the pattern is exactly 10min, then probably there is timeout of some sort on DNS requests, since pihole blocks websites by DNS requests.

Manjaro hardware detection tool can install kernel modules for r8168 driver and blacklist r8169 driver

sudo mhwd -i pci network-r8168

Or use Manjaro Settings Manager GUI:

Kernel 6.5 seems to be too new for this:

$ sudo mhwd -i pci network-r8168
[sudo] Passwort für stefan: 
> Installing network-r8168...
Sourcing /etc/mhwd-x86_64.conf
Has lib32 support: true
Sourcing /var/lib/mhwd/db/pci/network_drivers/r8168/MHWDCONFIG
Processing classid: 0200
:: Paketdatenbanken werden synchronisiert …
 core wird heruntergeladen …
 extra wird heruntergeladen …
 community wird heruntergeladen …
 multilib wird heruntergeladen …
Fehler: Ziel nicht gefunden: linux65-r8168
Error: pacman failed!
Error: script failed!

It’ll be released next week. Why do you think you need this rc version?

You could try the dkms version but from experience, they also need modifications for new kernel versions.

OK so I’ll wait and stick to older version - thx!

Kernel 6.5 seems to be too new for this

Package linux65-r8168 is not available yet - packages.manjaro.org/linux65

Hello, so I narrowed it down to the DNS server. I’ve set the etc/network manager/conf.d/20-connectivity.conf to enabled=false

I’ve been looking at the settings and wondering if the pihole is just killing the connections, but am not sure if something needs to be white listed or if I’ve missed a setting.

I appreciate all your comments, again total noob to anything arch based

To add to this, I also checked the pihole DNS server was set on /etc/resolv.conf

So guess not :sweat_smile:

You also didnt provide any of the information people asked for.

And what does this mean? you just put enabled=false in there?

… I guess this means you are using the old ‘resolvconf’ style? What is resolvconf set to use?

It is still not clear whether you are actually providing your own DNS or using some provider.

(pihole could be using a dns cache on its own … or could just be a firewall while using your ISP dns, we dont know)

Besides which thats that system … so theres however that is configured on top of however your actual manjaro system is configured. (like whether it is using the DNS provided by pihole or not)


And all this is besides the possible confusion … are you still only talking about connection to another system on the home network? That probably shouldnt even be going to DNS resolution at all … which may have to do with nsswitch.conf or similar.

It sounds like you have a decent amount of complexity … but we dont have all the information to fill out those schematics.