Network disconnects for a minute after sleep

Thanks for the help so far, both of you. I’ve set the static IP and the the static DNS. Issue has significantly improved, but it still takes ~30 seconds for internet to come back:

sep 20 06:59:13 komp NetworkManager[655]: <info>  [1600577953.9177] manager: sleep: sleep requested (sleeping: no  enabled: yes)
sep 20 06:59:13 komp NetworkManager[655]: <info>  [1600577953.9177] manager: NetworkManager state is now ASLEEP

    PC sleeps here

sep 20 07:02:25 komp NetworkManager[655]: <info>  [1600578145.5494] manager: sleep: wake requested (sleeping: yes  enabled: yes)
sep 20 07:02:25 komp NetworkManager[655]: <info>  [1600578145.5495] device (enp34s0): state change: activated -> unmanaged (reason 'sleeping', sys-iface-state: 'managed')
sep 20 07:02:25 komp NetworkManager[655]: <info>  [1600578145.5731] manager: NetworkManager state is now CONNECTED_GLOBAL
sep 20 07:02:25 komp NetworkManager[655]: <info>  [1600578145.5886] manager: NetworkManager state is now DISCONNECTED
sep 20 07:02:25 komp NetworkManager[655]: <info>  [1600578145.5892] device (enp34s0): state change: unmanaged -> unavailable (reason 'managed', sys-iface-state: 'managed')
sep 20 07:02:25 komp dbus-daemon[654]: [system] Activating via systemd: service name='org.freedesktop.nm_dispatcher' unit='dbus-org.freedesktop.nm-dispatcher.service' requested by ':1.14' (uid=0 pid=655 comm="/usr/bin/NetworkManager --no-daemon ")
sep 20 07:02:25 komp systemd[1]: Starting Network Manager Script Dispatcher Service...
sep 20 07:02:25 komp systemd[1]: Started Network Manager Script Dispatcher Service.
sep 20 07:02:25 komp audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=NetworkManager-dispatcher comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
sep 20 07:02:25 komp kernel: audit: type=1130 audit(1600578145.592:161): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=NetworkManager-dispatcher comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
sep 20 07:02:28 komp NetworkManager[655]: <info>  [1600578148.9882] device (enp34s0): carrier: link connected
sep 20 07:02:28 komp NetworkManager[655]: <info>  [1600578148.9883] device (enp34s0): state change: unavailable -> disconnected (reason 'carrier-changed', sys-iface-state: 'managed')
sep 20 07:02:28 komp NetworkManager[655]: <info>  [1600578148.9891] policy: auto-activating connection 'Wired connection 1' (c71e2d8f-69a3-374d-97a9-1b8b9e402b99)
sep 20 07:02:28 komp NetworkManager[655]: <info>  [1600578148.9895] device (enp34s0): Activation: starting connection 'Wired connection 1' (c71e2d8f-69a3-374d-97a9-1b8b9e402b99)
sep 20 07:02:28 komp NetworkManager[655]: <info>  [1600578148.9896] device (enp34s0): state change: disconnected -> prepare (reason 'none', sys-iface-state: 'managed')
sep 20 07:02:28 komp NetworkManager[655]: <info>  [1600578148.9899] manager: NetworkManager state is now CONNECTING
sep 20 07:02:28 komp NetworkManager[655]: <info>  [1600578148.9901] device (enp34s0): state change: prepare -> config (reason 'none', sys-iface-state: 'managed')
sep 20 07:02:28 komp NetworkManager[655]: <info>  [1600578148.9905] device (enp34s0): state change: config -> ip-config (reason 'none', sys-iface-state: 'managed')
sep 20 07:02:28 komp NetworkManager[655]: <info>  [1600578148.9925] device (enp34s0): state change: ip-config -> ip-check (reason 'none', sys-iface-state: 'managed')
sep 20 07:02:28 komp NetworkManager[655]: <info>  [1600578148.9947] device (enp34s0): state change: ip-check -> secondaries (reason 'none', sys-iface-state: 'managed')
sep 20 07:02:28 komp NetworkManager[655]: <info>  [1600578148.9949] device (enp34s0): state change: secondaries -> activated (reason 'none', sys-iface-state: 'managed')
sep 20 07:02:28 komp NetworkManager[655]: <info>  [1600578148.9953] manager: NetworkManager state is now CONNECTED_LOCAL
sep 20 07:02:28 komp NetworkManager[655]: <info>  [1600578148.9962] manager: NetworkManager state is now CONNECTED_SITE
sep 20 07:02:28 komp NetworkManager[655]: <info>  [1600578148.9963] policy: set 'Wired connection 1' (enp34s0) as default for IPv4 routing and DNS
sep 20 07:02:28 komp NetworkManager[655]: <info>  [1600578148.9972] device (enp34s0): Activation: successful, device activated.
sep 20 07:02:36 komp systemd[1]: NetworkManager-dispatcher.service: Succeeded.
sep 20 07:02:36 komp audit[1]: SERVICE_STOP pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=NetworkManager-dispatcher comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
sep 20 07:02:36 komp kernel: audit: type=1131 audit(1600578156.049:163): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=NetworkManager-dispatcher comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
sep 20 07:03:04 komp NetworkManager[655]: <info>  [1600578184.5298] manager: NetworkManager state is now CONNECTED_GLOBAL

That’s a 50% improvement! :stuck_out_tongue_winking_eye:

Run the following commands in 2 terminal tabs

ping -O -D 1.1.1.1
ping -O -D YourDefaultGateway

sleep, wake up and provide your log output on top of the output above, please…

:innocent:

Logs:

sep 25 12:58:21 komp NetworkManager[617]: <info>  [1601031501.0766] manager: sleep: sleep requested (sleeping: no  enabled: yes)
sep 25 12:58:21 komp NetworkManager[617]: <info>  [1601031501.0767] manager: NetworkManager state is now ASLEEP


sep 25 13:21:37 komp NetworkManager[617]: <info>  [1601032897.5249] manager: sleep: wake requested (sleeping: yes  enabled: yes)
sep 25 13:21:37 komp NetworkManager[617]: <info>  [1601032897.5250] device (enp34s0): state change: activated -> unmanaged (reason 'sleeping', sys-iface-state: 'managed')
sep 25 13:21:37 komp NetworkManager[617]: <info>  [1601032897.5425] manager: NetworkManager state is now CONNECTED_GLOBAL
sep 25 13:21:37 komp NetworkManager[617]: <info>  [1601032897.5665] manager: NetworkManager state is now DISCONNECTED
sep 25 13:21:37 komp NetworkManager[617]: <info>  [1601032897.5671] device (enp34s0): state change: unmanaged -> unavailable (reason 'managed', sys-iface-state: 'managed')
sep 25 13:21:37 komp dbus-daemon[616]: [system] Activating via systemd: service name='org.freedesktop.nm_dispatcher' unit='dbus-org.freedesktop.nm-dispatcher.service' requested by ':1.14' (uid=0 pid=617 comm="/usr/bin/NetworkManager --no-daemon ")
sep 25 13:21:37 komp audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=NetworkManager-dispatcher comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
sep 25 13:21:37 komp kernel: audit: type=1130 audit(1601032897.570:63): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=NetworkManager-dispatcher comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
sep 25 13:21:41 komp NetworkManager[617]: <info>  [1601032901.5840] device (enp34s0): carrier: link connected
sep 25 13:21:41 komp NetworkManager[617]: <info>  [1601032901.5841] device (enp34s0): state change: unavailable -> disconnected (reason 'carrier-changed', sys-iface-state: 'managed')
sep 25 13:21:41 komp NetworkManager[617]: <info>  [1601032901.5846] policy: auto-activating connection 'Wired connection 1' (c71e2d8f-69a3-374d-97a9-1b8b9e402b99)
sep 25 13:21:41 komp NetworkManager[617]: <info>  [1601032901.5848] device (enp34s0): Activation: starting connection 'Wired connection 1' (c71e2d8f-69a3-374d-97a9-1b8b9e402b99)
sep 25 13:21:41 komp NetworkManager[617]: <info>  [1601032901.5849] device (enp34s0): state change: disconnected -> prepare (reason 'none', sys-iface-state: 'managed')
sep 25 13:21:41 komp NetworkManager[617]: <info>  [1601032901.5851] manager: NetworkManager state is now CONNECTING
sep 25 13:21:41 komp NetworkManager[617]: <info>  [1601032901.5852] device (enp34s0): state change: prepare -> config (reason 'none', sys-iface-state: 'managed')
sep 25 13:21:41 komp NetworkManager[617]: <info>  [1601032901.5855] device (enp34s0): state change: config -> ip-config (reason 'none', sys-iface-state: 'managed')
sep 25 13:21:41 komp NetworkManager[617]: <info>  [1601032901.5868] device (enp34s0): state change: ip-config -> ip-check (reason 'none', sys-iface-state: 'managed')
sep 25 13:21:41 komp NetworkManager[617]: <info>  [1601032901.5887] device (enp34s0): state change: ip-check -> secondaries (reason 'none', sys-iface-state: 'managed')
sep 25 13:21:41 komp NetworkManager[617]: <info>  [1601032901.5889] device (enp34s0): state change: secondaries -> activated (reason 'none', sys-iface-state: 'managed')
sep 25 13:21:41 komp NetworkManager[617]: <info>  [1601032901.5891] manager: NetworkManager state is now CONNECTED_LOCAL
sep 25 13:21:41 komp NetworkManager[617]: <info>  [1601032901.5897] manager: NetworkManager state is now CONNECTED_SITE
sep 25 13:21:41 komp NetworkManager[617]: <info>  [1601032901.5898] policy: set 'Wired connection 1' (enp34s0) as default for IPv4 routing and DNS
sep 25 13:21:41 komp NetworkManager[617]: <info>  [1601032901.5903] device (enp34s0): Activation: successful, device activated.
sep 25 13:21:47 komp systemd[1]: NetworkManager-dispatcher.service: Succeeded.
sep 25 13:21:47 komp audit[1]: SERVICE_STOP pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=NetworkManager-dispatcher comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
sep 25 13:21:47 komp kernel: audit: type=1131 audit(1601032907.450:65): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=NetworkManager-dispatcher comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
sep 25 13:21:47 komp dbus-daemon[616]: [system] Activating via systemd: service name='org.freedesktop.nm_dispatcher' unit='dbus-org.freedesktop.nm-dispatcher.service' requested by ':1.14' (uid=0 pid=617 comm="/usr/bin/NetworkManager --no-daemon ")
sep 25 13:21:47 komp audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=NetworkManager-dispatcher comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
sep 25 13:21:47 komp kernel: audit: type=1130 audit(1601032907.693:66): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=NetworkManager-dispatcher comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
sep 25 13:21:57 komp systemd[1]: NetworkManager-dispatcher.service: Succeeded.
sep 25 13:21:57 komp audit[1]: SERVICE_STOP pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=NetworkManager-dispatcher comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
sep 25 13:21:57 komp kernel: audit: type=1131 audit(1601032917.456:67): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=NetworkManager-dispatcher comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
sep 25 13:22:01 komp NetworkManager[617]: <info>  [1601032921.9709] manager: NetworkManager state is now CONNECTED_GLOBAL
sep 25 13:22:01 komp dbus-daemon[616]: [system] Activating via systemd: service name='org.freedesktop.nm_dispatcher' unit='dbus-org.freedesktop.nm-dispatcher.service' requested by ':1.14' (uid=0 pid=617 comm="/usr/bin/NetworkManager --no-daemon ")
sep 25 13:22:01 komp audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=NetworkManager-dispatcher comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
sep 25 13:22:01 komp kernel: audit: type=1130 audit(1601032921.973:68): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=NetworkManager-dispatcher comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
sep 25 13:22:13 komp systemd[1]: NetworkManager-dispatcher.service: Succeeded.
sep 25 13:22:13 komp audit[1]: SERVICE_STOP pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=NetworkManager-dispatcher comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
sep 25 13:22:13 komp kernel: audit: type=1131 audit(1601032933.154:69): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=NetworkManager-dispatcher comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'

Ping 1.1.1.1:

PING 1.1.1.1 (1.1.1.1) 56(84) bytes of data.
[1601032904.485777] no answer yet for icmp_seq=1
[1601032905.499118] no answer yet for icmp_seq=2
[1601032906.512452] no answer yet for icmp_seq=3
[1601032907.525775] no answer yet for icmp_seq=4
[1601032908.539109] no answer yet for icmp_seq=5
[1601032909.552444] no answer yet for icmp_seq=6
[1601032910.565777] no answer yet for icmp_seq=7
[1601032911.579114] no answer yet for icmp_seq=8
[1601032912.592448] no answer yet for icmp_seq=9
[1601032913.605776] no answer yet for icmp_seq=10
[1601032914.619112] no answer yet for icmp_seq=11
[1601032915.632442] no answer yet for icmp_seq=12
[1601032916.645778] no answer yet for icmp_seq=13
[1601032917.659113] no answer yet for icmp_seq=14
[1601032918.672449] no answer yet for icmp_seq=15
[1601032919.685777] no answer yet for icmp_seq=16
[1601032920.699117] no answer yet for icmp_seq=17
[1601032921.712446] no answer yet for icmp_seq=18
[1601032921.921072] 64 bytes from 1.1.1.1: icmp_seq=18 ttl=56 time=1222 ms
[1601032921.921162] 64 bytes from 1.1.1.1: icmp_seq=19 ttl=56 time=209 ms
[1601032922.719917] 64 bytes from 1.1.1.1: icmp_seq=20 ttl=56 time=5.94 ms
[1601032923.721812] 64 bytes from 1.1.1.1: icmp_seq=21 ttl=56 time=6.02 ms
[1601032924.722898] 64 bytes from 1.1.1.1: icmp_seq=22 ttl=56 time=6.05 ms
[1601032925.723975] 64 bytes from 1.1.1.1: icmp_seq=23 ttl=56 time=6.04 ms
[1601032926.725103] 64 bytes from 1.1.1.1: icmp_seq=24 ttl=56 time=6.10 ms
[1601032927.726222] 64 bytes from 1.1.1.1: icmp_seq=25 ttl=56 time=6.08 ms
[1601032928.727321] 64 bytes from 1.1.1.1: icmp_seq=26 ttl=56 time=6.07 ms
[1601032930.424160] 64 bytes from 1.1.1.1: icmp_seq=27 ttl=56 time=6.04 ms

Local gateway:

PING 192.168.1.1 (192.168.1.1) 56(84) bytes of data.
[1601032902.992454] no answer yet for icmp_seq=1
[1601032904.005782] no answer yet for icmp_seq=2
[1601032904.646021] From 192.168.1.2 icmp_seq=1 Destination Host Unreachable
[1601032905.006416] no answer yet for icmp_seq=3
[1601032906.032442] no answer yet for icmp_seq=4
[1601032907.045785] no answer yet for icmp_seq=5
[1601032908.059113] no answer yet for icmp_seq=6
[1601032909.072448] no answer yet for icmp_seq=7
[1601032910.085778] no answer yet for icmp_seq=8
[1601032910.726124] From 192.168.1.2 icmp_seq=7 Destination Host Unreachable
[1601032911.086519] no answer yet for icmp_seq=9
[1601032912.112441] no answer yet for icmp_seq=10
[1601032913.125778] no answer yet for icmp_seq=11
[1601032914.139114] no answer yet for icmp_seq=12
[1601032915.152442] no answer yet for icmp_seq=13
[1601032916.165777] no answer yet for icmp_seq=14
[1601032916.806144] From 192.168.1.2 icmp_seq=13 Destination Host Unreachable
[1601032917.166545] no answer yet for icmp_seq=15
[1601032918.192447] no answer yet for icmp_seq=16
[1601032919.205783] no answer yet for icmp_seq=17
[1601032919.846135] From 192.168.1.2 icmp_seq=16 Destination Host Unreachable
[1601032920.206524] no answer yet for icmp_seq=18
[1601032921.232442] no answer yet for icmp_seq=19
[1601032921.914872] 64 bytes from 192.168.1.1: icmp_seq=19 ttl=64 time=1708 ms
[1601032921.914901] 64 bytes from 192.168.1.1: icmp_seq=20 ttl=64 time=682 ms
[1601032922.233337] 64 bytes from 192.168.1.1: icmp_seq=21 ttl=64 time=0.096 ms
[1601032923.259213] 64 bytes from 192.168.1.1: icmp_seq=22 ttl=64 time=0.094 ms
[1601032924.272570] 64 bytes from 192.168.1.1: icmp_seq=23 ttl=64 time=0.090 ms
[1601032925.285888] 64 bytes from 192.168.1.1: icmp_seq=24 ttl=64 time=0.099 ms
[1601032926.299257] 64 bytes from 192.168.1.1: icmp_seq=25 ttl=64 time=0.135 ms
[1601032927.312596] 64 bytes from 192.168.1.1: icmp_seq=26 ttl=64 time=0.142 ms
[1601032928.326018] 64 bytes from 192.168.1.1: icmp_seq=27 ttl=64 time=0.224 ms
[1601032929.339278] 64 bytes from 192.168.1.1: icmp_seq=28 ttl=64 time=0.158 ms

OK, that’s <21 seconds…

Can you please:

  1. Change to a brand new CAT-6 cable
    And if that doesn’t improve the response:
  2. fix the Ethernet speed at 100mbps? (if you don’t know how to do that, shout out)

(Last-ditch effort)

:wink:

Yes, all my times are estimates. But 21 seconds is still very annoying to me. Whole point of putting PC into sleep mode is to have it up and ready immediately.

Number one will be a bit harder because current Cat 5e cable goes through the wall to another room. However, I’m not sure if it is the cable, because Windows installation on that same machine does not experience the same issue.

Will try the 100mbps thing. Can you hint me on what I have to do? I’ve been trying to find the option but I can only find people wanting to do the reverse.

Windows fixes the network speed automatically.

what’s the output of:

nmcli connection show Something

Where Something is the name of your Ethernet connection (In my case Wired\ connection\ 1)

Thanks for all your help, both of you.

Issue is not happening anymore, but I’m not quite sure what fixed it. I suspect system update.

Urgh… all this work and now no one gets a solution!

:sob:

OTOH, I’ve got lots of :unicorn::unicorn::unicorn: :dollar::dollar::dollar: already…

:innocent:

Yeah, I’m also a bit annoyed that we couldn’t figure this out. Could it be that network drivers got updated recently?

It’s very probable that the network drivers got updated in the meantime on kernel 5.8 and the disadvantage of being on a rolling release… :wink:

And as it’s very probably fixed by now you don’t have to worry (much) about it happening again in the future…

:grin:

I was wrong, the problem is back.

One interesting thing I noticed, is that the network does not disconnect immediately after resume. Couple of seconds after resume, network is still available (pings and http requests go through), but then it disconnects (and reconnects back after couple of seconds).

Here is requested print from nmcli:

connection.id:                          Wired connection 1
connection.uuid:                        c71e2d8f-69a3-374d-97a9-1b8b9e402b99
connection.stable-id:                   --
connection.type:                        802-3-ethernet
connection.interface-name:              --
connection.autoconnect:                 yes
connection.autoconnect-priority:        -100
connection.autoconnect-retries:         -1 (default)
connection.multi-connect:               0 (default)
connection.auth-retries:                -1
connection.timestamp:                   1602316382
connection.read-only:                   no
connection.permissions:                 --
connection.zone:                        --
connection.master:                      --
connection.slave-type:                  --
connection.autoconnect-slaves:          -1 (default)
connection.secondaries:                 --
connection.gateway-ping-timeout:        0
connection.metered:                     unknown
connection.lldp:                        default
connection.mdns:                        -1 (default)
connection.llmnr:                       -1 (default)
connection.wait-device-timeout:         -1
802-3-ethernet.port:                    --
802-3-ethernet.speed:                   0
802-3-ethernet.duplex:                  --
802-3-ethernet.auto-negotiate:          no
802-3-ethernet.mac-address:             --
802-3-ethernet.cloned-mac-address:      --
802-3-ethernet.generate-mac-address-mask:--
802-3-ethernet.mac-address-blacklist:   --
802-3-ethernet.mtu:                     auto
802-3-ethernet.s390-subchannels:        --
802-3-ethernet.s390-nettype:            --
802-3-ethernet.s390-options:            --
802-3-ethernet.wake-on-lan:             default
802-3-ethernet.wake-on-lan-password:    --
ipv4.method:                            manual
ipv4.dns:                               192.168.1.1
ipv4.dns-search:                        --
ipv4.dns-options:                       --
ipv4.dns-priority:                      0
ipv4.addresses:                         192.168.1.2/24
ipv4.gateway:                           192.168.1.1
ipv4.routes:                            --
ipv4.route-metric:                      -1
ipv4.route-table:                       0 (unspec)
ipv4.routing-rules:                     --
ipv4.ignore-auto-routes:                no
ipv4.ignore-auto-dns:                   no
ipv4.dhcp-client-id:                    --
ipv4.dhcp-iaid:                         --
ipv4.dhcp-timeout:                      0 (default)
ipv4.dhcp-send-hostname:                yes
ipv4.dhcp-hostname:                     --
ipv4.dhcp-fqdn:                         --
ipv4.dhcp-hostname-flags:               0x0 (none)
ipv4.never-default:                     no
ipv4.may-fail:                          no
ipv4.dad-timeout:                       -1 (default)
ipv6.method:                            ignore
ipv6.dns:                               --
ipv6.dns-search:                        --
ipv6.dns-options:                       --
ipv6.dns-priority:                      0
ipv6.addresses:                         --
ipv6.gateway:                           --
ipv6.routes:                            --
ipv6.route-metric:                      -1
ipv6.route-table:                       0 (unspec)
ipv6.routing-rules:                     --
ipv6.ignore-auto-routes:                no
ipv6.ignore-auto-dns:                   no
ipv6.never-default:                     no
ipv6.may-fail:                          yes
ipv6.ip6-privacy:                       -1 (unknown)
ipv6.addr-gen-mode:                     stable-privacy
ipv6.ra-timeout:                        0 (default)
ipv6.dhcp-duid:                         --
ipv6.dhcp-iaid:                         --
ipv6.dhcp-timeout:                      0 (default)
ipv6.dhcp-send-hostname:                yes
ipv6.dhcp-hostname:                     --
ipv6.dhcp-hostname-flags:               0x0 (none)
ipv6.token:                             --
proxy.method:                           none
proxy.browser-only:                     no
proxy.pac-url:                          --
proxy.pac-script:                       --
GENERAL.NAME:                           Wired connection 1
GENERAL.UUID:                           c71e2d8f-69a3-374d-97a9-1b8b9e402b99
GENERAL.DEVICES:                        enp34s0
GENERAL.IP-IFACE:                       enp34s0
GENERAL.STATE:                          activated
GENERAL.DEFAULT:                        yes
GENERAL.DEFAULT6:                       no
GENERAL.SPEC-OBJECT:                    --
GENERAL.VPN:                            no
GENERAL.DBUS-PATH:                      /org/freedesktop/NetworkManager/ActiveConnection/9
GENERAL.CON-PATH:                       /org/freedesktop/NetworkManager/Settings/1
GENERAL.ZONE:                           --
GENERAL.MASTER-PATH:                    --
IP4.ADDRESS[1]:                         192.168.1.2/24
IP4.GATEWAY:                            192.168.1.1
IP4.ROUTE[1]:                           dst = 192.168.1.0/24, nh = 0.0.0.0, mt = 100
IP4.ROUTE[2]:                           dst = 0.0.0.0/0, nh = 192.168.1.1, mt = 100
IP4.DNS[1]:                             192.168.1.1
IP6.GATEWAY:                            --

Oh boy! You’ve really got a weird issue there. The only thing I can think of is:

Did you turn on MAC address randomization?

If that’s not it,

  • fix the network speed to 100Mbps FD or 1GBPS HD (Half Duplex, not High Definition) on the same tab in that order.

And then a last ditch effort:

  • Have I already told you to change the cable with a CAT6 shielded cable?

If even all of that doesn’t work, I’m throwing my hands in the air:

:man_shrugging:

There is no random MAC address. I’ve tried lowering connection speed, even to 10Mb/s Half and there is no change.

As I already mention, cable goes behind the floor and through the wall, so replacing it would infeasible.

Well I guess that’s it. Thanks for your help anyway, I’ve learned quite a lot here.

I have the same NIC (Realtek 8168) that generally works ok with r8169 driver (Asus motherboard)
but it would sometimes be slow to connect after boot, so i changed to kernel driver r8168

I know Linux users with the same NIC on Gigabyte motherboards where r8169 driver does not work at all and r8169 driver must be blacklisted to use the r8168 driver

suggest try changing to r8168 kernel driver in

manjaro-settings-manager -m msm_mhwd

enable option in bottom left corner - Show All Devices

Look in section Network controller > RTL8111/8168/8411 for network-r8168

Right click on network-r8168 and select Install

Manjaro Settings Manager should install r8168 driver for each kernel version on system and blacklist the r8169 driver

1 Like

I had the same problem. Installing the r8169 also gave a problem which I figured out.
Ethernet Device from (sudo inxi -basic):
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Samsung Co driver: r8169 v: kernel port: 3000 bus ID: 06:00.0
chip ID: 10ec:8168
I attempted to update the driver r8169aspm-dkms with Kernel 5.4.67-1-MANJARO. Constantly got a failed installation. Then I finally read the comments that were referenced to in the installation. “linux/pci-aspm.h” was missing. The kernel had something similar from my reading but with a different name. Further reading online I saw that using a newer Kernel (5.7.19-2-MANJARO) might have linux/pci-aspm.h there. The problem came back for me today so just updating the driver did not work for me. I have to read the warning messages more in the logs. I upgraded to 59 but it crashed the system. 58 could not find the files for installation.I have been reading things wrong. This time two (4.14 ,4.19 )kernels seemed to have installed the r8169 correctly . 44,54, and 57 did not. Two kernels installed without error. When I went to the build this time there was no build folder. Installing with the newer Kernel must have fixed the missing file problem. This r8169-aspm is not working right with the dkms. I have no idea what is wrong. I fixed one problem but the bad dkms interaction did not go away. Before this I don’t think I got the new one installed at all but now I do. I started my computer without r8169 so I have a wireless connection via usb dongles. This is the installer info:
Preparing…
Cloning r8169aspm-dkms build files…
Checking r8169aspm-dkms dependencies…
Warning: r8169aspm-dkms-v4.15.3-2 is up to date – reinstalling
Resolving dependencies…
Checking inter-conflicts…

Building r8169aspm-dkms…
==> Making package: r8169aspm-dkms v4.15.3-2 (Tue 20 Oct 2020 06:13:05 PM KST)
==> Checking runtime dependencies…
==> Checking buildtime dependencies…
==> Retrieving sources…
-> Updating r8169_aspm git repo…
Fetching origin
-> Found dkms.conf
-> Found blacklist-r8169-dkms.conf
==> Validating source files with sha256sums…
r8169_aspm … Skipped
dkms.conf … Passed
blacklist-r8169-dkms.conf … Passed
==> Removing existing $srcdir/ directory…
==> Extracting sources…
-> Creating working copy of r8169_aspm git repo…
Cloning into ‘r8169_aspm’…
done.
==> Entering fakeroot environment…
==> Starting package()…
==> Tidying install…
-> Removing libtool files…
-> Purging unwanted files…
-> Removing static library files…
-> Compressing man and info pages…
==> Checking for packaging issues…
==> Creating package “r8169aspm-dkms”…
-> Generating .PKGINFO file…
-> Generating .BUILDINFO file…
-> Generating .MTREE file…
-> Compressing package…
==> Leaving fakeroot environment.
==> Finished making: r8169aspm-dkms v4.15.3-2 (Tue 20 Oct 2020 06:13:08 PM KST)
==> Cleaning up…

Checking keyring…
Checking integrity…
Loading packages files…
Checking file conflicts…
Checking available disk space…
==> dkms remove --no-depmod -m r8169_aspm -v v4.15.3 -k 4.14.202-1-MANJARO
==> dkms remove --no-depmod -m r8169_aspm -v v4.15.3 -k 4.19.152-1-MANJARO
==> Unable to remove module r8169_aspm/v4.15.3 for kernel 5.7.19-2-MANJARO: Not found in dkms status output.
==> Unable to remove module r8169_aspm/v4.15.3 for kernel 4.4.240-1-MANJARO: Not found in dkms status output.
==> Unable to remove module r8169_aspm/v4.15.3 for kernel 5.4.72-1-MANJARO: Not found in dkms status output.
Reinstalling r8169aspm-dkms (v4.15.3-2)…
Running post-transaction hooks…
Arming ConditionNeedsUpdate…
Install DKMS modules
==> dkms install --no-depmod -m r8169_aspm -v v4.15.3 -k 5.7.19-2-MANJARO
Error! Bad return status for module build on kernel: 5.7.19-2-MANJARO (x86_64)
Error while configuring
Consult /var/lib/dkms/r8169_aspm/v4.15.3/build/make.log for more information.
==> Warning, dkms install --no-depmod -m r8169_aspm -v v4.15.3 -k 5.7.19-2-MANJARO' returned 10 ==> dkms install --no-depmod -m r8169_aspm -v v4.15.3 -k 4.4.240-1-MANJARO Error! Bad return status for module build on kernel: 4.4.240-1-MANJARO (x86_64) Error while configuring Consult /var/lib/dkms/r8169_aspm/v4.15.3/build/make.log for more information. ==> Warning, dkms install --no-depmod -m r8169_aspm -v v4.15.3 -k 4.4.240-1-MANJARO’ returned 10
==> dkms install --no-depmod -m r8169_aspm -v v4.15.3 -k 5.4.72-1-MANJARO
Error! Bad return status for module build on kernel: 5.4.72-1-MANJARO (x86_64)
Error while configuring
Consult /var/lib/dkms/r8169_aspm/v4.15.3/build/make.log for more information.
==> Warning, `dkms install --no-depmod -m r8169_aspm -v v4.15.3 -k 5.4.72-1-MANJARO’ returned 10
==> dkms install --no-depmod -m r8169_aspm -v v4.15.3 -k 4.14.202-1-MANJARO
==> dkms install --no-depmod -m r8169_aspm -v v4.15.3 -k 4.19.152-1-MANJARO
==> depmod 4.4.240-1-MANJARO
==> depmod 5.7.19-2-MANJARO
==> depmod 4.19.152-1-MANJARO
==> depmod 4.14.202-1-MANJARO
==> depmod 5.4.72-1-MANJARO
Transaction successfully finished.

$ modinfo -V r8169
kmod version 27
+XZ +ZLIB +LIBCRYPTO -EXPERIMENTAL (Experimental: I think the installer is a work in progress)

Same computer ran LinuxMint with no problems for years. Linux mint was painfully slow. The Linux kernels were all 4…
With Manjaro 2 of the 4. kernels seemed to install OK. None of the 5… Kernels installed without a problem I disconnected the cable from my Netgear N600 WiFi Range Extender. Put a WiFi dongle into my USB port and blocked the module r8169. No problems yet. When the module was active and failed it stopped the wifi in the Network manager also with no internet. I think the installer is not compatible with the kernels. I also think that the when the module r8169 fails it takes down the network manager with it preventing the use of Wifi.

Started Manjaro with Kernel 4.19.152-1-MANJARO. Went into hibernation. After getting things going again the Ethernet connection still was functional and the Network manager still was in the panel. I am really thinking that the driver setup problem is related to the setup file and the Kernel that is used for the setup.

Kernel 5.7 may be EOL but 5.8 caused too many problems on my computer along with a Nvidia driver update (problem connected???). It also made the 5.7 bad both Kernels with the problem with light display manager which eventually I corrected in 5.7.

1 Like

Unfortunately, Kernel 5.7 is EOL so…

I’ve tried r8168 driver and it did not appear to make a difference :frowning:

@ImConfused from what I see, r8169aspm is another driver? This one? AUR (en) - r8169aspm-dkms

It appears to be deprecated though: GitHub - KastB/r8169: Linux driver for Realtek network chips with enabled ASPM

The driver I was using was r8169aspm-dkms v 4.15.3-2. When I tried to use an r8168 it did not work for me. r8169 was the first one that was installed for my Manjaro setup. The r8169aspm-dkms v 4.15.3-2 did work on the kernel 4.19.152-1-MANJARO when I tested it. The Network manager was there after a long period of inactivity under the r8169aspm-dkms v 4.15.3-2 kernel. I just had to sign into my wifi connections again when it worked.The ethernet connection was still there.

My Asus motherboard worked with either version of driver for many years, until it started getting intermittent disconnection problems and I had to use r8186 (about 2 years ago)
But other users would have problems with r8168 driver and need r8169

Installing an r8168 driver from AUR is not enough to get r8169 driver replaced
Manjaro Settings Manager installs the driver matched to the Manjaro kernel
(eg Linux58-r8168 for kernel v5.8)
and linux58-headers
and also creates a file in /etc/modprobe.d/ to blacklist the r8169 driver

A user on old Manjaro forum created search tags for r8168 and r8169 because there were regular issues reported with these drivers

He even worked out commands to load and unload each driver so a user could test both drivers

Ethernet is not working any more (but Wi-Fi still works) - Networking - Manjaro Linux Forum

If the r8168 driver has been installed you can test either driver in this manner.

To test the r8168 driver:

sudo modprobe -r r8168 && sleep 3 && sudo modprobe r8168 && systemctl restart NetworkManager

To test the r8169 driver:

sudo modprobe -r r8168 && sleep 3 && sudo modprobe r8169 && systemctl restart NetworkManager
1 Like

I was having problems with my MSI tomahawk. Some times it didn’t had Network and other times only wifi, after applying the test for r8169 it detected and configured the Ethernet cable.

Thanks for this! :slight_smile: