Wine/Lutris Nvidia GPU Scaling problem on KDE

I have a couple of problems running old games on Lutris with Wine. When the resolution is lower than the desktop resolution it switches to that resolution without GPU scaling - I tried to fix that from the Nvidia X Server settings - didn’t work.
What’s worse - KDE doesn’t remember the position of my icons and every time the resolution changes I have to reorganize my desktop.

So now I’m stuck using Wine in virtual desktop mode whenever I want to play an old game. Works for some games which can scale to a high resolution but that’s not a good option in most cases because a lot of those games are not meant to be run on 1600x1200 and the text and gui is miniscule. I’d much prefer to run my games at 320x240 or 640x480 at full screen with scaling and hopefully not losing my desktop setup in the process…


Please share:
cat /etc/X11/mhwd.d/nvidia.conf
mhwd -li
inxi -Fazy


I should add that I did try to edit the nvidia.conf file by hand to force composition pipeline to be on. The setting is on according to the utility but it doesn’t do anything.

I don’t quite agree. In Section “Device” if you use that entry ForceCompositionPipeline=On is ok when you use a dynamic layout. See here Desktop Lag/Stuttering while gaming
Also note my opinion about using both Force and FullForce FPS went to drain after ugrading from 20 to 20.1

Also since you are on KDE Plasma, see what i mention about the and the additions to the nvidia.conf.

Remove it, you don’t need it and reinstall the proprietary driver. make sure you backup your config before that, then check to not have the wrong modules blacklisted I have to reinstall my GPU drivers after every reboot

OK. So I tried all of that and the result was I had to restore with timeshift through terminal because the sddm wouldn’t start.

Oh man, this might be a bit too late now, but I’ve faced similar issues on a previous distro with older wine version, but it was also Xfce.
In the end, all I had to do is that I had to have Compositor Enabled on the “Window Manager Tweaks” options menu, last tab.
Re-enabling the compositor back On makes full-screen and resolutions work properly again.

edit: I believe this could be added on future versions of Xfce, put a warning there saying “Disabling Compositor might cause problems on fullscreen apps or resolution settings not scaling up properly”
It’s such an easy fix :slight_smile: