I have to reinstall my GPU drivers after every reboot

I wasn’t aware i could do that!

But i actually can’t send the link ( pasting the whole thing tells me that there’s a link top)

It should be a single link. … or you cannot post that ?
It should be a very short link like " https://0x0.st/iEYo.txt "
If you cannot post real links … can you just give me the last section?
(in case above that would be “iEYo.txt”)

The last section is iEYs.txt

I figured as much.
You have dual-graphics.
The actual driver profile you want is


or 450.
To install you can do:

sudo mhwd -i pci video-hybrid-amd-nvidia-440xx-prime

Do my GPU would be used or my igpu then?

The way PRIME works is you would boot into the weaker card by default … when you want to use more power from the nvidia you use prime-run.

glxinfo | grep renderer
prime-run glxinfo | grep renderer

(and then there is also “reverse prime” meaning it does it the other way around … but needs extra set up)

If you only ever want to use the nvidia … then you would want to entirely disable the amd gfx … if you are lucky there will be a switch in the BIOS.

So using video-nvidia is always going to lead me to this issue ? Because i don’t really want my gpus to behave like that

I refer you again to the post above.
video-nvidia will not work on its own if you have also an amd card.
How do you want your gpus to behave? This is pretty normal …

I want my NVIDIA GPU to be used by default and not having to do that every time i boot

Then you need to disable the amd or use reverse prime.

Before you do the test as mentioned above, could you return from terminal:
mhwd -li

Since is a desktop pc the combination with prime-run is not quite ideal IMHO. Also in case you will want to attach more displays to each GPU, or possible to want to use the AMD GPU passthrough to a virtual machine … So, if you manually installed the nvidia drivers and the files i mentioned did not got created, then there might be something with mhwd as mentioned here:

That means, you will have to create also manually the file:
With this lines:



Do not create any custom /etc/X11/mhwd.d/nvidia.conf and also remove the /etc/X11/xorg.conf.d/90-mhwd.conf

If this gives you trouble, add nomodeset as kernel boot parameter and see if that helps and from there we might be able to help more.

I’m getting that error everytime i try to download drivers/updating…
e[1me[31m> e[mInstalling video-nvidia-450xx…
e[0;32mSourcing /etc/mhwd-x86_64.conf
e[me[0;32mHas lib32 support: true
e[me[0;32mSourcing /var/lib/mhwd/db/pci/graphic_drivers/nvidia-450xx/MHWDCONFIG
e[me[0;32mProcessing classid: 0300
e[me[0;32mSourcing /var/lib/mhwd/scripts/include/0300
e[me[0;32mProcessing classid: 0302
e[me[0;32m:: Synchronizing package databases…
e[me[0;32merror: failed to update core (unable to lock database)
e[me[0;32merror: failed to update extra (unable to lock database)
e[me[0;32merror: failed to update community (unable to lock database)
e[me[0;32merror: failed to update multilib (unable to lock database)
e[me[0;32merror: failed to synchronize all databases
e[me[0;32mError: pacman failed!
e[me[1me[31mError: e[mscript failed!

sudo rm /var/lib/pacman/db.lck
sudo pacman-mirrors -f && sudo pacman -Syyu
then run the mhwd command to install either the drivers i mentioned, or follow the advice kindly provided by @cscs (i have no experience with prime and dual GPUs)

I’m stuck at (6/6) Updating the desktops file MIME type cache... when trying to download any of the drivers…

Ok i did everything you said and i was able to boot with linux58 and the server x is working normally…
The thing is, i’m scared about having the same issue after rebooting

iEht.txt & iEhv.txt

The fact that the drivers are installed but not used is very weird… Actually i would have to reinstall these for the server x to work

Sorry to do this, but i’m uping this thread as i still don’t have any fixes…
I tried using linux54, won’t boot at all.
But i still have the same issue in any other versions

So, the proposed approach by @cscs didn’t worked and mine neither. How about if you backup your data and do a fresh install?
Have you tried removing completely the Nvidia drivers, reboot and set in BIOS that the AMD GPU is primary, even change the PCI port each GPU is connected, then once you have access to the desktop trough the AMD GPU install the Nvidia drivers and then only remove the configurations but keep the modules to load? Have you tried to append nomodestting at BOOT?

Ok, i think i will restart with a fresh install (i know it will fix it bc it already happend a few month ago)…
Is there any way i could keep my applications installed ?