Windows/super key not working


I upgraded my system yesterday to KDE Plasma 5.20.2, and today my Windows/super key does not work at all.

No shortcuts using the super key work and I have found nothing in the system logs.

I’ve tried several solutions I’ve found online but none have worked, like changing keyboard layouts, switching languages, rebooting, changing shortcut settings in Manjaro’s system settings, editing the kwinrc config file…

Any idea what to do? I’m completely lost :slight_smile:

Update 1: I plugged in another keyboard, and with that the super key works… Weird. I’ll check if the same problem exists in Windows too.

Update 2: The same problem persists in Windows 10. However, if I launch the Cooler Master Hub (or whatever it’s called, I have the Cooler Master Masterkeys Pro S), then suddenly the Windows key work again. The second I close that program the Windows key stops working… This issue has never happened before. Is it a driver issue maybe?

Ok I figured it out. I’m officially dumb ;D

I had accidentally activated the “Windows Lock” on my keyboard. Deactivating it and using this solution solved the issue.

Marking thread as solved.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.