KDE Application launcher doesn't open when Meta key is pressed

I did set the keybind to alt+f1

I do have the launcher on the panel, yes.

I think i’ve found the problem: it doesn’t activate when the widget is placed on a application menu bar panel. Otherwise, it works fine.

Maybe: Bug 391322 - Meta key randomly stops opening Plasma launcher menu

Or

I can’t bind the Meta key to open the Application Launcher anymore!
There is one sentence at the above link, which has another link (“this section”). I posted a snipped from “this section”.

If it’s not working, make sure your “Start Menu” widget has a global shortcut like Alt+F1 set (you can’t assign it directly to Meta, but it will open with Meta if another shortcut is assigned).

This issue appears multiple times at forum.kde.org.

1 Like

Yes, I’ve set it to alt+f1

There was more at that link… which was similar to the work around in the bug report (comment 23).

Putting them together:

.config/kwinrc

[ModifierOnlyShortcuts]
Meta=org.kde.plasmashell,/PlasmaShell,org.kde.PlasmaShell,activateLauncherMenu

qdbus org.kde.KWin /KWin reconfigure

If you have qdbusviewer installed you can follow the path to the method:
org.kde.plasmashell > PlasmaShell > org.kde.PlasmaShell > activateLauncherMenu
If you double click the method it will open the launcher. This is just an educational or verification step.

I do not have this problem, but KDE isn’t my main machine anymore. I looked in my kwinrc and didn’t have a ModifierOnlyShortcuts section, but I added it anyway along with the next line and restarted kwin. The Meta key still worked, and I didn’t appear to break anything :slight_smile: I am using the Application Menu, but changed it to the alternative, Application Launcher and the Meta key worked there too. I set Meta= nothing, to confirm I could unassign it and that worked too. Absent any other fix, this is one option to potentially try.

2 Likes

Mine doesn’t have it either, but I am using the Plasma Dashboard as my application launcher. It opens on pressing either Meta or Alt+F1.

I tried Meta= and Meta=org... with the Plasma Dashboard and got the expected results. I have 3 alternative start menus (Application Dashboard, Application Launcher, and Application Menu). and tried with each. At most I can say it shouldn’t break anything and it might make the Meta key work based on the bug report and the Plasma/Tips. Defintely watch the above bug.

Same for me. Assigning Alt+F1 also enabled the Meta key again.

6 Likes

This didn’t work for me

Does it still work for you if you put the application launcher widget on a application menu bar panel?

I was also having same problem after a testing update, but I also installed plasma wayland session to try it on the side, don’t know it has any correlation to it. But for me it worked only after removing the widgets from panel, adding again and manually applying Alt+F1 shortcut to it. (Using X11 session currently).

Also I noticed under system settings > shortcuts ‘Activate Application Launcher Widget’ is listed 4 times though I have the widget only twice on panels on two different monitors.

An application menu bar, as you call it, is really nothing other than an empty panel with the global menu widget already on it. But that is not how I set things up on my end. I simply moved the original panel from the bottom to the top, made it thinner, removed the task bar widget, and added the global menu widget (and a few other widgets).

It’s the exact same thing, really. The option to add an application menu bar is simply a shortcut that the KDE folks provided for people who don’t want to do all of this manually. It’s just a standard panel.

And yes, last time I did it as you describe, it worked. But that was a long time ago and on another machine. On this machine here I set things up as I explained above, and I’m not going to mess with that, because it works perfectly and just the way I want it. :wink:

The same here.

I had the same issue suddenly noticed today. I had to mess around/reboot a lot. I didn’t even have Meta + … input registering when trying to assign shortcuts. Then after removing all shortcuts (yeah, one guy said he had four, I had two application launcher configurable shortcut + the one in the actual application launcher for whatever reason), changing keyboard to another one and back to generic 105 keys, I had Meta key registering again so I add Alt+F1 shortcut to the application launcher settings, then in System Settings->Shortcuts->Application launcher I change the first one to Alt+F1 too and it started working again…

Another KDE special treat lol

4 Likes

Interesting thread, thought it was just me - the Super keys haven’t launched the menu for some time now (don’t know kow long. I didn’t notice until recently). I’ll try the suggestions in this thread & see if it fixes it.

N.B. I had the panels crash some time back; maybe this is something to do with it. I just replaced them.

What finally worked for me was this one terminal command from userbase.kde.org that stargazer linked to; Plasma/Tips - KDE UserBase Wiki

kwriteconfig5 --file ~/.config/kwinrc --group ModifierOnlyShortcuts --key Meta "org.kde.plasmashell,/PlasmaShell,org.kde.PlasmaShell,activateLauncherMenu"
qdbus org.kde.KWin /KWin reconfigure

After I ran that command, it instantly started working again. Prior to this, no amount of rebinding to ALT+F1, or removing and re-adding the actual Launcher widget, would get it to work. And prior to that, I most certainly didn’t change any shortcuts. This problem started happening out of the blue as far as I could tell.

3 Likes

can you solve this problem???

Hi - I’m new to Manjaro and was experiencing this annoyance. I tried various fixes in this thread, but none of them worked for me. However, I think I’ve found out my issue. I’ve been switching between different themes since it’s a new install. I noticed that this is related to why my Meta key isn’t mapped to open the Application Launcher. Let me explain.

As I’m new to Manjaro, I don’t know the underlying theming mechanisms, but from what I understand is that you’re able to add numerous Application Launcher Widgets to a Panel. As such, each Application Launcher Widget is unique and has their own internal configuration, including keyboard shortcuts, which I assume this all boils up to a desktop layout configuration somewhere.

Now, by out of the box, Manjaro had mapped the Meta key to the ALW and in my case, that mapping mysteriously stopped working. My hypothesis for this is that as I changed themes and selected Use desktop layout from theme, the stock Manjaro configurations (including the mapped Meta key to ALW) was effectively overwritten. The culprit seems to be Use desktop layout from theme option. I’m not blaming that option, because that’s probably its expected behavior.

My solution:

  • Select the theme I’d like to use
  • Right-click the panel → Edit Panel
  • Hover over the Application Launcher Widget → ConfigureKeyboard Shortcuts
  • Add the Meta (Windows) key (I had to use Meta-F1, since it requires 2+ key combination`)
  • Escape out of editing the panel
  • Press Meta key and test if it opens up

From this point on, you’ll want to remember to not select Use desktop layout from theme or else your mapping will be gone when you switch themes, unless the theme provides that mapping by default (is that even possible?).

6 Likes

Yes, it’s annoying and it was fixed (and works with a new account).

However, before it was ‘fixed’ you could use ksuperkey.

The good news is - it still works.

pamac install ksuperkey
Reset the shortcut to Alt+F1
Set ksuperkey in autostart.
Log off.

The other way to manage it, and I use this for umenu which I’m testing this week, is to use Ctrl+z for menu…

Also remember Krunner - zero shortcuts for that if you’re on desktop (just type and it comes up). Sometimes I forget and open the menu - and wonder why I wasted all that time hitting the Meta key :rofl: