Window Manager Not working anymore: Completely unusable OS

The measures one has to take to reset an Xfce session to the default it came with are more severe than I thought.
Just removing and then replacing the files and directories with defaults will not do.
Logging out of the session and doing it from TTY will not do.
Killing the settings daemon beforehand and logging out and back in afterwards also won’t do.
Restarting the display manager also won’t do.

It has to be a reboot.
I have to admit - this is strange.

save your work
open a terminal
and run these commands:

rm -rf ~/.config/xfce4
cp -r /etc/skel/.config/xfce4 ~/.config

the first removes the whole xfce configuration folder and everything in it
the second then copies the default values to that place which was just removed
third is the reboot

imgur com/nQn6QMX.png, This is much worse, now my options don’t open, my monitor is on the right instead of on the left, it has the wrong resolution. Jeez.
It seems that what you did was resetting my WM, but i am pretty sure i have none.

Just to be sure that indeed nothing is missing, reinstall the whole of xfce
sudo pacman -S xfce4

I didn’t do anything - you did.
I described every thing in detail.
Just two commands: to remove the current config and replace it with the default one.
Noting more happened.
This - if you did it correctly, gives you the Desktop as you saw it right after installation.
Of course all your custom config is gone - and I told you this.

Anyway - it appears that you do have a dock running - or is that an extra panel?
It is possible that this interferes with things.

What happens if you create a new user (a test user) and log into that account?
Does the desktop work there?

the resolution is very easy to fix/adjust
I have no idea what you mean by “my monitor is on the right”.

In the screenshot, my second monitor (the one with Discord open) is on the right, while it actually is on my left, no big deal, also yes i meant what you sent not what you did,I have tried reinstalling xfce, but even if i have plenty of space (10GB), and the download is 1.6GB, it will still fail at the end for not enough space, and fill my drive, until i clean up everything (gist github com/rumansaleem/083187292632f5a7cbb4beee82fa5031)

sudo pacman -S xfce4
[sudo] Passwort für nachlese: 
:: There are 15 members in group xfce4:
:: Repositorium extra
   1) exo  2) garcon  3) thunar  4) thunar-volman  5) tumbler  6) xfce4-appfinder  7) xfce4-panel  8) xfce4-power-manager  9) xfce4-session  10) xfce4-settings
   11) xfce4-terminal  12) xfconf  13) xfdesktop  14) xfwm4  15) xfwm4-themes

That amounts to less than 25 MB - and you should still have it in cache.

How did you try to reinstall Xfce to have such a huge download size?
Perhaps that is the pending system update - that you should do.

Sorry, i got things a little mixed up, i was trying to install lightdm, not xfce (i installed xfce now btw) and it did that

to fix your resolution and probably your monitors, too:

in a terminal
if you can’t open it via a menu
go to “Display” …

If it’s not too late, what happens when you run:

xfwm4 --replace
1 Like

How??? It’s literally working, thanks so much!

1 Like

Well, I boot in tty now… The only thing I think could’ve done anything about this was earlier in the day when I uninstalled and reinstalled lightdm, although the reinstall didn’t go through smoothly, it was working though

Wahh, why did you uninstall lightdm ! The issue is that it may have uninstalled dependencies shared with other Xfce components…

Anyhow, try:

sudo rm .Xauthority
sudo rm .ICEauthority
sudo rm .xsession-errors*
rm -rf ~/.cache/sessions/*
sudo reboot

If insufficient, try:

rm -fr ~/.cache

No sudo with the rm commands !

systemctl status lightdm.service
it should say: Active: active (running)

systemctl status lightdm.service 
● lightdm.service - Light Display Manager
     Loaded: loaded (/usr/lib/systemd/system/lightdm.service; enabled; vendor preset: disabled)
     Active: active (running) since Thu 2021-02-18 18:23:38 UTC; 1 day 14h ago
       Docs: man:lightdm(1)
   Main PID: 703 (lightdm)
      Tasks: 14 (limit: 9387)
     Memory: 106.5M
     CGroup: /system.slice/lightdm.service
             ├─703 /usr/bin/lightdm
             └─736 /usr/lib/Xorg :0 -seat seat0 -auth /run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch

You deinstalled it and installed it again?
Then you probably need to start and enable the service again.

systemctl enable lightdm.service
systemctl start lightdm.service

xfwm4 --replace
that was clever and a good find - it was a long time ago that I saw something like this and did not remember that it was caused by the window manager not running for some reason

LightDM is not your window manager!!! it is the display manager.
Your window manager is xfwm4 by default.
A simple xfwm4 --replace restarts it as mentioned above.

And please provide information as per the following (makes it easier for other members):

Also maybe some information here could help with troubleshooting your game.

@nam1962 what does that do? Also lightdm is gone, I don’t even think I have enough disk space to reinstall it… Oof

It turns out I do, doing it!

So i have done all you said, except for that removing thing because i didnt understand what it did
Now my desktop is back, it also seems to work after i reboot, granted i xfwm4 --replace every time on boot, which is a pain, although, (please don’t rage on me if i get the definition of desktop manager wrong) but i think its not there, i.imgur com/fHmjZbj.jpg, this is my main screen right now for some reason and the ability to right click and get the context menu on the desktop is gone, it has been for a while (since i’ve had this whole problem)

Do the rm thing :wink: (It’ll remove stored sessions on which the system starts again.)

Did you apply @Nachlese instructions ? (you should have)

i will, and yes

I just had the same thing happen to a clients computer, and theyre not the type to be poking around and changing dot files or GUI configurators. I did try the suggestion of restoring from /etc/skel/ but that and a reboot didnt seem to help. What /did/ eventually fix it was removing a saved session from the xfce4-session manager application. I think what was happening in my case was a session had xfdesktop or or something xfwm maybe, that wasnt starteds but it thought it was. ==yay -S xfce4== mostly offered reinstalls in this case as well.

Not sure how xfce4 sessions work but clearing it was a matter of xfce4-settings-manager > Session & Startup > Saved Sessions > Select any existing Sessions > Clear Saved Sessions.

I’m not sure any of that will be relevant to you, so good luck :slight_smile:

1 Like