Window Manager Not working anymore: Completely unusable OS

imgur com/OM9dOiw.png This is what i am currently seeing, no borders around windows, no background, some xfce related apps straight don’t work, like the Window Manager in the options, it just hangs there after you click it and doesn’t do anything.
Basically anything else works, i can play games fine, i can listen to audio… etc.
If i don’t open something, i have no cursor, once i open something, in this case discord, i got an X cursor (as seen in the screenshot), a friend of mine told me it something related to Xorg? i have no idea.

1 Like

… do you know what you did to get there?
(that doesn’t just happen ™ by itself)
probably not :wink:
The window decorations seem to be missing.
It could be a theme issue - try to change that.
If you can’t make them reappear by looking through “Appearance” and “Window-Manager” settings in xfxe4-settings-manager
then there is always the possibility to reset to default
which is a terminal job
I could describe it if you want to go that route.

So what i did yesterday, was literally installing Garry’s Mod on Steam, literally!, i have terrible internet so i left it to do its thing all day pretty much.
Trying to open that just doesn’t do nothing, i click it and it runs the little loading animation on my cursor for ever.
A friend tried helping me troubleshoot this.
It seems that i have no window manager installed that my system can recognize, even after completely uninstalling LightDM, and reinstalling it (making sure to enable it as a service) it wouldn’t work. No its not a theme issue, yes i’d like to reset it

this doesn’t make much sense
not to me anyways

you downloaded … something

Garry’s Mod on Steam


and suddenly your settings changed?

… hard to follow/believe

What may be very important here is:
what is

“Garry’s Mod on Steam”

and what did you do with it?
(what does “clicking on it” actually do?)

it may be far easier to just return to defaults for your Desktop Environment than to solve what happened here because of “clicking on something just downloaded from … somewhere”

something was apparently messed up - and this is the only culprit as of now
Is it worth investigating it?
I’d say yes.

But it is your system … not mine.

Honestly, i think it would be somethingn that happened before, the only weird thing i remember from yesterday was that right whenn i was shutting down my pc i saw all my icons on my desktop move to my second screen, also garry’s mod is a video game and steam is where you get that game, it is even preinstalled in your system, unless you removed it.
Clicking on it (if i could) would just open it.
Anything i can do i will to fix this.

Have you a 2nd monitor connected?

what that actually is … could help
(apparently you know
I don’t
most of all the others also likely don’t)
not everyone reading this is a gamer - who presumably would know …

As I said before
resetting to defaults is not very difficult
can be done several ways

if you want to do that
… that’s fine - with me …
instead of investigating what messed up your system
(as of now, we only have “Garry’s Mod” as a possible culprit)

but, then again, you don’t think that was the cause

you wanna investigate
you wanna restore?

Yes, i have a second monitor

Garry’s Mod is a Linux Native Sandbox game, that has nothing to do with this as i didn’t even run it, nor install it yet, it is only downloaded.
Again, this isn’t the first time stuff like this happened, When i installed manjaro, it took so long that then i just went to bed, the next day it would boot loop, it never happened since but its a weird trend with me and linux to break randomly.
Would restoring work? Honestly if it just does i dont really care about finding what did it, unless it can happen again.


why even mention it to people who want to,
and who you asked to,
to assist in troubleshooting? …

What do you want?

Do you want to fix your issue?
You want help?
… because you don’t know how by yourself?

Or do you want to rant?

I already suggested some ways.
and that resetting to defaults is rather easy as well …

What do you mean why mention it? I asked a friend whose been using Manjaro for years, they’ve linked me this forum, i just want it fix, i am not ranting, I have no idea what you mean by resetting to defaults and i would like to know

Because it is a distraction from the cause of the issue.

Did you try to look at:
“Appearance” and “Window-Manager” settings in xfxe4-settings-manager

Do you want to reset to defaults?
(the current defaults)
which are all in

Yes i would like to reset to defaults, by going into Appearance and changing themes, nothing happens but my firefox changing themes accordingly.
If i open Window-Manager it hangs there with the loading animation and does nothing

The measures one has to take to reset an Xfce session to the default it came with are more severe than I thought.
Just removing and then replacing the files and directories with defaults will not do.
Logging out of the session and doing it from TTY will not do.
Killing the settings daemon beforehand and logging out and back in afterwards also won’t do.
Restarting the display manager also won’t do.

It has to be a reboot.
I have to admit - this is strange.

save your work
open a terminal
and run these commands:

rm -rf ~/.config/xfce4
cp -r /etc/skel/.config/xfce4 ~/.config

the first removes the whole xfce configuration folder and everything in it
the second then copies the default values to that place which was just removed
third is the reboot

imgur com/nQn6QMX.png, This is much worse, now my options don’t open, my monitor is on the right instead of on the left, it has the wrong resolution. Jeez.
It seems that what you did was resetting my WM, but i am pretty sure i have none.

Just to be sure that indeed nothing is missing, reinstall the whole of xfce
sudo pacman -S xfce4

I didn’t do anything - you did.
I described every thing in detail.
Just two commands: to remove the current config and replace it with the default one.
Noting more happened.
This - if you did it correctly, gives you the Desktop as you saw it right after installation.
Of course all your custom config is gone - and I told you this.

Anyway - it appears that you do have a dock running - or is that an extra panel?
It is possible that this interferes with things.

What happens if you create a new user (a test user) and log into that account?
Does the desktop work there?

the resolution is very easy to fix/adjust
I have no idea what you mean by “my monitor is on the right”.

In the screenshot, my second monitor (the one with Discord open) is on the right, while it actually is on my left, no big deal, also yes i meant what you sent not what you did,I have tried reinstalling xfce, but even if i have plenty of space (10GB), and the download is 1.6GB, it will still fail at the end for not enough space, and fill my drive, until i clean up everything (gist github com/rumansaleem/083187292632f5a7cbb4beee82fa5031)

sudo pacman -S xfce4
[sudo] Passwort für nachlese: 
:: There are 15 members in group xfce4:
:: Repositorium extra
   1) exo  2) garcon  3) thunar  4) thunar-volman  5) tumbler  6) xfce4-appfinder  7) xfce4-panel  8) xfce4-power-manager  9) xfce4-session  10) xfce4-settings
   11) xfce4-terminal  12) xfconf  13) xfdesktop  14) xfwm4  15) xfwm4-themes

That amounts to less than 25 MB - and you should still have it in cache.

How did you try to reinstall Xfce to have such a huge download size?
Perhaps that is the pending system update - that you should do.

Sorry, i got things a little mixed up, i was trying to install lightdm, not xfce (i installed xfce now btw) and it did that

to fix your resolution and probably your monitors, too:

in a terminal
if you can’t open it via a menu
go to “Display” …