Wifi options available on Windows, not Linux

I currently Dual-boot Windows and Manjaro and keep having this issue.
Before Manjaro, I used Mint and had the same problem.

Wifi options are almost never available but might show up after a restart, however, they will disappear again after another restart and its only by luck that they ever show up again after more restarts. On my Windows partition, I don’t seem to ever have this issue.

I tried getting help to fix it a while back when I was using Mint, but it never worked out

Kernel: 5.15.28-1-MANJARO x86_64 Up: 11m Mem: 2611.2/7826.1 MiB (33.4%)
Storage: 465.76 GiB (5.0% used) Procs: 212 Shell: Zsh inxi: 3.3.13

Welcome to Manjaro! :smiling_face_with_three_hearts:

  1. Please read the information behind this link. It will help you to post necessary information. [HowTo] Provide System Information
  2. Please press the three dots below your post and then press the :pencil2:
  • If you give us information about your system, we can see what we’re talking about and make better suggestions.
  1. You can do this by using inxi in a terminal or in console.
inxi --admin --verbosity=7 --filter --no-host --width
  • Personally identifiable information such as serial numbers and MAC addresses are filtered out by this command
  • Presenting the information in this way allows everyone to be familiar with the format and quickly find the items they need without missing anything.
  1. Copy the output from inxi (including the command) and paste it into your post.
  • To make it more readable, add 3 backticks ``` on an extra line before and after the pasted text.

Check what model you have, you may need to install a driver: