Wifi is very slow despite good connection

When my iphone is connected to the same network, I’m getting 76.51 Mbps with a 15 Ping and low latency, that’s on my slow network as Manjaro won’t see my faster 5Ghz network. However, on Manjaro Gnome, I’m at 6.22Mbps, 95 Ping with an extraordinarily high latency. This is not a machine problem. I’m on a 2013 early MB Pro Retina, 15", 16GB, 2.7 i7, 1TB SSD, and I see the same speeds as on my iphone on my slower network and on the unseen (on Manjaro) 5Ghz network, I see 500+ Mbps. It doesn’t seem to make a difference whether or not I’m on battery or AC power.

Device-1: Broadcom NetXtreme BCM57786 Gigabit Ethernet PCIe driver: N/A
port: 2000 bus ID: 03:00.0 chip ID: 14e4:16a3 class ID: 0200
Device-2: Broadcom BCM4331 802.11a/b/g/n vendor: Apple AirPort Extreme
driver: bcma-pci-bridge v: N/A modules: bcma port: 2000 bus ID: 04:00.0
chip ID: 14e4:4331 class ID: 0280

It seems you’re using WiFi to connect to your laptop. Try porting an ethernet connection(with the LAN port to your router). That should give you the same( usually even more) speed than your phone.

1 Like

Yeah, I think you’re missing my point or I’m not explaining it very well. Yes, I am using Wifi to connect to my laptop. Yes, that is the problem that I’m getting very slow speeds when connecting via Wifi. I used my phone to show you that the speeds I should be getting but am not.

1 Like

Have you installed the correct drivers? Looks like you need broadcom-wl


Is there a driver available when you go the Manjaro Settings → Hardware and is it installed?

I have the video-linux open source driver for my GK107M (GeForce GT 650M Mac Edition) and the video-linux open source driver for my 3rd Gen Core processor Graphics Controller (Intel Corporation). the video-modesetting and video-vesa show as not installed. I’m hesitant to try them as I’m concerned about never again booting into my desktop as I know the linux GUI to be extremely fragile.

However, if you are asking about Show all devices, under Network Controller nothing shows as installed, but nothing shows as an option to be installed. There are no boxes to be clicked to install anything related to those 4 items listed.
NetXtreme BCM57786 Gigabit Ethernet PCIe (Broadcom)
NetXtreme BCM57761 Gigabit Ethernet PCIe (Broadcom)
BCM4331 802.11a/b/g/n (Broadcom)
NetXtreme BCM57761 Gigabit Ethernet PCIe (Broadcom)

They are all for graphics cards, there should be a separate section for Network Controllers.

Alternatively, open pamac and search for broadcom-wl, then install the correct driver for your kernel version.

Obviously I was not talking about video drivers :expressionless:

If you have no NETWORK driver there then don’t install anything from there.

See my edit that I added to the last question above for the network cards.
Meanwhile, I tried that and it turned off my wifi completely and affected my ability to restart my machine with hangups booting back into the GUI. I had to uninstall and I have wifi back. But still very slow and not seeing my 5ghz network.

I’m also seeing something similiar posted in '19 here but while it says solved, I see no solution. Following the link, I type in “mhwd -li” but I only see that my video-linux is installed. No reference to a network driver and it also says “Warning: No installed USB configs!”:

Here’s a better link to the solution, but it’s from 2018 and posted by tbg. I don’t think that it’s accurate enough 3 years later to use his solution:

Maybe your WIFI and your card can’t work with the current settings at the speed you expect.

What is exactly the type of WIFI you have?
What does you card support?

Other devices having better speed can simply be normal if your hardware is different.

I don’t think you read what I wrote above. On my Mac, running OSX I get the speeds I expect. Running Manjaro, the wifi speeds are quite poor. So same hardware, different OS’s, different results in wifi speeds. The problem is listed above and has been known about since '18 see the forums I posted. But then the problem was the adapter identifying as either:

Kernel driver in use: bcma-pci-bridge
Kernel modules: bcma

Kernel driver in use: b43-pci-bridge
Kernel modules: ssb

From what I have been able to ascertain with my very limited knowledge is that this is not my problem. I don’t see either of those kernels being used. However, installing broadcom-wl doesn’t fix the problem either and in fact shuts down wifi. So something is interfering with the broadcom-wl driver.

Maybe you didn’t install properly the driver then?

PS: I don’t see any mention of you using the same machine on a different OS. I saw you claimed it was not a machine problem but you didn’t make that clear.

My apologies, I mentioned the MB Pro and that I see the speeds that i expect and that it’s not a machine problem, but I failed to mention that the fast speeds are seen when running Mac OSX. I don’t know if I didn’t install the drivers properly. I’m not an engineer, I’m a RE Broker and a Mortgage Lender and I’m just trying to get away from Apple without having to learn how to program a computer. The previous person mentioned to install broadcom-wl through pamac, which I did.

Not sure why the driver wouldn’t install properly, you could try installing broadcom-wl-dkms instead

Same thing as before. The installation disables wifi and prevents it from coming out of airplane mode. Plus it affects my bootup the first time. Both times after installing the driver you gave me the computer hangs the first time I try to reboot after installing. I have to turn it off and start again, wherein it starts and wifi is disabled.

I think you both are failing to realize that there is a driver already installed and this broadcom driver is conflicting with that. However, I do not know how to find what that current driver is as the instructions to find that in the '18 resolution doesn’t provide me with any answers.

To list the current driver use inxi -N

For example mine shows:
Device-2: Qualcomm Atheros AR9227 Wireless Network Adapter driver: ath9k

There is some discussion about changing from bcma to wl drivers here:

  Device-1: Broadcom NetXtreme BCM57786 Gigabit Ethernet PCIe driver: N/A 
  Device-2: Broadcom BCM4331 802.11a/b/g/n driver: bcma-pci-bridge 
  Device-3: Broadcom NetXtreme BCM57761 Gigabit Ethernet PCIe driver: tg3 
  Device-4: Broadcom NetXtreme BCM57761 Gigabit Ethernet PCIe driver: tg3

Ah, so it is the problematic driver

So the question is how do I remove it. The closest I see is in the link you provided but his driver set was slightly different from mine so I don’t know that I should do exactly as they told him to do, besides, he said he had an error message when trying to uninstall that driver using that method.

03:00.1 SD Host controller [0805]: Broadcom Inc. and subsidiaries BCM57765/57785 SDXC/MMC Card Reader [14e4:16bc] (rev 10) (prog-if 01)
Subsystem: Broadcom Inc. and subsidiaries Device [14e4:96bc]
Flags: bus master, fast devsel, latency 0, IRQ 17
Memory at c1820000 (64-bit, prefetchable) [size=64K]
Capabilities: <access denied>
Kernel driver in use: sdhci-pci
Kernel modules: sdhci_pci