WIFI Disabled after waking up my Laptop

Hi, i’m using dual boot with windows, and i`m having the problem that wifi is disabled after woke up from Sleep Mode (not having the problem after hibernation) in windows it works perfectly.
I have reed many posts here but non of theme actually solve my problem.
If any one have an idea of what could be causing the problem would be very helpful.

plasmashell 5.24.6
Manjaro 21.3.7

Thanks

when did it started to happen?
was it working properly?
try with different kernels
is fast startup disabled in windows?
and provide system info:
inxi -Faz

It start happening as soon as i star using manjaro a few weeks ago.

Im not really sure how to try different kernels. :neutral_face:

Yes, fast startup is already disabled.


inxi -Faz

System:
Kernel: 5.15.60-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.1.1
parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
root=UUID=81e6cfa7-8060-4d99-80d0-3f7a5dd0ab6a rw quiet
resume=UUID=78216305-e2a2-4f96-b482-fdf842074ec4 udev.log_priority=3
Desktop: KDE Plasma v: 5.24.6 tk: Qt v: 5.15.5 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Manjaro Linux base: Arch Linux

Network:
Device-1: Intel Cannon Lake PCH CNVi WiFi driver: iwlwifi v: kernel
bus-ID: 00:14.3 chip-ID: 8086:a370 class-ID: 0280
IF: wlo1 state: up mac:
Device-2: Qualcomm Atheros QCA8171 Gigabit Ethernet
vendor: Micro-Star MSI driver: alx v: kernel pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 port: 3000 bus-ID: 3d:00.0 chip-ID: 1969:10a1 class-ID: 0200
IF: enp61s0 state: down mac:
IF-ID-1: ipv6leakintrf0 state: unknown speed: N/A duplex: N/A
mac:
IF-ID-2: proton0 state: unknown speed: 10 Mbps duplex: full mac: N/A

Swap:
Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
ID-1: swap-1 type: partition size: 6.43 GiB used: 324.1 MiB (4.9%)
priority: -2 dev: /dev/nvme1n1p4 maj-min: 259:5

edit your post and use formating: click this icon in editor:</> and copy the whole output there from the inxi -Faz command…
go to system settings/kernel and install the 5.19.1-3, reboot and select it in the grub menu/advanced options during booting

Hi, sorry i had no time to do it yet, i will try and let you know if it works.

Thanks …

I did change the kernel but it continue having the same issue, after wake up from sleep mode wifi doest work, the only way to have internet is using an ethernet cable or reboot the system.

try disable powersave on your wifi:
create this file:
kate /etc/modprobe.d/wifi.conf
and put there this line:
options iwlwifi power_save=0
save it and run this:
sudo mkinitcpio -P
reboot and then test

I did it, But still with the same problem. :frowning_face:
Also tried some config on TLP but nothing…

Really don’t know what could be, i also read many related articles but nothing seems to help.

is it a lenove laptop?

msi p65

it is funny, you are the only one who answers, and and you’re still here… Thanks

did some googling and you are not the only one that has issues with this wifi model;
the solutions were -
1.removing the card from the notebook and plugging it back again helped
2.change some power related settings in bios

1 Like

Sh…t i thought that could be a general problem.
Ok, ill try the bios setting first, if nothing happens will continue with the first option.

Thank you !!