Wifi Connection Shows device not ready, tried everything please help!

In wifi networks, it always shows device not ready, I have tried 100 different things suggested on internet, nothing has changed, please help. I am ready to post as many output you want.

Output of nmcli:

eno1: connected to WiredConnection
        "Realtek RTL8111/8168/8411"
        ethernet (r8168), 46:22:5E:B4:7C:86, hw, mtu 1500
        ip4 default, ip6 default
        route4 metric 100
        route4 default via metric 20100
        inet6 fe80::8196:9390:b4c6:772c/64
        route6 fe80::/64 metric 1024
        route6 default via fe80::76da:daff:feaa:b262 metric 20100

wlp0s20f0u2: unavailable
        "TP-Link TL-WN722N v2/v3"
        wifi (r8188eu), B0:A7:B9:58:25:CF, hw, mtu 1500

lo: unmanaged
        loopback (unknown), 00:00:00:00:00:00, sw, mtu 65536

DNS configuration:


        interface: eno1

Use "nmcli device show" to get complete information about known devices and
"nmcli connection show" to get an overview on active connection profiles.

Consult nmcli(1) and nmcli-examples(7) manual pages for complete usage details.

Hi @alan5420,

After some looking around, it seems like a possible cause is an orphaned package. No, I don’t know how or why. Remove all orphans with:

pamac remove --orphans

Don’t know if it will, but I hope it helps!


If it’s still faulty, I don’t know what else. But someone might, so please provide the required information afterwards.

1 Like


There might be hints:

journalctl --boot 0 --unit NetworkManager --no-pager
journalctl --boot 0 --dmesg --no-pager

:notebook: Only one network manager can run at once. maybe you installed another one?

1 Like

Thank You!!
But now I got a new problem, when I am using my organizations wifi, it doesnt connect to internet, shows ERR_NAME_NOT_RESOLVED, I tried configuring changing DNS Servers, but nothing happens, when I had done the same thing on windows 10, it worked.

It sounds like a gateway issue. The only thing I can recommend is that you ensure the correct gateway is in use.

Seeing as it works with your personal Wifi, compare the settings with the organization’s. To do so, run:

ip a


ip route list

When connected to the personal Wifi and to the organization’s Wifi. Compare those two.

If you need assistance, open a new thread, since this one is solved.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.