Wifi adapter RTL8821CE and black screen after reboot

Hi …

I have a HP 255G7 with the WLAN module: RTL8821CE.

The following problem occurs. I am installing the rtl8821ce-dkms package together with the headers for Kernel 5.8.

  1. sudo pacman -S linux58-headers
  2. yay -S rtl8821ce-dkms

This goes so far without any problems :slight_smile:

But after a restart my screen remains black. The system won’t start anymore, no matter how often I try.

I am new to the Linux world and have no idea what I can do.

I have already reinstalled Manjaro twice and am now looking for help in the forum.

Thanks a lot

1 Like

have tried the other package in the meantime: rtl8821ce-dkms-git. Still without success …

I can still access the tty and log in. The journalctl says something about:

lightdm.service: Failed with result and failed to start Light Display Manager.

I still don’t understand why the “Light Display Manager” doesn’t work after installing the rtl8821ce-dkms-git package …

Does anyone have an idea what I can do now? Reinstall again and simply using Ethernet is not a solution …

Have checked systemctl

systemctl --failed

lightdm.service loaded failed failed
systemd-backlight@backlight:acpi_video0.service loaded failed failed
systemd-backlight@backlight:amdgpu_b10.service loaded failed failed

A solution for everyone with the same problem on XFCE and HP255G7/RCRTL8821ce:

  1. Install manjaro-xfce-20.1.1-201001-linux58
  2. sudo pacman -Syu
  3. sudo pacman -S base-devel
  4. sudo pacman -S linux58-headers
  5. yay -S rtl8821ce-dkms-git
  6. sudo pacman -S --needed sddm
  7. sudo systemctl disable lightdm
  8. sudo systemctl enable sddm
  9. reboot

I could still log in via the tty with the commands:

systemctl enable lightdm.service
systemctl start lightdm

Changed the display manager because:
systemctl --failed
“lightdm.service failed”

It’s obvious there was an issue with its installation and or configuration but its work with sddm.

Wlan works fine …

1 Like

I’ve marked the below answer as the solution to your question as it is by far the best answer you’ll get.

However, if you disagree with my choice, please feel free to take any other answer as the solution to your question or even remove the solution altogether: You are in control! (I just want to avoid even more subjective opinions being posted and confusing you even more)

:innocent:
P.S. In the future, please don’t forget to come back and click the 3 dots below the answer to mark a solution like this below the answer that helped you most :
Solution
so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.

1 Like