Widevine in arm

I got this issue since I have done some software updates on my manjaro.
The docker is not working and by running it in console I got those couple of error lines.

Set host IP for Pulseaudio
/usr/local/bin/chromium-armhf: line 4: hostname: command not found
Enabling XHost Forwarding
non-network local connections being added to access control list
Searching for Docker image ...
Found and using 2cbe4a04edc2
WARNING: The requested image's platform (linux/arm) does not match the detected host platform (linux/arm64/v8) and no specific platform was requested
docker: Error response from daemon: failed to create shim: OCI runtime create failed: runc create failed: unable to start container process: unable to apply cgroup configuration: chown /sys/fs/cgroup/system.slice/docker-865912667ff981866e9c5be3bef890d4f70fc7b7901af3d438d032c6bc17053e.scope/memory.oom.group: no such file or directory: unknown.

Is there any solution for that?
I have been very happy since docker started to work for me almost 1 year ago.
Hope I will be able to get it back.

Guys, @tartanpion or @spikerguy, have you got a solution for not working docker? Could you please explain/help?

You can fix that by adding the following entries at the end of your /boot/cmdline.txt file:
cgroup_enable=memory cgroup_memory=1

It is really a docker issue related to cgroup capabilities. Reboot and you will be good to go.

However, if you are planning to use the latest chromium-docker to have widevine, you are out of luck with the rest of us: chrome://components/ does not list widevine anymore :frowning:

And there are a couple of other minor issues. For example, you may need to install inetutils to get hostname to work for that script and, if your paprefs is broken, you will need to install pulseaudio (uninstalling pipewire-pulse first, since it conflicts):

sudo pacman -S inetutils
sudo pacman -S pulseaudio

Anyway, your mileage may vary but this should get you going.

Best regards!


I did as you advised with this cgroup enable memory in cmdline.txt. I have also reinstalled docker and now it works as previous. It is possible for me to again watch Netflix. Thank you @LifeBlower .

Can you please share the steps you took to get this work? Did you have to setup a seperate docker instance?

Sry @Mangled, I can not list exact steps for you. I have just did as I mentioned. I can just suppose that I have some specific state of Manjaro. I could share with this but to be honest, I do not know how could I feed you.

Seems like the 64 bit Raspbian Bullseye has got the support for widevine through installing thee 32 bit version and switching to it.
Isn’t that possible on Manjaro?

this is what we do but we use dockers for 32bit app or systemd container option, as we do not maintain the 32bit user space anymore so we have to use the above options.

1 Like

On a fresh Manjaro XFCE installation I didn’t need all those tips from this thread. What I did:

  • pamac install inetutils docker
  • reboot
  • systemctl enable docker
  • systemctl start docker
  • pamac install chromium-docker
  • reboot

And everything is fine, now I can watch Netflix on the second display (an old TV). Sound via HDMI works out of the box, I didn’t test bluetooth or other outputs (my Pi400 only has bluetooth and HDMI).

UPDATE: A minor drawback seems to be, that docker sends audio signals only to HDMI-1. Otherwise it works quite well.

1 Like

Does amazon prime work as well? I think prime requires the latest widevine components.

I’m sorrry, I don’t have an account on amazon so I cannot test it. In general the solution for Manjaro with the armhf-docker-container is not perfect at all. It works, but only for some setups. I’m not able to route the audio output to bluetooth for example. Only HDMI-1 works. And after a few minutes of watching Netflix, chrome opens a popup and want’s to be updated.

hi, can i install chromium amd64 with box64 ? if possible will widevine work?

Good idea.
Give it a try.

1 Like

I have just formatted and reinstalled from manjaro arm xfce to gnome.
I used fresh iso and proceed with chromium docker installation.
Netflix movie runs. Music is also available but I can not again manipulate with the volume (only one constant same level of volume is available from chromium docker).

First thing I did was to configure paprefs but i got this issue described here:

Does anybody knows how to solve?

1 Like

If you’re using pipewire then i dont think paprefs will help.

We need to find a better solution for widewine use all together.

Hopefully Google should release it for arn64.

Sorry I do not get you @spikerguy.
I do not know how to use pipewire. Does pipewire is kind of substitute for paprefs?
You are saying that there is no way to use paprefs for chromium-docker?

Hi, i 've a problem with chromium-docker, i can’t start it :frowning:

here is the error message :

[dams@dams-pc ~]$ sudo chromium-armhf
[sudo] Mot de passe de dams :
Set host IP for Pulseaudio
/usr/local/bin/chromium-armhf: ligne 4: hostname : commande introuvable
Enabling XHost Forwarding
non-network local connections being added to access control list
Searching for Docker image …
Found and using ee9f33d99146
/usr/local/bin/chromium-armhf: ligne 13: pax11publish : commande introuvable
WARNING: The requested image’s platform (linux/arm/v7) does not match the detected host platform (linux/arm64/v8) and no specific platform was requested
Failed to dup renderonly object
free(): invalid pointer
[dams@dams-pc ~]$

If someone has an idea ?

Ugoos am6b+/ 5.25.3/Wayland

I had to reinstall docker and forgot how to activate the sound through the docker. Can someone please remind me how to do it on rockpro64?

This worked great! Thank You!

New updates regarding widevine package. You can now download the widevine-aarch64 and widevine-glibc packages from AUR to work with your browser on aarch/manjaro. However, from my own experience, pamac indicates that glibc is a locked package and will not allow me to install it. Does anyone have a solution?

Instructions for a successful install would be:

Please make sure to run the registering scripts register_widevine_firefox and/or register_widevine_chromium for every user that needs to be able to use widevine. This script only needs to be run once; no need to repeat it after upgrade.

run (on the command line). Like:

LD_PRELOAD=/opt/WidevineCdm/libgcc_hide.so firefox

1 Like