Widevine in arm

What I mean about “toggle the voice” is that the audio is too low for me. I wanted to watch it with full volume though.

I found the solution to it using @spikerguy post by enabling the audio over network using paprefs then reboot and I could see it in my Audio Volume Settings > Audio > Applications and there listed my chromium-docker and could toggle the volume to 150% max.

Where would you want to output your audio though? You got audio jack, HDMI, and bluetooth options. But then you can toggle them by clicking the Volume at your system tray.
audio pallet

If you want simultaneous audio output you could toggle it also in paprefs > Simultaneous Output and check the Add virtual output device for simultaneous output on all local sound cards
simultaneous audio output

Well, the answer is right in front of you. You just have to follow the steps.

I’d be happy to assist :slight_smile:

Gents, I am doing all that stuff you posting here and I think I am following your advises.
As I said before:

By saying this I mean:
When I play Youtube in chromium-docker, I can’t modify anything related to the audio. In another words, The youtube audio plays even I disable all devices in Audio Volume system tray. And for any enabled device, if I switch to it, the voice comes from the same source - from HDMI (so Analog Output).

What is interesting:

I do not see Chromium-docker in Audio tray / Devices.

If there is any way to diagnose remotely my issue, I would be very glad to do so.
Thank you @spikerguy and @Ace for so far support.

Did you reboot your system after checking those boxes in paprefs? I had mine available after reboot though.

1 Like

Sorry for late feedback.

Of course I have reboot the system (like it was solution for all)…

I do not get by chromium-docker what I need to. I have got one level sound from it, without possibility to make sound higher or lower and without possibility to change a output device.

Solution for me was:
Change OS to Raspbian and watch Netflix in Kodi.

Thanks for all your support. Regards!

1 Like

After the error message in the shell and discovering that hostname isn’t in the bashrc.

echo "Set host IP for Pulseaudio"
addrip="$(hostname -i | grep -v '' | awk '{ print $1}')"

i have read the readme in usr/share/chromium-docker and after editing usr/local/bin/chromium-armhf

#echo "Set host IP for Pulseaudio"
#addrip="$(hostname -i | grep -v '' | awk '{ print $1}')"

docker run --rm --privileged \
-v chromium_home:/home \
-v /tmp/.X11-unix:/tmp/.X11-unix \
-v /dev:/dev -v /run:/run \
-v /etc/machine-id:/etc/machine-id \
--ipc=host \
--device /dev/dri \
--group-add video \

I have a working chromium-docker with sound.

1 Like

That is working mate!
Explain me please, what is it all about?
Thank you very much @tartanpion.

@spikerguy Is the problem mentioned here, still there ?

What’s the best way to use Widevine now ?
Is there an official ARM-64 Widevine support available now ?
Should we still use chromium-docker ?
If yes should we do other things after installation or is just a pure installation working now ?

Not sure, I’ve not tested it regularly but if it happen then just follow that command.


Have not found anything yet.

This is what I get when I run chromium-armhf:

Set host IP for Pulseaudio
/usr/local/bin/chromium-armhf: line 4: hostname: command not found
Enabling XHost Forwarding
non-network local connections being added to access control list
Searching for Docker image ...
Found and using
"docker run" requires at least 1 argument.
See 'docker run --help'.

Usage:  docker run [OPTIONS] IMAGE [COMMAND] [ARG...]

Run a command in a new container.


Nothing is returned while the command executes successfully on running docker images -q hthiemann/chromium-armhf:latest :expressionless:

Update 2:
Running the following parts of this file made is possible to run chromium-armhf without sound:

echo "Building Docker Image - This will take sometime"
cd /usr/share/chromium-docker/git
docker build -t hthiemann/chromium-armhf .
# Enabling xhost forwarding
echo "Enabling xhost forwarding"
xhost +local:docker
#Creating Volume
docker volume create chromium_home
install -m 755 chromium-armhf /usr/local/bin      

I now have 2 problems:

  1. No sound
  2. Mouse is too small when it enters the chromium-armhf's GUI window.

Chromium docker doesnt appear to have widevine anymore. Just installed it and doesnt appear in chrome://components. Ive reinstalled it a few times to make sure the installation was fine.

Has the setup changed?

Is anyone else having this issue? I use RP64

I doubt that it will not have widevine but yes it might not be able to play anything anymore as Amazon prime needs newer widevine version and I have not been able to find the right combination of User Agent, browser and widevine version yet.

I will try this tonight to see if it comes up or not.

any luck?


Waiting to see what is rpi doing for ita 64bit kernel and userbase.

Why not to use the same strategy used by Raspberry Pi OS instead of using chromium-docker?

To use the WidevineCDM library is just install the 32 bits version of Chromium, using the following command: sudo apt install chromium-browser:armhf libwidevinecdm0

If want to go back to 64 bits version (without WidevineCDM), just use this command: sudo apt install chromium-browser:arm64 libwidevinecdm0- .

We could have something similar to Manjaro

this could be done via chroot environment. I will give it a go

That’s what I tried in sway profile: overlays/sway/usr/local/bin/install_chromium_widevine.sh · master · manjaro-arm / applications / arm-profiles · GitLab. But still you need a compatible chromium-armhf and widevine plugin…

I got this issue since I have done some software updates on my manjaro.
The docker is not working and by running it in console I got those couple of error lines.

Set host IP for Pulseaudio
/usr/local/bin/chromium-armhf: line 4: hostname: command not found
Enabling XHost Forwarding
non-network local connections being added to access control list
Searching for Docker image ...
Found and using 2cbe4a04edc2
WARNING: The requested image's platform (linux/arm) does not match the detected host platform (linux/arm64/v8) and no specific platform was requested
docker: Error response from daemon: failed to create shim: OCI runtime create failed: runc create failed: unable to start container process: unable to apply cgroup configuration: chown /sys/fs/cgroup/system.slice/docker-865912667ff981866e9c5be3bef890d4f70fc7b7901af3d438d032c6bc17053e.scope/memory.oom.group: no such file or directory: unknown.

Is there any solution for that?
I have been very happy since docker started to work for me almost 1 year ago.
Hope I will be able to get it back.