Why Manjaro Kde use fsck?

Why Manjaro kde plasma use fsck?
is it important?

What exactly makes you think that it uses fsck?

Well, Fsck checks my files Everytime I boot,reboot,shutdown :roll_eyes:

I repeat:

If all you want to know is why and if fsck is important, just go to wiki.archlinux.org and search for “fsck”. There you will also find ways to enable or disable it.

1 Like

Well I wanna know why it starts with manjaro kde :thinking:
It didn’t start with manjaro XFCE :roll_eyes:

Start of fsck at boot is usually initiated either via mkinitcpio hook or systemd itself, I don’t see how this could be linked to the DE which comes into the game much later. But either way is not causing it to be executed every time the system is booted.

1 Like

So you’re saying somehow this fsck is booting only with my pc :roll_eyes: ???

Can you provide the outputs of:

cat /etc/fstab

cat /etc/default/grub

cat /etc/mkinitcpio.conf

1 Like

1
2

[frozen@frozen ~]$ cat /etc/mkinitcpio.conf
# vim:set ft=sh
# MODULES
# The following modules are loaded before any boot hooks are
# run.  Advanced users may wish to specify all system modules
# in this array.  For instance:
#     MODULES=(piix ide_disk reiserfs)
MODULES=""

# BINARIES
# This setting includes any additional binaries a given user may
# wish into the CPIO image.  This is run last, so it may be used to
# override the actual binaries included by a given hook
# BINARIES are dependency parsed, so you may safely ignore libraries
BINARIES=()

# FILES
# This setting is similar to BINARIES above, however, files are added
# as-is and are not parsed in any way.  This is useful for config files.
FILES=""

# HOOKS
# This is the most important setting in this file.  The HOOKS control the
# modules and scripts added to the image, and what happens at boot time.
# Order is important, and it is recommended that you do not change the
# order in which HOOKS are added.  Run 'mkinitcpio -H <hook name>' for
# help on a given hook.
# 'base' is _required_ unless you know precisely what you are doing.
# 'udev' is _required_ in order to automatically load modules
# 'filesystems' is _required_ unless you specify your fs modules in MODULES
# Examples:
##   This setup specifies all modules in the MODULES setting above.
##   No raid, lvm2, or encrypted root is needed.
#    HOOKS=(base)
#
##   This setup will autodetect all modules for your system and should
##   work as a sane default
#    HOOKS=(base udev autodetect block filesystems)
#
##   This setup will generate a 'full' image which supports most systems.
##   No autodetection is done.
#    HOOKS=(base udev block filesystems)
#
##   This setup assembles a pata mdadm array with an encrypted root FS.
##   Note: See 'mkinitcpio -H mdadm' for more information on raid devices.
#    HOOKS=(base udev block mdadm encrypt filesystems)
#
##   This setup loads an lvm2 volume group on a usb device.
#    HOOKS=(base udev block lvm2 filesystems)
#
##   NOTE: If you have /usr on a separate partition, you MUST include the
#    usr, fsck and shutdown hooks.
HOOKS="base udev autodetect modconf block keyboard keymap resume filesystems fsck"

# COMPRESSION
# Use this to compress the initramfs image. By default, gzip compression
# is used. Use 'cat' to create an uncompressed image.
#COMPRESSION="gzip"
#COMPRESSION="bzip2"
#COMPRESSION="lzma"
#COMPRESSION="xz"
#COMPRESSION="lzop"
#COMPRESSION="lz4"
#COMPRESSION="zstd"

# COMPRESSION_OPTIONS
# Additional options for the compressor
#COMPRESSION_OPTIONS=()

Sure last one I entered directly cause it’s large :slight_smile:

I made a typo, I meant:

/etc/default/grub

1 Like
[frozen@frozen ~]$ cat /etc/default/grub
GRUB_DEFAULT=saved
GRUB_TIMEOUT=5
GRUB_TIMEOUT_STYLE=hidden
GRUB_DISTRIBUTOR="Manjaro"
GRUB_CMDLINE_LINUX_DEFAULT="quiet apparmor=1 security=apparmor resume=UUID=4dd2fd5d-3dde-48fa-878c-3fa834d7c95e udev.log_priority=3"
GRUB_CMDLINE_LINUX=""

# If you want to enable the save default function, uncomment the following
# line, and set GRUB_DEFAULT to saved.
GRUB_SAVEDEFAULT=true

# Preload both GPT and MBR modules so that they are not missed
GRUB_PRELOAD_MODULES="part_gpt part_msdos"

# Uncomment to enable booting from LUKS encrypted devices
#GRUB_ENABLE_CRYPTODISK=y

# Uncomment to use basic console
GRUB_TERMINAL_INPUT=console

# Uncomment to disable graphical terminal
#GRUB_TERMINAL_OUTPUT=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command 'videoinfo'
GRUB_GFXMODE=auto

# Uncomment to allow the kernel use the same resolution used by grub
GRUB_GFXPAYLOAD_LINUX=keep

# Uncomment if you want GRUB to pass to the Linux kernel the old parameter
# format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx"
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
GRUB_DISABLE_RECOVERY=true

# Uncomment this option to enable os-prober execution in the grub-mkconfig command
GRUB_DISABLE_OS_PROBER=false

# Uncomment and set to the desired menu colors.  Used by normal and wallpaper
# modes only.  Entries specified as foreground/background.
GRUB_COLOR_NORMAL="light-gray/black"
GRUB_COLOR_HIGHLIGHT="green/black"

# Uncomment one of them for the gfx desired, a image background or a gfxtheme
#GRUB_BACKGROUND="/usr/share/grub/background.png"
#GRUB_THEME="/path/to/gfxtheme"

# Uncomment to get a beep at GRUB start
#GRUB_INIT_TUNE="480 440 1"

# Uncomment to ensure that the root filesystem is mounted read-only so that
# systemd-fsck can run the check automatically. We use 'fsck' by default, which
# needs 'rw' as boot parameter, to avoid delay in boot-time. 'fsck' needs to be
# removed from 'mkinitcpio.conf' to make 'systemd-fsck' work.
# See also Arch-Wiki: https://wiki.archlinux.org/index.php/Fsck#Boot_time_checking
#GRUB_ROOT_FS_RO=true

I’m not sure why your text is being displayed in such a large font. :hushed:

As for your three files…

Your fstab is configured with the defaults, to allow fsck to run on your root ( / ) file-system.

Your mkinitcpio.conf has the fsck “hook”

Your default Grub settings don’t have anything to suggest a fsck for every single bootup, however.

So to be clear, you’re saying with every boot, your screen shows your root file-system being checked with fsck? Every time?

1 Like

please go back and edit/reformat your posts
highlight the output and then format it with the </> button

If you don’t format it, the # marks at the start of each line are interpreted as “print it big and bold”.

1 Like

Yep it starts every time. :frowning:
Btw I don’t know about the font I just copy pasted :slight_smile:

see my post - now you know

1 Like

Let me see mm

Thanks for helping bro :smiling_face_with_three_hearts:

Can you describe which screen / process this happens during?

Do you see the Manjaro logo (or your PC’s vendor logo) while it tells you it’s checking the file-system?

How long does it take? Can you actually see a percentage “progress” that eventually reaches 100%?

There is a way to disable it, either in the fstab or with mkinitcpio, but I think it’s better to figure out why it checks your file-system at every boot.

While in Manjaro, can you type:

sudo tune2fs -l /dev/sdxx | grep -i “last checked”

Replace sdxx with root partition.

This will tell you when the file-system was last checked.

1 Like

This will hide yr file system check msg…just send it to another tty.

1 Like
[frozen@frozen ~]$ sudo tune2fs -l / | grep -i “last checked”
grep: checked”: No such file or directory
[sudo] password for frozen: 
tune2fs: Is a directory while trying to open /
Couldn't find valid filesystem superblock.