When I install nvidia proprietary drivers, manjaro doesn't boot

Hi! So I’ve finally decided to switch from VM to real hardware and dedicated a whole separate SSD for Manjaro.

And immediately experienced some troubles. I will be glad if you help, thanks in advance.

Let’s start with the first one.

I’ve installed proprietary drivers for my RTX 2070S (video-nvidia-450xx) and after that only rescue mode is available:


Here I’ve managed to uninstall them via mhwd -r pci video-nvidia-450xx and now it boots up again with free drivers.

How can I make non-free drivers work?

I’m not sure the RTX series are supported yet. You will need newer drivers then 450xx. But I would have sworn that that the 2000sdGPUs work… and it is the 3000s that have issues.

You should be able to use the nonfree when you first installed Manjaro by selecting nonfree when booting the LiveMedia. Otherwise go to Manjaro Settings Manager in the Menu and click on Hardware and then Auto Install Proprietary Driver and go from there.

Reboot after installing the Nvidia Drivers…

I’m not 100% certain but as you have a ryzen nvidia combo I think you need to disable the intergrated graphics from bios. This is a slightly different setup to yours but the thread may help

When I select nonfree in live booting, it won’t boot. It hangs at line like “setting up MHWD”. I waited until I seen [8 minutes / no limit], then I just rebooted with free drivers

I don’t have an integrated GPU…

I’ve just tried to install https://www.nvidia.com/Download/driverResults.aspx/150803/en-us , it said nouveau should be disabled, I’ve created a file in /etc/modprobe.d to disable it, rebooted, and it doesn’t boot again and even doesn’t show rescue mode…

Sorry I thought your ryzen had the intergrated vega graphics

OMG, disconnection of Ethernet cable solved the problem: https://www.reddit.com/r/ManjaroLinux/comments/iobltn/manjaro_kde_plasma_installation_stuck_at_a_start/

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.