What's wrong with my Manjaro?

This might point to a defective file system. I would try fsck, preferably, from the live system on the USB stick.


Even if you have 16 GB of RAM installed, having a swap partition or swap file still makes sense.

I guess you cannot remmeber what you did change on your system back then.

Sadly I don’t remember.

What is the issues list? Inxi seg fault, stuck boot, … ?

What do you mean?

Even if you have 16 GB of RAM installed, having a swap partition or swap file still makes sense.

So what should I do now?

I mean, apart from the inxi error and your booting trouble, do you have other issues?

Sometimes the whole system freezes (except sound) and I need to forcerly reboot.

Try this already

have you checked your log ?

sudo journalctl -b0 -p4

I’m not so good at reading journalctl…Could you help me?

“Stuck” is the past tense of “stick”. “Stucked” is not a word.

I’ve tried it but the command takes to long. After 25 min still no output and no return.

fsck -a /dev/nvme0n1/nvme0n1p2
fsck from util-linux 2.36.1
fsck.ext2: Not a directory while trying to open /dev/nvme0n1/nvme0n1p2
The superblock could not be read or does not describe a valid ext2/ext3/ext4
filesystem.  If the device is valid and it really contains an ext2/ext3/ext4
filesystem (and not swap or ufs or something else), then the superblock
is corrupt, and you might try running e2fsck with an alternate superblock:
    e2fsck -b 8193 <device>
    e2fsck -b 32768 <device>

Is what I get now and the commands with ef2fsck do not work…

Could you post the result of lsblk --output NAME,SIZE,TYPE,FSTYPE,MOUNTPOINT ?

loop0        55,4M loop squashfs /var/lib/snapd/snap/core18/1944
loop1        31,1M loop squashfs /var/lib/snapd/snap/snapd/11036
loop2       169,3M loop squashfs /var/lib/snapd/snap/spotify/42
loop3       210,1M loop squashfs /var/lib/snapd/snap/eclipse/48
loop4        55,5M loop squashfs /var/lib/snapd/snap/core18/1988
loop5         173M loop squashfs /var/lib/snapd/snap/spotify/43
loop6        32,3M loop squashfs /var/lib/snapd/snap/snapd/11107
sda         111,8G disk          
├─sda1        100M part vfat     
├─sda2         16M part          
├─sda3      111,2G part ntfs     
└─sda4        513M part ntfs     
sdb         931,5G disk          
├─sdb1         16M part          
├─sdb2      634,8G part ntfs     
└─sdb3      296,7G part ext4     
nvme0n1     465,8G disk          
├─nvme0n1p1   300M part vfat     /boot/efi
└─nvme0n1p2 465,5G part ext4     /

I think I figured out…I was using kernel 5.10. Switching to 5.9 seems to be a good decision. I would rather use 5.4 because it’s LTS but some apps (e.g. Spotify) simply do not run on 5.4 kernel…
The error from spotify:

cannot query current apparmor profile: Invalid argument

Oh is that so? Nice then, but be careful, this kernel is End Of Life, it won’t receive updates anymore (potential security issues) and it could be removed from Manjaro repos some updates later.

I’m not actively reading the linux news and I’d rather stay on something stable. Is there a reasons to use 5.9 or 5.10 (or even 5.11) instead of 5.4 (which is LTS)? Note that (as said) I’m not following all news and sometimes I hate to repair conflicts after updates.

I don’t understand why do I have problems with 5.10 when it is a LTS in Comparison with 5.9…

5.4 is the stable LTS, still updated until 2 or 3 years if I remember (it’s on kernel.org). It has been proved solid and it’s good to have it installed, just in case. You can have several kernels installed.
But it’s older, and newest hardwares and softwares are not always compatible with it.

5.10 is destined to be the next LTS. It is supposed to be rock solid and all… But it had (still has?) some youth issues and bugs. For a LTS wannabe, it’s not the as stable and reliable as it should be.

For many, as myself and my ooold hardware, 5.10 works very fine. For others, some problems could arise and it’s not the 1st time I saw that downgrading to 5.9 fixes it.

5.9 is a transition kernel. If it fixes more than damages your system, go for it. But keep in mind it will disappear in the next few months from Manjaro. And let’s hope 5.10, 5.11, will be good for your system when it’s time.

For 5.11, it’s still too young. But if you’re a developer who needs absolute new features, go for it. Otherwise, keep the stable proven kernels.

There seems to be a problem with kernel 5.4 on Manjaro: Snaps stopped working after 2020-12-30 update - #11 by philm

Unfortunately, there is apparently no solution other than using a newer kernel.