What's the best UHD driver to use?

Hello, I’m new here and a newbie in the Linux world.
Just installed it to my laptop that has an UHD Graphics intel and noticed tearing in YouTube videos on full screen. so I thought I might check the hardware configuration and noticed that there are three and the one installed is Video-Linux the other two are Video-modesetting and Video-vesa.

what is the deference between them and are they the same in performance? which one could fix the tearing problem ?

thanks in advance.

I have an Intel UHD 630 GPU, and I’ve recently switched to video-modesetting, but I’m not seeing any tearing here. Before that, I was using video-linux, and that was fine too ─ I would even say that it was a bit snappier… :man_shrugging:

You don’t want video-vesa, though. That’s just a generic VESA driver for very old hardware, and I doubt that it would be able to do HD, let alone UHD.


Okay I’ll install it and write here if I see any changes in performance for me.

1 Like

Don’t forget to come back and write about it!

:innocent: :wink:

1 Like

I did install the video-modesetting then rebooted and there is no deference that I can see. screen tearing is still there so nothing has changed

Have you updated your system yet? There was a major update today.

sudo pacman-mirrors -f 5 && sudo pacman -Syyu

Additionally, depending on your exact GPU ─ there are different types of Intel UHD ─ you may be better off with another kernel version.

What @Aragorn said, but we’ll need a little bit more info. Therefore, please read this:

How to provide good information in your posts - Tutorials - Manjaro Linux Forum

and post some more information so we can see what’s really going on. Now we know the symptom of the disease, but we need some more probing to know where the origin lies…

An inxi --admin --verbosity=7 --filter --no-host would be the minimum required information… (Personally Identifiable Information like serial numbers and MAC addresses will be filtered out by the above command)


P.S. If you enter a bit more details in your profile, we can also see which Desktop Environment you’re using, which CPU/GPU you have, …

1 Like

Actually the major update caused me to re install Manjaro more like 4 times. the laptop keeps booting into BIOS every time I install the update through Graphical package manger so I used the terminal to update everything and it’s working perfectly good now. but the screen tearing is still there.

this is the information you asked for, and if you need anything else just tell me.

  Kernel: 5.7.19-2-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.7-x86_64 
  root=UUID=c07ba933-150a-4940-a99f-727cf4261180 rw quiet apparmor=1 
  security=apparmor resume=UUID=20cad62b-128d-46e4-8620-42ac3fe30f0d 
  Desktop: KDE Plasma 5.19.5 tk: Qt 5.15.0 wm: kwin_x11 dm: SDDM 
  Distro: Manjaro Linux 
  Type: Laptop System: LENOVO product: 20RW v: Lenovo ThinkBook 15-IML 
  serial: <filter> Chassis: type: 10 serial: <filter> 
  Mobo: LENOVO model: LVA/LVAB v: NO DPK serial: <filter> UEFI: LENOVO 
  v: CJCN29WW date: 06/19/2020 
  ID-1: BAT1 charge: 44.9 Wh condition: 44.9/45.0 Wh (100%) 
  volts: 13.0/11.5 model: Celxpert L19C3PF1 type: Li-poly 
  serial: <filter> status: Full cycles: 22 
  RAM: total: 3.36 GiB used: 1.50 GiB (44.6%) 
  RAM Report: 
  permissions: Unable to run dmidecode. Root privileges required. 
  Topology: Quad Core model: Intel Core i5-10210U bits: 64 type: MT MCP 
  arch: Kaby Lake family: 6 model-id: 8E (142) stepping: C (12) 
  microcode: D6 L2 cache: 6144 KiB bogomips: 33615 
  Speed: 900 MHz min/max: 400/4200 MHz Core speeds (MHz): 1: 900 2: 900 
  3: 900 4: 900 5: 900 6: 900 7: 900 8: 901 
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat 
  arch_capabilities arch_perfmon art avx avx2 bmi1 bmi2 bts clflush 
  clflushopt cmov constant_tsc cpuid cpuid_fault cx16 cx8 de ds_cpl 
  dtes64 dtherm dts epb ept ept_ad erms est f16c flexpriority flush_l1d 
  fma fpu fsgsbase fxsr ht hwp hwp_act_window hwp_epp hwp_notify ibpb 
  ibrs ibrs_enhanced ida intel_pt invpcid invpcid_single lahf_lm lm mca 
  mce md_clear mmx monitor movbe mpx msr mtrr nonstop_tsc nopl nx pae 
  pat pbe pcid pclmulqdq pdcm pdpe1gb pebs pge pln pni popcnt pse pse36 
  pts rdrand rdseed rdtscp rep_good sdbg sep smap smep ss ssbd sse sse2 
  sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_adjust 
  tsc_deadline_timer vme vmx vnmi vpid x2apic xgetbv1 xsave xsavec 
  xsaveopt xsaves xtopology xtpr 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 
  mitigation: Enhanced IBRS, IBPB: conditional, RSB filling 
  Type: srbds mitigation: TSX disabled 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel UHD Graphics vendor: Lenovo driver: i915 v: kernel 
  bus ID: 00:02.0 chip ID: 8086:9b41 
  Device-2: Acer SunplusIT Integrated Camera type: USB driver: uvcvideo 
  bus ID: 1-6:4 chip ID: 5986:2113 
  Display: x11 server: X.Org 1.20.8 compositor: kwin_x11 
  driver: modesetting alternate: fbdev,intel,vesa display ID: :0 
  screens: 1 
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") 
  s-diag: 582mm (22.9") 
  Monitor-1: eDP-1 res: 1920x1080 hz: 60 dpi: 142 
  size: 344x194mm (13.5x7.6") diag: 395mm (15.5") 
  OpenGL: renderer: Mesa Intel UHD Graphics (CML GT2) v: 4.6 Mesa 20.1.7 
  direct render: Yes 
  Device-1: Intel vendor: Lenovo driver: snd_hda_intel v: kernel 
  alternate: snd_soc_skl,snd_sof_pci bus ID: 00:1f.3 chip ID: 8086:02c8 
  Sound Server: ALSA v: k5.7.19-2-MANJARO 
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Lenovo driver: r8168 v: 8.048.03-NAPI modules: r8169 
  port: 3000 bus ID: 01:00.0 chip ID: 10ec:8168 
  IF: enp1s0 state: up speed: 100 Mbps duplex: full mac: <filter> 
  IP v4: <filter> type: dynamic noprefixroute scope: global 
  broadcast: <filter> 
  IP v6: <filter> type: noprefixroute scope: link 
  Device-2: Realtek vendor: Lenovo driver: N/A port: 2000 
  bus ID: 02:00.0 chip ID: 10ec:c82f 
  WAN IP: <filter> 
  Local Storage: total: 931.51 GiB used: 8.69 GiB (0.9%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/sda vendor: Toshiba model: MQ04ABF100 size: 931.51 GiB 
  block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  rotation: 5400 rpm serial: <filter> rev: 0E scheme: GPT 
  Message: No Optical or Floppy data was found. 
  Message: No RAID data was found. 
  ID-1: / raw size: 923.83 GiB size: 908.32 GiB (98.32%) 
  used: 8.69 GiB (1.0%) fs: ext4 dev: /dev/sda2 label: N/A 
  uuid: c07ba933-150a-4940-a99f-727cf4261180 
  ID-2: /boot/efi raw size: 300.0 MiB size: 299.4 MiB (99.80%) 
  used: 280 KiB (0.1%) fs: vfat dev: /dev/sda1 label: N/A 
  uuid: F09A-9364 
  Kernel: swappiness: 60 (default) cache pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 7.39 GiB used: 0 KiB (0.0%) 
  priority: -2 dev: /dev/sda3 label: N/A 
  uuid: 20cad62b-128d-46e4-8620-42ac3fe30f0d 
  Message: No unmounted partitions found. 
  Hub: 1-0:1 info: Full speed (or root) Hub ports: 12 rev: 2.0 
  speed: 480 Mb/s chip ID: 1d6b:0002 
  Device-1: 1-3:2 info: ASUSTek ROG STRIX IMPACT type: Mouse,HID 
  driver: hid-generic,usbhid interfaces: 3 rev: 2.0 speed: 12 Mb/s 
  chip ID: 0b05:1847 
  Device-2: 1-5:3 info: Shenzhen Goodix Goodix FingerPrint Device 
  type: <vendor specific> driver: N/A interfaces: 1 rev: 2.0 
  speed: 480 Mb/s chip ID: 27c6:55a4 
  Device-3: 1-6:4 info: Acer SunplusIT Integrated Camera type: Video 
  driver: uvcvideo interfaces: 2 rev: 2.0 speed: 480 Mb/s 
  chip ID: 5986:2113 
  Device-4: 1-10:5 info: Realtek Bluetooth Radio type: Bluetooth 
  driver: btusb interfaces: 2 rev: 1.0 speed: 12 Mb/s chip ID: 0bda:c02f 
  serial: <filter> 
  Hub: 2-0:1 info: Full speed (or root) Hub ports: 6 rev: 3.1 
  speed: 10 Gb/s chip ID: 1d6b:0003 
  System Temperatures: cpu: 41.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
  Processes: 208 Uptime: 2h 37m Init: systemd v: 246 Compilers: 
  gcc: 10.2.0 Packages: pacman: 1175 lib: 313 flatpak: 0 Shell: Bash 
  v: 5.0.18 running in: konsole inxi: 3.1.05

You’re on the 5.7 kernel and have an Intel GPU whose drivers are built into the kernel, so:

  • Print this page so you have it as a reference while in TTY2

  • Log off

  • Switch to TTY2 by pressing Ctrl+Alt+F2

  • Log in there

  • Execute:

    sudo mhwd-kernel --install linux419
    sudo mhwd-kernel --install linux54
    sudo mhwd-kernel --install linux58
  • to ensure grub is showing, execute:

     sudo nano --backup /etc/default/grub
  • Change (or add?) the following 3 lines:


    (3 or higher is fine, add the # before the lines above if those lines are present)

  • Ctrl+X Y Enter to save if there is anything to save

  • If you did save, execute:

     sudo update-grub
  • Reboot

  • Go to grub’s Advanced options

  • Choose these kernels one by one and try them out one by one and see if that helps.



Have you tried the “TearFree” Xorg option?


I will try it now and give you a feed back as soon as I finish it. :crossed_fingers:

tried that on Ubuntu a week ago and it didn’t fix the problem. and brought a bigger one that when I rebooted the system green squares were all around my desktop.

I guess you could give it a try. That was Ubuntu, this is Manjaro.

Tried the Kernel 5.8 and Kernel 5.4 same thing no change. but on Kernel 4.19 didn’t boot to manjaro I was stuck at the lenovo icon.

as you mentioned I was on Kernel 5.7 so know I’m using 5.8 .

I’ll try the Tearfree method that @pobrn mentioned.

by the way should I keep the kernal versions I installed ? or should I delete them if yes how?.

thanks for your efforts.

If you don’t use a kernel, I don’t see why you’d need to keep it. You can uninstall kernels in manjaro-settings-manager.

1 Like

thanks a lot.
one more question is how to create /etc/X11/xorg.conf.d/20-intel.conf ?
is it the same command line as in ubuntu? I used $ sudo nano /etc/X11/xorg.conf.d/20-intel.conf or there is a specific one here should I use ?

It would be the same. :wink:

1 Like

I got this message now after rebooting [failed] failed to start simple desktop display manager.

sddm is your graphical login screen. Apparently it doesn’t like your modification. :face_with_raised_eyebrow:

So anyway to undo what I just did ? :joy: