What is up with copy/paste on Manjaro KDE?

Seriously, what is up with this? Not sure when it started, maybe the past couple days, but copy/paste is a complete pain in the ___ and “works,” but constantly gives an error that requires you to reload or reopen a page to use it.

It is something I do pretty often, and having this issue is just about enough to make me go with another distro. So what is the deal?

Also, would just search through DuckDuckGo or Google what others have tried, but none of the links will actually go to a page. Just says “Ooops, that doesn’t exist anymore or is private” (or something to that effect). Really irritating.

Perhaps we would be able to offer more assistance if you were to tell us what the actual problem is.

I’m running KDE Plasma 5.19.4 here, and copy/paste works exactly as it should. :man_shrugging:

2 Likes

It’s due to the remake of the forums. Search indexes aren’t up to date yet.

It’s not working. That’s the actual problem.

I’m not sure how that affects a result on Google that should load up a page here.

Most old posts are on the old forum now located at https://archived.forum.manjaro.org/ and for google and other search engines to update it’s links, they need to crawl things again to re-index everything.

1 Like

Ah, okay. Hopefully that’ll make an issue like this easier to find a solution rather than starting a new thread.

You are describing two different issues here. One is copy / paste, the other is obviously (just guessing, as you did not specify) what @thomassjogren mentioned.

I’d rather just search for an issue and find a solution rather than have to start a new thread. Have any ideas what is up with copy and pasting now? It doesn’t work.

Btw. Any link you get " Oops! That page doesn’t exist or is private." you can try add “archived” before “forum” in th URL and pray it loads :smile:

2 Likes

I’ll try that and see if I have any success. Thanks.

So anyone have any solutions for copy/paste being borked or? Something as simple as pasting a link shouldn’t result in an error, and it is rather annoying.

So back to the OT… copy and paste doesn’t work. How are you doing it? Ctrl+C / Ctrl+V? Highlight text and then use middle mouse button to paste? Select text, right click, Copy and then right click and Paste? Is it just text? Is it just the web browser?

In other words, what are the steps you are following? What happens? What do you think should (or used to) happen?

1 Like

The standard shortcut keys. Copy link, paste link, doesn’t work.

There are, to the best of my knowledge, no standard shortcuts for copying a link.

Also, it may be that something else is selected in your clipboard. It’s always best to check the clipboard for the active selection if you’ve been copying/pasting a lot, and across applications ─ especially between GTK applications and Qt applications.

Have you checked the shortcut keys in System Settings and perhaps tried to reset them?

1 Like

You say ‘Copy link, paste link’. So this is in the web browser? What web browser? Does copy and paste works elsewhere? And you say it

“works,” but constantly gives an error that requires you to reload or reopen a page to use it.

What is the error?

1 Like

There is a standard shortcut to copy a link.

Anyways, I was able to isolate the issue. It seems to have been solely Firefox, after doing some messing around, and I think the culprit was “dom.event.clipboardevents.enabled,” which had gotten set to false, most likely when I was messing around with settings in about:config.

2 Likes

The error was different per page, but I think I have isolated the issue to “dom.event.clipboardevents.enabled.”

1 Like

Out of curiosity, what is the shortcut? Or is this terminology confusion, and you meant the context menu, not a keyboard/mouse shortcut?

Pretty sure Ctrl+C and Ctrl+V are universal.