What is changing my cpupower governor?

I use Manjaro i3 with kernel 5.10.56.49-rt-lts in dell xps 9570 pc and I wanted to set my cpupower governor to performance. But it changes just for a while. It automatically gets reset to powersave. And I am stuck with powersave mode now. Does anybody knows what can be the culprit?

Have you checked if it’s tlp?

How to check if tlp is changing the governer? I stopped the systemctl tlp service and tried to change it using cpupower. Same result.

Also I changed the default tlp config on /etc/tlp.config file. It did nothing at all.

You can change tlp settings easily by installing tlpui

Just tried it, but no luck even after reboot. Changed cpu governor even cpu policy to performance. tlp-stat shows powersave still.

Found this log,

Aug 31 19:26:16 max tccd[716]: CpuWorker: Incorrect settings, reapplying profile
Aug 31 19:26:16 max tccd[716]: CpuWorker: Unexpected value core11 energy performance preference => 'performance' instead of 'balance_performance'
Aug 31 19:26:16 max tccd[716]: CpuWorker: Unexpected value core11 scaling governor  => 'performance' instead of 'powersave'
Aug 31 19:26:16 max tccd[716]: CpuWorker: Unexpected value core10 energy performance preference => 'performance' instead of 'balance_performance'
Aug 31 19:26:16 max tccd[716]: CpuWorker: Unexpected value core10 scaling governor  => 'performance' instead of 'powersave'
Aug 31 19:26:16 max tccd[716]: CpuWorker: Unexpected value core9 energy performance preference => 'performance' instead of 'balance_performance'
Aug 31 19:26:16 max tccd[716]: CpuWorker: Unexpected value core9 scaling governor  => 'performance' instead of 'powersave'
Aug 31 19:26:16 max tccd[716]: CpuWorker: Unexpected value core8 energy performance preference => 'performance' instead of 'balance_performance'
Aug 31 19:26:16 max tccd[716]: CpuWorker: Unexpected value core8 scaling governor  => 'performance' instead of 'powersave'
Aug 31 19:26:16 max tccd[716]: CpuWorker: Unexpected value core7 energy performance preference => 'performance' instead of 'balance_performance'
Aug 31 19:26:16 max tccd[716]: CpuWorker: Unexpected value core7 scaling governor  => 'performance' instead of 'powersave'

Finally found the culprit… tcc in the log was Tuxedo Control Center… Not sure if i installed it or came with manjaro…

I don’t have Tuxedo Control Center, and every time my computer reboots or comes back from standby it is in powersave mode, despite any of the controls in cpupower-gui. it is really frustrating because I never need powersave mode for any reason. I want it to stop automatically changing back to power save mode. Feels like some vegan terrorists have sabotaged my computer and I want it to stop.

Where/how would one find that?
To check it, change it …

good question, there are options somewhere that i once found, but as is the case in at least KDE plasma, good luck finding options twice in a row, they’re scattered everywhere and generally it seems to be designed as a kind of labyrinth. There ought to be no reason such a “feature” (involuntary cpu limiting) exists other than some kind of vestigial clipping ceremony to prevent too much fun to happen while computing. The promise of Linux as a day to day operating system is more like a full time job to reinvent the wheel I have to say. There must be paid agents from Microsoft and Apple who are sabotaging Linux. It’s a hobby in of itself, I need to hire a full time computer technician to keep my own desktop running, which ends up making me redundant. I’m on a losing streak right now, packages listed on AUR aren’t installing, packages on pacman/pamac/whatever its called i cant remember, aren’t installing. How am I supposed to remember the difference between pacman and pamac? it’s a bit silly. Things feel intentionally obfuscated. 10 years after my first try with Linux it was promising to be back, a lot of stuff works that didn’t used to work. Great. however, it’s taking me over a month to set up for work, and I can’t explain that to anyone because no one cares. linux as a way to chomp and move data around, great, linux distros are another story completely. there are too many and it seems, again, like sabotage.

I’m sure there are Masters and PhD level degrees for Linux administration, don’t get me wrong. Not taking anything away from the geniuses. The question I am now asksing is if I want to do stuff with my computer or do i want to be a Linux Administrator?

Maybe the world is set up where everyone has to compete for existentially justifying their existence, so everyone has to reinvent the wheel in often the most mediocre way, over and over again. (Just look at the Google Play store for a “media player” for example, and on a fun note how 99.9% of them have ads built in.)

if Arch Linux was my life, I could easily remember the difference between pamac and pacman. But my mind rebels at the idea of taking up space in my brain to remember such a bad naming scheme for such similar programs.

Wouldn’t you need to define it as a udev rule or kernel parameter (at boot, via Grub or Systemd-Boot) in order for it to be persistent between reboots?

You don’t have to.
Just use pamac. Or it’s gui app.
… in Manjaro, that is …

or just use pacman - as you are used to it
and another app like yay for AUR packages

… but then: you could just keep using Arch …

Manjaro is an Arch derivative - with pamac (and gui app) as one of the distinctive features,
but pacman and other Arch tools still work.

It’s a fact of life that you need to learn the tools and ways to operate and maintain the OS that you chose to use :wink:

As to the original problem:
… what @winnie said …

pardon my meltdown, the past week of Linuxing has been a drag. maybe i learned things, but the reality is there are so many mechanisms at play, it’s not possible to learn everything, and it will never be possible at least for me, since my ultimate aims are things other than Linux system administration, so sometimes it’s more like surfing or flying a kite. But you definitely notice you’re using Linux, it has a way of reminding you. Linux is fine, but the distros are just semicoherent wild mishmashes of prebuilt third party modules, and it seems most distros have all the sophistication of a collage or a mixed drink compared to the monsters windows and osx.

I am positive that i once edited a param somewhere relating to cpu performance profiles, perhaps in systemd. let me just grep around a little… but where should I grep? first I have to grep the net to find out where to grep in my comp. Aside from the varied suppositions of other users, how is someone supposed to be able to find such a toggle? where’s the phonebook sized manual if I wanted to RTFM that? I’m telling you Greta is behind this.

i could make Linux my life, it’s that big of a subject, but I’d need to fight a bunch of people smarter than me, many of whom are trying to pull Linux in different directions, (which may be an tell of their actual ‘smartness’) and who has the energy for that?

Package cpupower includes a systemd service to set the CPU governor at system boot, but the service is not active on Manjaro and has to be configured for the correct governor

If you check cpupower configuration file it will probably show the default governor commented out with a # like this:

$ grep 'governor=' /etc/default/cpupower
#governor='powersave'

Open the configuration file in a text editor
(other text editors are available, but nano is usually installed on any version of Manjaro)

sudo nano /etc/default/cpupower

and change the setting for the governor to this:

# Define CPUs governor
# valid governors: ondemand, performance, powersave, conservative, userspace.
governor='performance'

For nano, use Ctrl + O to save the file and Ctrl + X to exit

Then use this command to start and enable the systemd service for cpupower to keep governor set to performance

systemctl enable --now cpupower.service

CPU frequency scaling - cpupower | ArchWiki

CPU governor randomly switching to Powersave, thus heavily limiting performance | forum.manjaro.org

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.