Weird Scaling issues on Manjaro KDE with Nvidia 3060

I installed manjaro KDE on Lenovo Legion 5 2021(15ACH6H) with iGPU disabled(with MUX switch) and some elements were scaled weirdly (the calendar was massive, the system tray icons were also massive , while the taskbar was tiny and the taskbar elements were also tiny)
But when I switched to hybrid Graphics mode, everything was scaled properly.
Anyone has any idea what could be causing this issue?

Hello @useless and welcome :wink:

Maybe it could be a DPI issue? Have look at this thread: G15 5515 Ryzen Edition Hybrid GPU DPI issue

1 Like

@amonobeax seems like I have similar issue as you did.
Although I’m switching graphics cards with mux switch and not optimus manager and I don’t have to do anything to the graphics drivers.

xdpyinfo | grep -B2 resolution
screen #0:
dimensions: 1920x1080 pixels (341x191 millimeters)
resolution: 143x144 dots per inch

I tried adding /etc/X11/xorg.conf.d/90-monitor.conf (
Section “Monitor”
Identifier “DVI-D-0”
DisplaySize 508 285
Option “DPI” “96 x 96”
EndSection
) but the dpi is still the same on dGPU.
Can you walk me through how you fixed it?

@useless

In that thread the Default configuration created by MHWD/Optimus-manager was forcing the correct DPI 96x96.
The issue there was entirely related to optimus-manager not actually switching the GPUs or loading the configs.
Check /etc/optimus-manager.conf part that forced DPI

# DPI value. This will be set using the Xsetup script passed to your login manager.
# It will run the command
# xrandr --dpi <DPI>
# Leave blank for the default (the above command will not be run).
DPI=96

I don’t use optimus-manager.
I switch to nvidia gpu using mux switch .
I don’t want to use iGPU and only use dGPU.
The problem is that the screen is size wrong and the dpi are incorrect .
Can anyone guide me on how to set the dpi and the screen size.
The ArchWiki says " Note: If you are using the proprietary NVIDIA driver, you may have to put Option "UseEdidDpi" "FALSE" under Device or Screen section to make it take effect."
Can anyone tell me where the device or the screen section is?

I don’t use optimus-manager

Yeah, I got it. I was just describing what worked and why, hoping that would give some info. IDK the mux switch method.

The ArchWiki says " Note: If you are using the proprietary NVIDIA driver, you may have to put Option "UseEdidDpi" "FALSE" under Device or Screen section to make it take effect."

I guess those are parameters passed at nvidia config files like xorg.conf.nvidia, but again IDK how mux switch deals with the config files

1 Like

Alright thanks.
I just switched back to Windows for now as I need a stable OS for the upcoming exams.
I guess I’ll wait for the 5.16 kernel release which fixes some issues with my laptop(wifi and brightness) without using workarounds.

1 Like

Thanks man I had the same issue with brightness (backlight control) and the 5.16 kernal fixed it, yay one less issue.

1 Like