Weird problem about restart

I have very weird problem i cant restart my computer on linux but i can on windows this happeing on all linux os i dont why i can anyone help me i dont want always shut dows to boot in windows
if you need log tell me becuase i dont know which you need log to fix this problem

DO you mean you dont get an entry in the bootoader to start Windows and need to change the bootsettings (at the start of the pc) to boot into Windows?

Which bootloader are you using?

Grub or something else?
Eufi or Legacy?

When i click restart on linux doesnt anything happen black screen i am using grub uefi

So you want to restart Linux to boot into Windows instead of shutdown and start the pc again.

What WM/Desktop are you using? I mean XFCE, Plasma, I3, Sway etc.

Does it work when you reboot with “systemctl reboot” in a terminal?

i am using XFCE i didnt try but i tried sudo reboot -f
now tried systemctl reboot same

When you say you can’t, what happens? You click restart and nothing? Or do you get an error message?

And please start to give your basic information following this topic:

Hi and welcome,

on very rare systems that could happen.

You can set which type of reboot you want to use in /etc/default/grub on line GRUB_CMDLINE_LINUX="".

        reboot=         [KNL]
                        Format (x86 or x86_64):
                                [w[arm] | c[old] | h[ard] | s[oft] | g[pio]] \
                                [[,]s[mp]#### \
                                [[,]b[ios] | a[cpi] | k[bd] | t[riple] | e[fi] | p[ci]] \
                        Where reboot_mode is one of warm (soft) or cold (hard) or gpio
                                        (prefix with 'panic_' to set mode for panic
                                        reboot only),
                              reboot_type is one of bios, acpi, kbd, triple, efi, or pci,
                              reboot_force is either force or not specified,
                              reboot_cpu is s[mp]#### with #### being the processor
                                        to be used for rebooting.

I would try the option:

reboot=efi or reboot=bios

for example.


sudo update-grub

after modifying the grub file and reboot with that option to activate it.

Noting happen black screen no error message

a poweroff works I understand.
how about a dirty reboot with reboot -ff (yes 2 f)

I tried doesnt work

Anything in the logs?

journalctl -b -0 | cat