Weird issue with with keyboard/mouse

Hello. I’ve got an issue where my mouse and keyboard stops working in GDM. I have to plug in a usb drive to get my mouse and keyboard back. I’ve tried using a different mouse or keyboard but that doesn’t fix the problem. How do I fix this without having to plug in a usb drive everytime I boot up?

:+1: Welcome to Manjaro! :+1:

  1. Please read this:
    How to provide good information
    and post some more information so we can see what’s really going on. Now we know the symptom of the disease, but we need some more probing to know where the origin lies…

  2. An inxi --admin --verbosity=7 --filter --no-host --width would be the minimum required information… (Personally Identifiable Information like serial numbers and MAC addresses will be filtered out by the above command)

  3. Are the mouse and keyboard plugged into the back and the USB drive in the front?

    • If yes, have you tried front ports already?
    • If no, have you tried different ports already? (some machines come with USB2 and 3 ports: try the lowest version ports for the keyboard/mouse combo)


P.S. If you enter a bit more details in your profile, we can also see which Desktop Environment you’re using, which CPU/GPU or Kernel, … you have without typing it every time