Warthunder broken again

Warthunder is broken again. Steam is flatpack, i login manually every time, it complains about libc and libpthread … i dont know where to go from here. Manjaro has been a poor platform for gaming for me. I am disappointed.

Steam Flatpak may have old libraries included… use the normal version :wink:

pamac install steam

no, last time i had steam installed, it used to break at every major update. absolutely not going there

Well no idea :man_shrugging: I use steam and nothing breaks there. Only last time freetype2 was newer than expected and that results in not displaying the game library. However… I could downgrade it or update steam to beta version and now it is fixed on stable.

On Manjaro you are on cutting edge software and that could also mean that software could break because of newer libraries…

If this is no-go for you then use Ubuntu, which is officially supported by steam and has fixed release model, but you have not the newest software. So, you decide.

About the flatpak: you can report Issues here: Issues · flathub/com.valvesoftware.Steam · GitHub

1 Like

That should not happen. Only time Steam has broken due to an update was only the one a few days ago, and it was a very easy 30 second fix.

Use the provided Manjaro Steam package then see if the issue occurs.

so steam is actually working this time around, warthunder is broken, because something changed in the system, and maybe a couple of libraries went missing. I need the crisp packages in Manjaro, but it seems that keeps breaking software that is not directly shipped by manjero. this is a big problem. older versions of libraries can be left safely on the disk, after all, linux libraries are versioned for exactly that reason.

that will also mean to fresh reinstall warthunder, losing all the settings. not really a viable option. and there are no guarantees the repository steam isn’t going to break next month. as it did before several times.

I do not see this in the known issues for the past releases, please link to it. Like I mentioned, only known confirmed issue I see is the one that happened a few days ago and had an easy fix.

just work with me to fix the current installation. I need help with this.

What system do you have?

inxi -Fazy


  Kernel: 5.12.19-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.12-x86_64 
  root=UUID=b1beb20b-cc4f-48d6-b4dd-8af0c2d1c655 rw quiet apparmor=1 
  security=apparmor resume=UUID=3cf867c8-0a8f-4184-8734-723e7fc75c34 
  udev.log_priority=3 nordrand 
  Desktop: KDE Plasma 5.22.5 tk: Qt 5.15.2 wm: kwin_x11 vt: 1 dm: SDDM 
  Distro: Manjaro Linux base: Arch Linux 
  Type: Desktop Mobo: Micro-Star model: MEG X570 ACE (MS-7C35) v: 1.0 
  serial: <filter> UEFI: American Megatrends LLC. v: 1.D0 date: 01/22/2021 
  Info: 8-Core model: AMD Ryzen 7 3800X bits: 64 type: MT MCP arch: Zen 2 
  family: 17 (23) model-id: 71 (113) stepping: 0 microcode: 8701021 cache: 
  L2: 4 MiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 124849 
  Speed: 2914 MHz min/max: 2200/3900 MHz boost: enabled Core speeds (MHz): 
  1: 2914 2: 2110 3: 2040 4: 3613 5: 2200 6: 2199 7: 2199 8: 2200 9: 2057 
  10: 2057 11: 2197 12: 2081 13: 2200 14: 2199 15: 2968 16: 3606 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP: 
  conditional, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
  Device-1: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590] 
  vendor: Gigabyte driver: amdgpu v: kernel bus-ID: 2d:00.0 chip-ID: 1002:67df 
  class-ID: 0300 
  Device-2: Creative Live! Cam Chat HD [VF0700] type: USB 
  driver: snd-usb-audio,uvcvideo bus-ID: 5-1:2 chip-ID: 041e:4088 
  class-ID: 0102 serial: <filter> 
  Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: 
  loaded: amdgpu,ati unloaded: modesetting alternate: fbdev,vesa 
  display-ID: :0 screens: 1 
  Screen-1: 0 s-res: 4480x1080 s-dpi: 96 s-size: 1185x285mm (46.7x11.2") 
  s-diag: 1219mm (48") 
  Monitor-1: DisplayPort-2 res: 1920x1080 hz: 60 dpi: 92 
  size: 531x298mm (20.9x11.7") diag: 609mm (24") 
  Monitor-2: HDMI-A-0 res: 2560x1080 hz: 60 dpi: 97 
  size: 673x284mm (26.5x11.2") diag: 730mm (28.8") 
  OpenGL: renderer: Radeon RX 570 Series (POLARIS10 DRM 3.40.0 
  5.12.19-1-MANJARO LLVM 12.0.1) 
  v: 4.6 Mesa 21.2.1 direct render: Yes 
  Device-1: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590] 
  vendor: Gigabyte driver: snd_hda_intel v: kernel bus-ID: 2d:00.1 
  chip-ID: 1002:aaf0 class-ID: 0403 
  Device-2: AMD Starship/Matisse HD Audio vendor: Micro-Star MSI 
  driver: snd_hda_intel v: kernel bus-ID: 2f:00.4 chip-ID: 1022:1487 
  class-ID: 0403 
  Device-3: Logitech Blue Microphones type: USB 
  driver: hid-generic,snd-usb-audio,usbhid bus-ID: 1-2.2:5 chip-ID: 046d:0ab7 
  class-ID: 0300 serial: <filter> 
  Device-4: Creative Live! Cam Chat HD [VF0700] type: USB 
  driver: snd-usb-audio,uvcvideo bus-ID: 5-1:2 chip-ID: 041e:4088 
  class-ID: 0102 serial: <filter> 
  Sound Server-1: ALSA v: k5.12.19-1-MANJARO running: yes 
  Sound Server-2: JACK v: 1.9.19 running: no 
  Sound Server-3: PulseAudio v: 15.0 running: yes 
  Sound Server-4: PipeWire v: 0.3.34 running: no 
  Device-1: Intel I211 Gigabit Network vendor: Micro-Star MSI driver: igb 
  v: kernel port: e000 bus-ID: 26:00.0 chip-ID: 8086:1539 class-ID: 0200 
  IF: enp38s0 state: down mac: <filter> 
  Device-2: Realtek RTL8125 2.5GbE vendor: Micro-Star MSI driver: r8169 
  v: kernel port: d000 bus-ID: 27:00.0 chip-ID: 10ec:8125 class-ID: 0200 
  IF: enp39s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
  Device-3: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel port: d000 
  bus-ID: 28:00.0 chip-ID: 8086:2723 class-ID: 0280 
  IF: wlo1 state: down mac: <filter> 
  Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 1-4:3 
  chip-ID: 8087:0029 class-ID: e001 
  Report: rfkill ID: hci0 rfk-id: 1 state: up address: see --recommends 
  Local Storage: total: 4.57 TiB used: 1.15 TiB (25.1%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 860 PRO 512GB 
  size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s 
  type: SSD serial: <filter> rev: 1B6Q scheme: GPT 
  ID-2: /dev/sdb maj-min: 8:16 vendor: Samsung model: SSD 860 PRO 512GB 
  size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s 
  type: SSD serial: <filter> rev: 1B6Q 
  ID-3: /dev/sdc maj-min: 8:32 vendor: Seagate model: ST2000DM008-2FR102 
  size: 1.82 TiB block-size: physical: 4096 B logical: 512 B speed: 3.0 Gb/s 
  type: HDD rpm: 7200 serial: <filter> rev: 0001 
  ID-4: /dev/sdd maj-min: 8:48 vendor: Seagate model: ST2000DM008-2FR102 
  size: 1.82 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  type: HDD rpm: 7200 serial: <filter> rev: 0001 
  ID-1: / raw-size: 459.43 GiB size: 451.22 GiB (98.21%) 
  used: 129.51 GiB (28.7%) fs: ext4 dev: /dev/sda2 maj-min: 8:2 
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) 
  used: 288 KiB (0.1%) fs: vfat dev: /dev/sda1 maj-min: 8:1 
  ID-3: /home raw-size: 1.82 TiB size: 1.82 TiB (100.00%) 
  used: 1.02 TiB (56.0%) fs: btrfs dev: /dev/sdc maj-min: 8:32 
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 17.21 GiB used: 0 KiB (0.0%) priority: -2 
  dev: /dev/sda3 maj-min: 8:3 
  System Temperatures: cpu: 52.2 C mobo: 40.0 C gpu: amdgpu temp: 50.0 C 
  Fan Speeds (RPM): fan-1: 0 fan-2: 1909 fan-3: 0 fan-4: 0 fan-5: 0 fan-6: 0 
  fan-7: 773 gpu: amdgpu fan: 712 
  Processes: 418 Uptime: 1h 12m wakeups: 0 Memory: 15.61 GiB 
  used: 3.66 GiB (23.5%) Init: systemd v: 248 tool: systemctl Compilers: 
  gcc: 11.1.0 clang: 12.0.1 Packages: 2034 pacman: 1987 lib: 514 flatpak: 39 
  snap: 8 Shell: Bash v: 5.1.8 running-in: konsole inxi: 3.3.06

I see there a lot of problems regarding to your issue and it 100% not Manjaro specific… For example here:

Error wainting for GPU Ryzen 3400G - Already Reported & Solved Issues - War Thunder - Official Forum

You need to add the json file to the startup options:

VK_ICD_FILENAMES=/usr/share/vulkan/icd.d/amdgpu_icd.json %command%

:warning: Check if it is the correct filename!

Maybe because it is a flatpak (sandboxed) it does not have access to this file of the system?

i guess that is not going to work in this case, the error message basically said i am running an outdated gpu drivers … which is nonsense

Not on a rolling release distro, no. If you’re holding back updating packages, that will cause a partial upgrade state which is not supported and will eventually cause breakage.

Tip: When pasting terminal output on Discourse forums, one can either…

  • Highlight it and use the Preformatted text </> toolbar button.

  • Add three backticks ` above and below the text (Markdown):


  • Use HTML:


I’ve done it for you this time. :wink:

cat /usr/share/vulkan/icd.d/radeon_icd.x86_64.json
    "ICD": {
        "api_version": "1.2.182",
        "library_path": "/usr/lib/libvulkan_radeon.so"
    "file_format_version": "1.0.0"

No, that is possible. Flatpaks provide its own driver and don’t use the system driver for vulkan.

For example Mesa on flatpak:


so, the idea is warthunder updated itself, but the seam flatpack didn’t, and now warthunder does not work

not sure, but could have happen here.

installed steam-manjaro , updated warthunder still the same problem. warthunder crashes at the same point with the same error report

Can you launch steam from the terminal by running steam then reproduce the crash, after this send the terminal output.


Run Steam like this:

steam > log.txt

That way all the contents get put to one file and it’s easy to share. This won’t show anything in the terminal, instead it’ll be pasted in the file in your home directory (assuming that’s where the terminal is pointing to)