Wanting to switch DE with reinstalling but I can't backup my files to a flash drive

Hello! I’m wanting to switch from KDE to GNOME and I heard that a fresh install is recommended, which I intend to do. However, I am having issues as I am not only unable to move files to my SanDisk Flash Drive but when I tried to fix that with (I think) chmod or chown, I now need that same drive whenever I try to boot into my Manjaro partition as I am dual-booting with Windows 10.

So, what I need help with is being able to move my files onto that flash drive, formatting it again is not an issue, so that I can reinstall Manjaro while keeping my files. I absolutely could backup all my files but I just prefer not, henceforth me requesting the forum’s help.

Thank you!

Sorry … but I am confused … you want to move your files onto a USB, but you dont want to backup files ?

No, I do want to backup my files by moving them onto my flash drive, preferably rather than uploading them to my Google Drive.

OK … so whats the issue ?

Why? How?

Maybe show us

lsblk -mp | sed -e "s/$HOSTNAME/HOST/gI" -e "s/$USER/USER/gI"

(edit - added pipe to hide possible identifiers)

PS. Just to jump the gun … I am guessing is something like this:
Root is RW, but all other drives are RO

/dev/loop0   55.3M root  disk    brw-rw----
/dev/loop1   55.4M root  disk    brw-rw----
/dev/loop2   14.5M root  disk    brw-rw----
/dev/loop3   30.9M root  disk    brw-rw----
/dev/loop4   30.9M root  disk    brw-rw----
/dev/sda    931.5G root  disk    brw-rw----
|-/dev/sda1   100M root  disk    brw-rw----
|-/dev/sda2 488.8G root  disk    brw-rw----
|-/dev/sda3     1K root  disk    brw-rw----
|-/dev/sda4   802M root  disk    brw-rw----
|-/dev/sda5  31.7G root  disk    brw-rw----
`-/dev/sda6 410.2G root  disk    brw-rw----
/dev/sdb     14.9G root  disk    brw-rw----
`-/dev/sdb1  14.9G root  disk    brw-rw----
/dev/sr0     1024M root  optical brw-rw----

/dev/sdb is my flash drive.

Below is what will happen after a long back screen when I boot into Manjaro from GRUB without the flash drive.

[ TIME] Time out waiting for device /dev/sdb1.
[DEPEND] Dependency failed for /run/media/brandonef/BRANDON'S.
[DEPEND] Dependency failed for Local File Systems.
You're in emergency mode.

Then it gives me commands to use after asking me to put in my password.

So that means the basic scenario is still that ‘root’ owns that usb/partition.
(as shown in the linked threads)
But the broader question is … why does your system depend on it?

I wouldn’t know; I just use Linux since I find it snappier compared to my Windows 10.

Going back to konsole, I found that I can use my up key to find all the inputs I’ve used when I first tried to remedy the issue. Is there any way I can export them so you can take a look?


history > myhistory.txt

If you want to share it I suggest using a pastebin-like command, ex:
cat myhistory.txt | curl -F 'file=@-' https://0x0.st

Related tutorial:
No-Install public command-line pastebin services

The second command assumes you ran the first.
cat outputs a files contents.
the | and everything after it is sending it to 0x0.st, a pastebin-like service.

The first one simply outputs the command history (which will show you your command history) to a local file of ‘myhistory.txt’.

So, assuming you made the file, then the second command is ‘read this - sending the content to 0x0’.
You could also skip all that and mix the two - history | curl -F 'file=@-' https://0x0.st.
(‘piping’ history directly the the 0x0 share)

I hope that makes it more clear.
(please see the link I left in the previous post)

Where is the myhistory.txt stored? There are lines I want to delete just for privacy reasons. If not, then no issue.

As no path was provided, it should be right in ‘current directory’ (pwd for print working directory).
By default, if you just opened a terminal, that would usually be your HOME.

Also, for being unable to edit a flash drive, this solution Advice Needed regarding Sudo/Permissions helped me. It used sudo chown username -R directory

https://0x0.st/i7oX.txt here you go!

Yeah … its about ownership … its in the docs and there are multiple threads on it because people skip the ones already existing.

EDIT. From your previous post …
Can you also share the contents of /etc/fstab ? Maybe thats where this is stemming from.

The links before weren’t helping and every time I did a google search about “manjaro can’t access flash drive (or usb)” it would be about installing not about permissions and flash drive storage management.

# /etc/fstab: static file system information.
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=9f99869b-17dc-4da5-aaff-a26a1ad672c4   /                                ext4   noatime    0 1 
/dev/sdb1                                   /run/media/brandonef/BRANDON'S   vfat   defaults   0 0

thats why.
but you are going to wipe and clean install anyways, so I suppose it doesnt matter.

(PS… you generally do not want to use anything other than UUID in fstab … things like sdb can change)

Just so I don’t make this mistake, if possible on GNOME, what did I do wrong and how to fix it if you don’t mind telling me? Thanks so much and in advance.

Its nothing super wrong.
You just set the device in fstab … which means the system expects the device to be there.
(also see my warning about not using relative titles like ‘/dev/sda’ as identifiers - they are not reliable)

If I understand correctly, you want to use the drive as both install media and backup. Install lutris ventoy to the drive, copy your ISO and create a directory for your files.