Wallpaper Resets After PlasmaShell Is Restarted (e.g. at Logout/Restart/ReplacePlasmaShell etc.)

I have/had a similar issue, but the issue has adapted/changed after trying new kernels so I thought maybe I should make a new post? If that was not the right option, I apologize.

This issue persists despite trying different kernels. My old issue was my wallpaper always being black at start – now the issue relates to the wallpaper always resetting to the default image.

Basically, plasmashell refuses to save my wallpaper settings, whatever I make them be (slideshow, a different manjaro image in the same folder as the default image, etc.). Restarting plasmashell just resets the wallpaper to the default, so does logging out and back in, or restarting my computer. Any other changes seem to be saved fine, it is simply the wallpaper settings that never are.

I have tried replacing plasmashell, quitting and restarting, renaming the plasma-orgwhatever file in .config to force a replacement that way, tried different kernels etc. . But the problem persists.

inxi --full --admin --verbosity=7 --filter --no-host
System:
  Kernel: 5.4.60-2-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.4-x86_64 
  root=UUID=87bc3162-9841-4275-9453-3640070c8bb5 rw quiet apparmor=1 
  security=apparmor udev.log_priority=3 
  Desktop: KDE Plasma 5.19.4 tk: Qt 5.15.0 info: latte-dock wm: kwin_x11 dm: SDDM 
  Distro: Manjaro Linux 
Machine:
  Type: Laptop System: Dell product: XPS 13 9300 v: N/A serial: <filter> Chassis: 
  type: 10 serial: <filter> 
  Mobo: Dell model: 077Y9N v: A00 serial: <filter> UEFI: Dell v: 1.1.0 
  date: 07/07/2020 
Battery:
  ID-1: BAT0 charge: 18.5 Wh condition: 51.6/51.0 Wh (101%) volts: 7.5/7.6 
  model: SMP DELL WN0N005 type: Li-poly serial: <filter> status: Discharging 
Memory:
  RAM: total: 15.23 GiB used: 2.02 GiB (13.3%) 
  RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
CPU:
  Topology: Quad Core model: Intel Core i7-1065G7 bits: 64 type: MT MCP 
  arch: Ice Lake family: 6 model-id: 7E (126) stepping: 5 microcode: 78 
  L2 cache: 8192 KiB bogomips: 23968 
  Speed: 1280 MHz min/max: 400/3900 MHz Core speeds (MHz): 1: 1163 2: 1129 3: 1158 
  4: 1163 5: 1161 6: 1088 7: 1196 8: 1117 
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat arch_capabilities 
  arch_perfmon art avx avx2 avx512_bitalg avx512_vbmi2 avx512_vnni avx512_vpopcntdq 
  avx512bw avx512cd avx512dq avx512f avx512ifma avx512vbmi avx512vl bmi1 bmi2 bts 
  clflush clflushopt cmov constant_tsc cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64 
  dtherm dts epb ept ept_ad erms est f16c flexpriority flush_l1d fma fpu fsgsbase 
  fxsr gfni ht hwp hwp_act_window hwp_epp hwp_pkg_req ibpb ibrs ibrs_enhanced ida 
  intel_pt invpcid invpcid_single lahf_lm lm mca mce md_clear mmx monitor movbe msr 
  mtrr nonstop_tsc nopl nx ospke pae pat pbe pcid pclmulqdq pdcm pdpe1gb pebs pge 
  pku pln pni popcnt pse pse36 pts rdpid rdrand rdseed rdtscp rep_good sdbg sep 
  sha_ni smap smep ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2 
  tpr_shadow tsc tsc_adjust tsc_deadline_timer tsc_known_freq umip vaes vme vmx vnmi 
  vpclmulqdq vpid x2apic xgetbv1 xsave xsavec xsaveopt xsaves xtopology xtpr 
  Vulnerabilities: Type: itlb_multihit status: KVM: Split huge pages 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 


Graphics:
  Device-1: Intel Iris Plus Graphics G7 vendor: Dell driver: i915 v: kernel 
  bus ID: 00:02.0 chip ID: 8086:8a52 
  Device-2: Realtek Integrated_Webcam_HD type: USB driver: uvcvideo bus ID: 3-9:3 
  chip ID: 0bda:5511 serial: <filter> 
  Display: x11 server: X.Org 1.20.8 compositor: kwin_x11 driver: intel 
  unloaded: modesetting alternate: fbdev,vesa display ID: :0 screens: 1 
  Screen-1: 0 s-res: 1680x1050 s-dpi: 96 s-size: 443x277mm (17.4x10.9") 
  s-diag: 522mm (20.6") 
  Monitor-1: eDP1 res: 1680x1050 hz: 60 dpi: 147 size: 290x180mm (11.4x7.1") 
  diag: 341mm (13.4") 
  OpenGL: renderer: Mesa Intel Iris Plus Graphics (ICL GT2) v: 4.6 Mesa 20.1.6 
  direct render: Yes 
Audio:
  Device-1: Intel Smart Sound Audio vendor: Dell driver: snd_hda_intel v: kernel 
  alternate: snd_sof_pci bus ID: 00:1f.3 chip ID: 8086:34c8 
  Sound Server: ALSA v: k5.4.60-2-MANJARO 
Network:
  Device-1: Intel Killer Wi-Fi 6 AX1650i 160MHz Wireless Network Adapter 
  vendor: Bigfoot Networks driver: iwlwifi v: kernel port: 4000 bus ID: 00:14.3 
  chip ID: 8086:34f0 
  IF: wlp0s20f3 state: up mac: <filter> 
  IP v4: <filter> type: dynamic noprefixroute scope: global broadcast: <filter> 
  IP v6: <filter> type: noprefixroute scope: link 
  WAN IP: <filter> 
Drives:
  Local Storage: total: 953.87 GiB used: 49.09 GiB (5.1%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/nvme0n1 model: SSDPEMKF010T8 NVMe INTEL 1024GB size: 953.87 GiB 
  block size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 
  serial: <filter> rev: 7003 scheme: GPT 
  Message: No Optical or Floppy data was found. 
RAID:
  Message: No RAID data was found. 
Partition:
  ID-1: / raw size: 390.62 GiB size: 383.49 GiB (98.17%) used: 49.01 GiB (12.8%) 
  fs: ext4 dev: /dev/nvme0n1p7 label: N/A uuid: 87bc3162-9841-4275-9453-3640070c8bb5 
  ID-2: /boot/efi raw size: 190.0 MiB size: 186.0 MiB (97.89%) 
  used: 76.4 MiB (41.1%) fs: vfat dev: /dev/nvme0n1p1 label: ESP uuid: 30DF-6832 
Swap:
  Alert: No Swap data was found. 
Unmounted:
  ID-1: /dev/nvme0n1p2 size: 128.0 MiB fs: <superuser/root required> label: N/A 
  uuid: N/A 
  ID-2: /dev/nvme0n1p3 size: 547.55 GiB fs: bitlocker label: N/A uuid: N/A 
  ID-3: /dev/nvme0n1p4 size: 990.0 MiB fs: ntfs label: WINRETOOLS 
  uuid: 3830AA4330AA07C8 
  ID-4: /dev/nvme0n1p5 size: 13.11 GiB fs: ntfs label: Image uuid: F812AA9A12AA5D7E 
  ID-5: /dev/nvme0n1p6 size: 1.30 GiB fs: ntfs label: DELLSUPPORT 
  uuid: BE181DA1181D59AB 
USB:
  Hub: 1-0:1 info: Full speed (or root) Hub ports: 1 rev: 2.0 speed: 480 Mb/s 
  chip ID: 1d6b:0002 
  Hub: 2-0:1 info: Full speed (or root) Hub ports: 4 rev: 3.1 speed: 10 Gb/s 
  chip ID: 1d6b:0003 
  Hub: 3-0:1 info: Full speed (or root) Hub ports: 12 rev: 2.0 speed: 480 Mb/s 
  chip ID: 1d6b:0002 
  Device-1: 3-5:2 info: Shenzhen Goodix FingerPrint type: <vendor specific> 
  driver: N/A interfaces: 1 rev: 2.0 speed: 12 Mb/s chip ID: 27c6:533c 
  Device-2: 3-9:3 info: Realtek Integrated_Webcam_HD type: Video driver: uvcvideo 
  interfaces: 5 rev: 2.0 speed: 480 Mb/s chip ID: 0bda:5511 serial: <filter> 
  Device-3: 3-10:4 info: Intel type: Bluetooth driver: btusb interfaces: 2 rev: 2.0 
  speed: 12 Mb/s chip ID: 8087:0026 
  Hub: 4-0:1 info: Full speed (or root) Hub ports: 6 rev: 3.1 speed: 10 Gb/s 
  chip ID: 1d6b:0003 
Sensors:
  System Temperatures: cpu: 41.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 237 Uptime: 1h 21m Init: systemd v: 246 Compilers: gcc: 10.2.0 
  Packages: 1477 pacman: 1461 lib: 398 flatpak: 6 snap: 10 Shell: Bash v: 5.0.18 
  running in: konsole inxi: 3.1.05

Thank you, and I am happy to delete this if it is deemed better to just stick to my older and still open post on the similar topic before.

1 Like

Hello,

have you tried this settings in Settings > Desktop Session ?

Have you checked permissions of the file ~/.config/plasma-org.kde.plasma.desktop-appletsrc ?

Thank you!

For Desktop Session, I had it at “restore previous session” – I just changed it to start with an empty session – is this an issue that would always happen with the restore previous session option? It is convenient to have my old firefox tabs open back up again and such.

It looks like permissions might be fine for that file (I did just run a sudo chown -R command on my home directory so maybe it wasn’t correct before), but I am no expert in interpreting that it is exactly as it should be – so here is my output of checking permissions:

ls -l plasma-org.kde.plasma.desktop-appletsrc 
-rw------- 1 keithcdodd keithcdodd 6075 Sep  5 14:51 plasma-org.kde.plasma.desktop-appletsrc

Sadly, even after changing my settings to “start with an empty session” I am still experiencing the same issue with no changes.

You can look at the file itself if contains the path to your wallpaper. Make sure, if is another partition that that partition is mounted before you start your session.

1 Like

Does this also happen if you create a new user and log in there? (E.G. kcdah2)

:innocent:

OK, it is not on another partition, but I did find something weird.

Hey Fabby! So, when I create a new user, the new user does not have the problem initially! This is good because it helped me narrow down the problem to a degree. Turns out, it’s only after applying a global theme that I love (KDE Sweet) that then this issue begins to occur!

On the new user (where the wallpaper was working as expected), I downloaded the global theme KDE sweet, and clicked to use desktop from theme (these changes it to the task bar format I like best with the theme). From then on, no matter how I change the wallpaper, it has an issue when I log out and back in. This remains true whether or not I uncheck the “use desktop from theme” option.

I wish I could figure out from there what the issue is, because I really like the look of the whole theme, but I want my wallpaper to work as expected too.

  • Remove the theme and file a bug with its developer.
  • Apply the theme changes manually to your main user (themes are just collections of other stuff like icons, wallpapers, cursors, …) until a fix gets published. Don’t apply the part of the theme that causes the issue (E.G. cursors…)

:scream:

3 Likes

Perfect – yes that worked. I just changed my global theme to default and clicked “use desktop from theme” on from that which fixed my wallpaper. Then I did what you said – changed my theme back to what I want while avoiding the aspect of the theme that broke it (for me, that was avoiding “use desktop from theme”) and making those changes I like manually instead.

Thanks again! I wouldn’t have been able to boil down the issue to a theme issue if it weren’t for everyone’s help here!

1 Like

@kcdah, why did you open two similar thread? :thinking:

Don’t you think one is enough? :wink:

1 Like

Yeah, I’m sorry! I messed up because I thought I had 2 different issues – one with rendering any wallpaper image only at reboot(all black), and one where the render gets stuck at the default image whenever I login/logout. When my first issue (all black at reboot) was fixed, I thought the fact that it was now all a default image whenever I logged out/in was a new issue at first. Turns out it was all due to the same thing.

should/can I delete one of the posts?

My apologies again.
:sweat:

I do not think there is any need; if it will be necessary, a moderator will join the two threads. I just wanted to point this out to you for the future. :relaxed:

1 Like

Thank you! In the future if I have similar problems, I will stick to staying in the same thread!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.