No Desktop Image After Boot

Small nuisance – For every time I turn on my computer, my desktop will be completely black. It still works, and appears to just be that it doesn’t load any desktop image. So every time I turn my computer on, I have to go back to configure desktop and select an image background again. Works fine then until next boot. Doesn’t seem to matter what the wallpaper type is or the picture selected.

Try close plasmashell, rename ~/.config/plasma-org.kde.plasma.desktop-appletsrc and start plasmashell.

Thank you for the help. I just want to clarify:

Run:

kquitapp5 plasmashell

And then you say to rename that file in .config, but rename it to what? I already have a ~/.config/plasma-org.kde.plasma.desktop=appletsrc ? Does it matter what I name it to?

Then I assume after that restart it with:

kstart5 plasmashell

Thank you

I just named it to something random, and restarted plasmashell. The desktop image was black/gone again. I added a picture again to the desktop and restarted the computer.

Unfortunately even after restart, it loaded a black desktop again (same issue as before), and automatically opened dolphin with it asking for a QML file (new behavior). I did not know what that was about so I simply closed it and added another desktop image again.

Rename plasma-org.kde.plasma.desktop-appletsrc to plasma-org.kde.plasma.desktop-appletsrc.bak for example to force plasmashell to recreate it.

If didn’t work, try start in console mode and remove in “~/.cache”, “plasmashell” folder and all “plasma*” files, and relogin in graphic mode.

plasmashell --replace and ‘kwin_x11 --replace’ are essential shortcuts - entered once in krunner, now just typing ‘pla’ or ‘kwi’ will bring them up - and it works in one line :wink:
otherwise, again in one line,
kquitapp5 plasmashell && kstart5 plasmashell

These also work well from mouse gestures :wink: one to kickstart compositing if it fails, the other to bring plasma back.

I tried this too (oddly, I couldn’t figure out how to log back into graphic mode from console mode, but I restarted my computer) and unfortunately the problem persists – on login I get a notification for the kdewallet, and a black desktop.

Thank you – I like the simplicity of this. Sadly, it did not fix my issue of the desktop starting with no image every time.

You can try the next narrow method.

  1. open ~/.config/plasma-org.kde.plasma.desktop-appletsrc in text editor like kate

  2. close plasmashell(kquitapp5 plasmashell)

  3. find in all sections named [Containments][ANY_NUMBER],not in [Containments][ANY_NUMBER] [Anything …], option named "wallpaperplugin=org.kde.image
    ", if don`t have any wallpaperplugin, write it.

  4. find all sections [Containments][ANY_NUMBER][Wallpaper][org.kde.image][General]
    for example if you have cection named “[Containments][24]” you need to have a section named “[Containments][24][Wallpaper][org.kde.image][General]”; if section not exist, create.

  5. write in thats sections “Image=file://Image full path” , for example :
    "[Containments][24][Wallpaper][org.kde.image][General]
    Image=file:///home/user/Images/wall-559.jpg "

    if Image= exist only write file://image full path
    *) dont touch anything else.

  6. save file.

  7. start plasmashell

  8. Good luck

Thank you.

Unfortunately that did not change the problem for me. I did have several issues though…

(1) several containments did not have a [Containments][#] section, so I added one for each and made sure to include the wallpaperplugin=org.kde.image. – hopefully that was the right call.

(2) Also, one of the containments was using a different wallpaperplugin, I think it was something like org.kde.potd. So I fixed that too.

(3) A few containments also did not have a section of [Containments[#][Wallpaper][org.kde.image][General] so I added those with an Image=file::// path, all of it being just the standard Autumn image to be safe.

After doing all that and restarting the plasma shell, it was still a black background. I tried restarting my computer and it was also still a black background, and I confirmed that the changes I had made to my config file were still there.

It`s always the same image? if it yes try with other. Maybe the name of image or path has something that plasma not undertand.
I dont have any ideas what will be the problem, Sorry.
Try changing compositor from opengl to raster or the last thing i would try is create a text file in image directory named “metadata.desktop” with de next content:

[Desktop Entry]
Name=Next
Name[ar]=التّالي
Name[bs]=Sljedeći
Name[ca]=Next
Name[ca@valencia]=Next
Name[cs]=Následující
Name[da]=Next
Name[de]=Next
Name[el]=Επόμενο
Name[en_GB]=Next
Name[es]=Next
Name[fi]=Next
Name[fr]=Suivant
Name[gl]=Seguinte
Name[hu]=Következő
Name[ia]=Proxime
Name[it]=Next
Name[ko]=Next
Name[lt]=Kitas
Name[nb]=Neste
Name[nds]=Nakamen
Name[nl]=Volgende
Name[nn]=Neste
Name[pa]=ਅੱਗੇ
Name[pl]=Dalej
Name[pt]=Next
Name[pt_BR]=Next
Name[ro]=Următor
Name[ru]=Next
Name[sk]=Ďalší
Name[sl]=Next
Name[sr]=Следећи
Name[sr@ijekavian]=Следећи
Name[sr@ijekavianlatin]=Sledeći
Name[sr@latin]=Sledeći
Name[sv]=Next
Name[tr]=Sonraki
Name[uk]=Next
Name[x-test]=xxNextxx
Name[zh_CN]=未来
Name[zh_TW]=下一個

X-KDE-PluginInfo-Name=Next
X-KDE-PluginInfo-Author=KDE Visual Design Group
X-KDE-PluginInfo-Email=
X-KDE-PluginInfo-License=LGPLv3

1 Like

The image does not matter. It’s as if on start up, plasma forgets to run a line of code to actually show the desktop image. No matter what it is/was. If there was a way I could run a start up command to show/select desktop image, that would also work. Because I can right click desktop configuration and set the image every time I login, but it’s just so tedious and not supposed to work like that.

The toolbar and latte dock and everything works fine at startup, it is only the desktop image.

My compositor is already at xrender instead of GL, because GL was giving me other issues.

I am sorry, I am confused on what the “image directory” is. Thanks!

Hi.

It happened also to me because my wallpaper was located in a different drive which needs to be mounted first. Are you sure your wallpaper is located in the same drive where Manjaro is installed?

1 Like

Thank you for the help – I guess I am unsure how to check that or quite what you mean by that.

I would assume so… I am dual booted, so I would think anything related to Manjaro would be in the same drive?

I am just trying to use a default desktop image from Manjaro, not my own image from something else, so I think that should be OK. Literally the default image I am trying to use works fine once I set it back up by going to configure desktop, it is just weird that it won’t be there after I restart my computer and then I have to set it up again…

I don’t know if it matters, but something I noticed is that each time I login, and it’s black, and then I configure desktop to get a wallpaper, it opens a new containment that it is using. I really don’t quite understand what containments are but still…

so yesterday it was Containment[39], but that doesn’t exist now, and is now Containment[40] on my .config/plasma-orgwhatever thing.

Maybe that helps reveal the issue – should it keep making a new containment?

Did you tried with different image and format?

Have you already tried to use a different default image? Can you try with a different theme?

Hello, yes I have tried with both different default images and formats (any of the default images, default slideshow, or picture of the days). Once set, any of these images or styles work completely fine, even when coming back from sleep or from locking the screen. But if I restart or shutdown and then turn on again later, it is a black screen again until I set the wallpaper once more.

I am unsure what a different theme would be… like a global theme? I use KDE Sweet – I can try a different global theme to see if that makes a difference – I hope not since I do enjoy this theme.

OK, I tried switching kernels, and also redeleting my .config/plasma-org_whatever and replacing the plasma shell.

The good news is that I do get a desktop image now on reboot, but it is always the default (as if it was completely reset) – so any changes to my desktop background is not reloaded or saved.

I wonder if it is a permissions thing? I had problems on a previous login profile in the past, so I made a new one and copied files over to the new login. This fixed my previous issues, but I have had weird permissions errors here and there… I wonder if there is something with this that is also a permissions error? But I wouldn’t know how to check or confirm that.

Note - even without restarting, simply quitting and restarting plasmashell deletes my wallpaper settings and starts the image again back at the default image. Similarly even logging out and back in again resets my desktop wallpaper to the default image!

Try for error log view in Konsole:
sudo dmesg|grep -i :warn
sudo dmesg|grep -i :err
systemctl --failed
journalctl -b 0
cat ~/.local/share/sddm/xorg-session.log

For fix permisions try in your home folder (~) : “sudo chown -R YOUR_USER:YOUR_USER HOMEDIR” where “YOUR_USER” is de user name of home, for example “sudo chown -R kcdah:kcdah /home/kcdah”.