Wallpaper and Desktop Context Menu missing

I have an issue on my Manjaro KDE installation that started 2-3 weeks back - I have no idea what caused it. The wallpaper is blacked out and the desktop context menu is also missing (Right-click on Desktop does nothing). I have two monitors and this issue is only on one of the monitors. Does anyone have any idea?

Welcome at the forum @xephrox. It would be nice if you could share some more information about your system, have a look into this post for details:

Apologies, I wasn’t sure what information would be required so I didn’t add anything. Some basic information below I guess:

$ inxi -b
System:    Host: manjaro Kernel: 5.7.15-1-MANJARO x86_64 bits: 64 Desktop: KDE Plasma 5.19.4 
           Distro: Manjaro Linux 
Machine:   Type: Laptop System: ASUSTeK product: G752VSK v: 1.0 serial: <superuser/root required> 
           Mobo: ASUSTeK model: G752VSK v: 1.0 serial: <superuser/root required> 
           UEFI: American Megatrends v: G752VSK.305 date: 04/29/2019 
Battery:   ID-1: BAT0 charge: 85.5 Wh condition: 89.8/96.5 Wh (93%) 
CPU:       Quad Core: Intel Core i7-7820HK type: MT MCP speed: 900 MHz min/max: 800/3900 MHz 
Graphics:  Device-1: NVIDIA GP104BM [GeForce GTX 1070 Mobile] driver: nvidia v: 440.100 
           Device-2: Realtek USB2.0 HD UVC WebCam type: USB driver: uvcvideo 
           Display: x11 server: X.Org 1.20.8 driver: nvidia resolution: 1: 2560x1440~60Hz 
           2: 2560x1440~144Hz 
           OpenGL: renderer: GeForce GTX 1070/PCIe/SSE2 v: 4.6.0 NVIDIA 440.100 
Network:   Device-1: Intel Wireless 8260 driver: iwlwifi 
           Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8169 
Drives:    Local Storage: total: 953.87 GiB used: 52.66 GiB (5.5%) 
Info:      Processes: 260 Uptime: 16h 21m Memory: 31.32 GiB used: 5.19 GiB (16.6%) Shell: Bash 
           inxi: 3.1.05

Monitor Information:

$ xrandr
Screen 0: minimum 8 x 8, current 5120 x 1440, maximum 32767 x 32767
DP-0 disconnected (normal left inverted right x axis y axis)
DP-1 disconnected (normal left inverted right x axis y axis)
DP-2 connected (normal left inverted right x axis y axis)
   3840x2160     60.02 +
HDMI-0 connected 2560x1440+2560+0 (normal left inverted right x axis y axis) 600mm x 340mm
   3840x2160     60.00 +  59.94    50.00    30.00    29.97    25.00    23.98  
   2560x1440     59.95* 
   1920x1080     60.00    60.00    59.94    29.97    23.98    60.00  
   1600x900      60.00  
   1280x1024     60.02  
   1280x800      59.81  
   1280x720      60.00    59.94  
   1152x864      60.00  
   1024x768      60.00  
   800x600       60.32  
   720x480       59.94  
   640x480       59.94    59.93  
DP-3 connected primary 2560x1440+0+0 (normal left inverted right x axis y axis) 597mm x 336mm
   2560x1440    144.00*+ 120.00    59.95    59.95  
   1920x1080    119.88    60.00    59.94    50.00  
   1680x1050     59.95  
   1440x900      59.89  
   1280x1024     75.02    60.02  
   1280x960      60.00  
   1280x800      59.81  
   1280x720      60.00    59.94    50.00  
   1152x864      75.00  
   1024x768      75.03    70.07    60.00  
   800x600       75.00    72.19    60.32    56.25  
   720x576       50.00  
   720x480       59.94  
   640x480       75.00    72.81    59.94  
DP-4 disconnected (normal left inverted right x axis y axis)

Please advise if any other information is required.

The issue occurs on DP-3 display. The desktop wallpaper turned black and right-clicking the desktop doesn’t do anything. The other monitor (HDMI-0) is working fine and I can see the desktop and the context menu.

Below is a screenshot:

https[://]forum.manjaro[dot]org/uploads/default/original/2X/c/ce8069a4e973aef6e77af1a86d592d36d23960bd.jpeg

Not really sure how helpful this is.

P.S. for some reason I can neither insert images nor links in a post.

Update: It’s weird but I found a temporary fix. If I disconnect and reconnect the Display Port the issue is fixed till the next reboot. Hopefully this helps with finding a permanent solution.