Wacom tablet seen in xsetwacom not as a wacom device, tablet "working"

I’m kinda new to Linux so sorry in advance for some stupid things I say.

I have a graphic tablet Wacom CTL-472. It “works” - My screen resolution is mapped to my tablet, if I move my pen to some position, cursor also goes there. If I touch the tablet or press the button on pen, the event of pressing it stays on the whole time, or rapidly clicks on screen.

I have installed kcm-wacomtablet, libwacom and xf86-input-wacom. I have Wacom tablet finder which is something I already had and from what I’ve seen on other threads, it’s better not to use because it disables two files for Wacom.

Running xsetwacom -v --list devices I get

... Found device 'Wacom One by Wacom S Pen' (13).
... 'Wacom One by Wacom S Pen' (13) is not a wacom device.

at the end of output. I tried running it on kernels

  • 5.19
  • 5.18
  • 5.15
  • 4.19
    with the same result.

Tablet works fine under windows, with both the official drivers as well as the OpenTabletDriver.

However OpenTabletDriver, installed through git clone (pamac install returned error for home directory not found), reads the tablet fine, I can set working dimensions and the click problem is still there, and now the cursor “teleport’s” vertically and horizontally when I try to stay in one place. This worked right after installing and rebooting PC - didn’t modify anything or replug my tablet.


Don’t use that if you want to have a working tablet and configure the buttons. See here

Don’t go that route either. You don’t need that, plus that dotnet dependency will lead you to more troubles later.
Also please read the topic i pointed out and if you have questions, just let me know.
I’m sure the ID is already there, no ned to modify the /usr/share/X11/xorg.conf.d/70-wacom.conf either
See that CTL-472 is already supported

Delete those files i mentioned in the other post, reconnect tablet and use KCM-Wacom only. Callibration also should work AFAIK, so there should be no funky anything about it.

I removed OpenTabletDriver and it’s files as well.

I plugged my tablet to USB2 in my motherboard, nothing changed. The Wacom Tablet service is running

I tried changing 70-wacom.conf MatchUSBID to match my 472 ID but the results of xsetwacom -v --list devices didn’t change at all, and did nothing.

I don’t have the files you’ve mentioned. I’ve tried running sudo find / | grep wacom and sudo find / | grep tablet in hopes of finding them in different location, but no. I installed input-wacom (through sudo pacman -S base-devel linux-headers like it said on github page Installing input wacom from source · linuxwacom/input-wacom Wiki · GitHub), updated kcm-wacomtablet and xf86-input-wacom, rebooted and re plugged my tablet. Results are the same.

I can still move my pen fine, my screen is mapped to whole tablet area, and the click problem is still there.

See if this will help

also discussed here

and here

Let me know if that is NOT the click issue you are talking about.

The way xsetwacom -v --list devices shows some information can be ignored if everything else is working.

The pen problem you mentioned in 2nd thread (I can’t put links in posts now) is not what I have. When I touch the tablet with pen, or when I press the buttons on the pen, cursor works like I’m holding left click. It occurs everywhere, on desktop, browser, dolphin and other apps.
Now, because the tablet isn’t registered in system settings, I can’t set working area on my tablet, or how buttons and pen works.
Manjaro registers pressing when I actually touch the tablet with pen, or press button on pen.
When I plug in the tablet, nothing happens until I start moving my pen.Moving pen works great, the problem is now that I can’t make my area smaller, and the issue with pressing.

The teleportation I had with OpenTabletDriver isn’t there now. My screen is mapped to my whole tablet and works great, no delays, cursor “swimming” or anything.

I’m on Plasma X11 session all the time.

You see this kind of notification in Graphic Tablet Settings ?

Or is a different, with different error?

In principle, there should be a way to create a profile and then manually set the Stylus Button Mapping.

Now, the thing is, while the libwacom and xf86-input-wacom have the support for that device ID, maybe the kcm-wacomtablet does not have the proper files. Few years back i had to do it myself and then my patches got adopted the project. The comment i left from 8 years ago is still there wacom tablet - KDE Store and points to a short video i made … but is irelevant this days, but maybe then there is a way to open an issue here System / Wacom Tablet KCM · GitLab to add the template for your tablet …