VLC Stutters when Seeking?

My VLC stutters (even for this humble 480p reading of Arthur C Clarke’s A Walk in the Dark.

This is surprising to me given my system specs (the file is local, not network) and is on my NVME hard drive.

I would not expect such seeking issues, which are only compounded when I view my 1080p school material.

Here is a video of it in action at various speeds: https://youtu.be/Gf0ixc14Ulw

How can I resolve this?

VLC Options:

System Specs:

  Host: MidnightStarSign Kernel: 5.9.11-3-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 10.2.0 Desktop: KDE Plasma 5.20.4 Distro: Manjaro Linux 
  Type: Desktop Mobo: ASUSTeK model: PRIME X570-PRO v: Rev X.0x 
  serial: <superuser/root required> UEFI: American Megatrends v: 1407 
  date: 04/02/2020 
  Info: 6-Core model: AMD Ryzen 5 3600 bits: 64 type: MT MCP arch: Zen 2 
  L2 cache: 3072 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 94842 
  Speed: 3950 MHz min/max: 2200/3950 MHz boost: enabled Core speeds (MHz): 
  1: 3950 2: 3950 3: 3950 4: 3950 5: 3950 6: 3950 7: 3950 8: 3950 9: 3950 
  10: 3950 11: 3950 12: 3950 
  Device-1: AMD Navi 10 [Radeon RX 5600 OEM/5600 XT / 5700/5700 XT] 
  vendor: ASRock driver: amdgpu v: kernel bus ID: 0b:00.0 
  Display: x11 server: X.Org 1.20.10 driver: amdgpu,ati 
  unloaded: modesetting,radeon resolution: 1: 1920x1080~60Hz 2: 1920x1080~60Hz 
  3: 1920x1080~60Hz 
  OpenGL: renderer: AMD Radeon RX 5600 XT (NAVI10 DRM 3.39.0 5.9.11-3-MANJARO 
  LLVM 11.0.0) 
  v: 4.6 Mesa 20.2.3 direct render: Yes 
  Device-1: AMD Navi 10 HDMI Audio driver: snd_hda_intel v: kernel 
  bus ID: 0b:00.1 
  Device-2: AMD Starship/Matisse HD Audio vendor: ASUSTeK driver: snd_hda_intel 
  v: kernel bus ID: 0d:00.4 
  Device-3: Microdia USB 2.0 Camera type: USB driver: snd-usb-audio,uvcvideo 
  bus ID: 7-2:3 
  Sound Server: ALSA v: k5.9.11-3-MANJARO 
  Device-1: Intel I211 Gigabit Network vendor: ASUSTeK driver: igb v: kernel 
  port: f000 bus ID: 05:00.0 
  IF: enp5s0 state: up speed: 1000 Mbps duplex: full mac: 24:4b:fe:5b:08:2a 
  Local Storage: total: 4.62 TiB used: 1.82 TiB (39.3%) 
  ID-1: /dev/nvme0n1 vendor: Western Digital model: WDS100T2B0C-00PXH0 
  size: 931.51 GiB 
  ID-2: /dev/sda vendor: Seagate model: ST2000LM015-2E8174 size: 1.82 TiB 
  ID-3: /dev/sdb vendor: Seagate model: ST380815AS size: 74.51 GiB 
  ID-4: /dev/sdc vendor: Toshiba model: MQ01ABD100 size: 931.51 GiB 
  ID-5: /dev/sdd vendor: Seagate model: ST1000LM035-1RK172 size: 931.51 GiB 
  ID-1: / size: 767.00 GiB used: 312.69 GiB (40.8%) fs: btrfs dev: /dev/dm-0 
  ID-2: /home size: 767.00 GiB used: 312.69 GiB (40.8%) fs: btrfs dev: /dev/dm-0 
  ID-1: swap-1 type: partition size: 64.00 GiB used: 0 KiB (0.0%) dev: /dev/dm-1 
  System Temperatures: cpu: 45.8 C mobo: N/A gpu: amdgpu temp: 45.0 C 
  Fan Speeds (RPM): N/A gpu: amdgpu fan: 0 
  Processes: 524 Uptime: 5h 27m Memory: 31.33 GiB used: 9.47 GiB (30.2%) 
  Init: systemd Compilers: gcc: 10.2.0 clang: 11.0.0 Packages: 1813 Shell: Bash 
  v: 5.0.18 inxi: 3.1.08

Maybe this thread is related, although they are talking about performance with games, it all is related to performance of your GPU IMHO :wink:

This is almost always related to how VLC sets its output and/or (accelerated) decoding.
The ‘automatic’ isnt always great.
Just set it to whatever you prefer or support - vaapi or vdpau or … well X11 isnt accelerated but almost always works for example.

Also … to be honest … for reasons like this I havent used VLC on linux in years.
(I like smplayer)

Even disabling acceleration and restarting doesn’t seem to do the trick :frowning:

But disabling GPU hardware acceleration shows the same issue :smiley:

Not just “Hardware-accelerated decoding” but “Output” preference.

You are lucky yours only produces the seek-stutter issue.
A common one is also the “video starts, but freezes after a few frames and audio continues” … much more annoying. :wink:

Like, as in “Simple Settings” -> Audio -> Output?

As in *

Simple Settings -> Video* -> Display -> Output

I think it helped somewhat, but it still largely has the same issue using the VDPAU output with any hardware acceleration (or none, I tried that as well) :smiley:

I didnt say to use vdpau … I said to check that setting as ‘automatic’ is often not sufficient.
I dont know your system or packages or anything to be able to tell you which output is best.
(I guess I could mention common fall-back ones, like when running linux through crouton on a chromebook … were XCB [X11] or OpenGL)

Also take care to restart VLC after making changes … its odd in the way it applies, so a new setting may appear to function, but video will be broken on the next file you open.

Ah I tried a bunch of others too, it didn’t appear to matter :smiley:

Please see my ninja-edit above.

Also … why not try smplayer? :wink:

Smpllayer seems to work well as well :smiley: