VLC / SMB - Watching videos via network-computer

Looking at it again, I don’t think %20 is valid. If you have a space in a directory or file name you have to use \

Like this: my\ file\ with\ spaces\ in\ the\ name

So try:
sudo mount -t cifs -o user=aahmad //asifs-mac-mini.local/asifs\ hd /mnt/

1 Like

@NGr - this worked perfectly! So, I am now able to mount my media drive and BOTH VLC and MPV are now able to play videos correctly. So, I guess does this mean whatever mechanism Gnome Files Utility does mounting, does NOT work correctly OOTB?

At this point, what’s the proper way to auto mount my server? I did some reading on modifying the fstab config here:

But I am unable to get things working for some reason. Any help you could provide would be greatly appreciated!

Looking at the Arch wiki, in the fstab, spaces in names should be replaced with \040

See Samba - ArchWiki

Thanks @NGr, so it worked for one session. I then restated and now I am getting permission denied:


//asifs-mac-mini.local/asifs\040hd	/home/aahmad/Asifs-Mac-Mini	cifs _netdev,username=aahmad,password=xxxxx 0 0

When I try to initiate the mount, I get a permission denied:

mount /home/aahmad/Asifs-Mac-Mini                                                                                                                                
mount.cifs: permission denied

Is there something else I need to do to get this working properly? Like I said, it worked initially, but now does not for some reason.

Thanks again for all your time and help, it is greatly appreciated!

Update, this worked:

sudo mount /home/aahmad/Asifs-Mac-Mini  

So, is there a trick here for getting my normal user (who should be an admin) to get this to work without sudo? Essentially, so it mounts correctly on boot using fstab?

What could be happening, particularly if you are on WiFi, is that the mount is attempted before the network is up.

hmm, but wouln’t it work after I’m botted in? I still have to ‘sudo’ to get it to mount properly.

I don’t think it keeps trying after it fails.

Reading about this, it appears you can add _netdev to the options sections of your fstab line, this is supposed to prevent the system from attempting to mount this filesystem until the network is up.

Another way around it would be to make a script with sudo mount -a and have that run after a period of time after booting.

So, I do have “_netdev” in my fstab line:

//asifs-mac-mini.local/asifs\040hd	/home/aahmad/Asifs-Mac-Mini	cifs _netdev,username=aahmad,password=xxxxx 0 0

Also, I caught the following when I restarted during boot-up time:

I’m not 100% sure if it’s a timing issue with wifi, but it seems like it’s a permission issue from the above screenshot? Is there a verbose log or some additional debug logging I can turn on to get more details?

Thanks again @NGr !

I believe the Dependency failed for Remote File System can still mean that the network wasn’t up before the mount was attempted. If typing sudo mount -a causes the drive to be mounted then the line in the fstab is correct.

You might be better off reading about systemd mount, I think there is a How To on this forum.

It wasn’t a How To, it was a blog I read. I have found it:

Hello. Thanks for answering.
What I mean by what Garuda does and Manjaro doesn’t, is because I want Manjaro to do it just as easy and uncomplicated. In Garuda I just run Dolphin, I scan my network to get to the NAS and I double click on the desired video and it starts playing with VLC without any problems. This is also achieved from the VLC itself. With Manjaro I only get an error message concerning the SMB that I still don’t know how to solve. To tell the truth, I’m more interested in using Manjaro. I want to switch from Windows 10 to this system, but first I’m trying to get everything that interests me to work. The VLC error message is the following, how do I solve it, what should I install?

I have Manjaro KDE installed.

I appreciate your kind responses.

PS: Ah, I already uninstalled the VLC and reinstalled it with all its suggested dependencies and nothing yet.

Do you have manjaro-settings-samba installed?

Installing kio-fuse works for me

Yes, I do

No change after installing ‘kio-fuse’ package.

Sorry,I don’t notice that it’s a DE related problem as you mentioned VLC / SMB - Watching videos via network-computer - #16 by A4orce84.

kio-fuse is from KDE framework,so it’s not working in Gnome.

Sorry for the wrong suggestion.