VLC / SMB - Watching videos via network-computer

Yes I agree that the problem is likely with the smb share, hence my recommendation to mount using systemd mount units or fstab. You could mount using the terminal, which will not persist after reboot as well:
sudo mount -t cifs -o user=user-id-for-access //remote-share-location /local-mount-point (user= needed if no public sharing, password will be prompted - can omit if not needed)

I have no idea why the file format being incorrectly determined would happen with mounting using your file manager though. If you force the file type, you can then check whether interpretation of the file type is the route cause of the issue issue with the mount as you have it, or whether there is something more to it. This would maybe help track down why it doesn’t work the way you have it set up currently. Best of luck!

Makes sense, I’ll try mounting it manually like you suggested. Also, how do I “force” the file-type? Is there a special command for that as well?

I think the option for forcing the format is --demuxer-lavf-format=, so e.g. entering mpv --demuxer-lavf-format=avi might get the video playing with your current setup.

If the manual mount works, then you know that the problem is with the file manager mount; if forcing the format works with your current setup, then it specifically is a problem with that being read from your current smb shares. I would again recommend sticking with the systemd or fstab option for mounting the shares in the longer term - less likely to run into performance issues or bugs in my experience. Hope you get it working :slight_smile: .

I also have the same problem with VLC and Manjaro and I have not been able to solve it since I am new to Linux. But, I recently installed Garuda and interestingly the VLC has no problems. So what does Garuda have that Manjaro doesn’t?

PS I’m sorry for my English, my mother tongue is Spanish.

That’s a question for the Garuda forums.

My answer? A lot of unnecessary things installed by default that normally should be optional.

Tip: Always check optional dependencies when installing new packages.

So here’s something interesting as a mini-update:

So, after the last comment from @hugola, I decided before I do any type of mounting, what if I created 2 live Manjaro USB’s one with Manjaro Gnome and one with Manjaro KDE, and try to play the video over my SMB share:

Manjaro-Gnome using Gnome Videos App:

Same behavior as my original post, but with a different error that is catered to the Gnome Videos application.

Manjaro-KDE using VLC Media Player:

It works in KDE with NO issues!

@Yochanan - I don’t know if it’s possible to somehow get the Manjaro KDE Team to talk to the Manjaro Gnome Team, but this definitely works on a live USB (aka OOTB) on KDE and not Gnome. Not sure if this is a deeper issue that should be investigated, but I wanted to bring it up so everyone has all the pertinent details and information.

I will try the other suggestions of mounting and forcing the .AVI file-type, but I just wanted to see what the results were with Gnome vs. KDE with no custom configurations and a ‘vanilla’ Live USB experience.

Hey @summrum,

Trying to do this, and I get the following output:

sudo mount -t cifs -o user=aahmad smb://asifs-mac-mini.local/asifs%20hd /mnt/                                                                               
Mounting cifs URL not implemented yet. Attempt to mount smb://asifs-mac-mini.local/asifs%20hd

When I then CD into this /mnt directory, I do not see the mount there. Not sure if I am executing this correctly?

Any help would be greatly appreciated!

I think it failed because you put smb: in the path. Try with that removed.

Getting closer…


sudo mount -t cifs -o user=aahmad //asifs-mac-mini.local/asifs%20hd /mnt/                                                                          
Password for aahmad@//asifs-mac-mini.local/asifs%20hd: 
mount error(22): Invalid argument
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs) and kernel log messages (dmesg)

In your log, can you see what the invalid argument was? journalctl -b | grep CIFS should show entries with “CIFS” from your current boot, for example. It may possibly be the lack of version specified (vers=), but your log should show what the issue is.

Looking at it again, I don’t think %20 is valid. If you have a space in a directory or file name you have to use \

Like this: my\ file\ with\ spaces\ in\ the\ name

So try:
sudo mount -t cifs -o user=aahmad //asifs-mac-mini.local/asifs\ hd /mnt/

1 Like

@NGr - this worked perfectly! So, I am now able to mount my media drive and BOTH VLC and MPV are now able to play videos correctly. So, I guess does this mean whatever mechanism Gnome Files Utility does mounting, does NOT work correctly OOTB?

At this point, what’s the proper way to auto mount my server? I did some reading on modifying the fstab config here:

But I am unable to get things working for some reason. Any help you could provide would be greatly appreciated!

Looking at the Arch wiki, in the fstab, spaces in names should be replaced with \040

See Samba - ArchWiki

Thanks @NGr, so it worked for one session. I then restated and now I am getting permission denied:


//asifs-mac-mini.local/asifs\040hd	/home/aahmad/Asifs-Mac-Mini	cifs _netdev,username=aahmad,password=xxxxx 0 0

When I try to initiate the mount, I get a permission denied:

mount /home/aahmad/Asifs-Mac-Mini                                                                                                                                
mount.cifs: permission denied

Is there something else I need to do to get this working properly? Like I said, it worked initially, but now does not for some reason.

Thanks again for all your time and help, it is greatly appreciated!

Update, this worked:

sudo mount /home/aahmad/Asifs-Mac-Mini  

So, is there a trick here for getting my normal user (who should be an admin) to get this to work without sudo? Essentially, so it mounts correctly on boot using fstab?

What could be happening, particularly if you are on WiFi, is that the mount is attempted before the network is up.

hmm, but wouln’t it work after I’m botted in? I still have to ‘sudo’ to get it to mount properly.

I don’t think it keeps trying after it fails.

Reading about this, it appears you can add _netdev to the options sections of your fstab line, this is supposed to prevent the system from attempting to mount this filesystem until the network is up.

Another way around it would be to make a script with sudo mount -a and have that run after a period of time after booting.

So, I do have “_netdev” in my fstab line:

//asifs-mac-mini.local/asifs\040hd	/home/aahmad/Asifs-Mac-Mini	cifs _netdev,username=aahmad,password=xxxxx 0 0

Also, I caught the following when I restarted during boot-up time:

I’m not 100% sure if it’s a timing issue with wifi, but it seems like it’s a permission issue from the above screenshot? Is there a verbose log or some additional debug logging I can turn on to get more details?

Thanks again @NGr !

I believe the Dependency failed for Remote File System can still mean that the network wasn’t up before the mount was attempted. If typing sudo mount -a causes the drive to be mounted then the line in the fstab is correct.

You might be better off reading about systemd mount, I think there is a How To on this forum.