VL805 usb 3 pcie card not working

VL805 usb 3 pcie card not working. adding iommu=soft isn’t working either. do u guyz know how to make it work??

Did you plug the molex power connector to it?

Yes…it is working fine in windows 10.

Ok, so you added:
and then run:
sudo update-grub
rebooted the system and is not working?

Will have to read some more about in that case, but probably somebody else will pass by with an idea why is not working for you, and provide a proper fix.

no i added that to GRUB_CMDLINE_LINUX_DEFAULT from grub menu…and in the desktop noting is working properly or even in tty…everything is sluggish…i think I am going to remove the card again…I had this issue few months ago…only kernel 5.4 worked…i thought 5.10 would work but seems like it isn’t working

Working on vanilla Arch with every kernel & all Ubuntu versions… Arch derivative distros are not working except Reborn os…don’t know what is the issue…also fedora isn’t working either. Might be missing vl805 driver.
Manjaro with kernel 5.4 is working fine.

Could be that the firmware version is not supported in Linux.

Read this article VIA VL805 USB 3.0 PCIe adapter: Forget about Linux (?)

And check reader comment #4 there is a link to raspberry pi updated firmware.

I have such Orico card and it works fine in Manjaro cinnamon after this firmware update, although you have to upgrade it under Windows…

The card is working on Ubuntu with kernel 5.11 and arch with kernel 5.10 lts & 5.12…with Manjaro kernel 5.4 works just fine… so I can’t figure out the problem…
I have a pcie usb 3 card…how to update the firmware from windows? Someone said they had to contact the manufacturer to get the firmware update.

it is in link i submitted…
but here it is Via VL805/806 Usb 3.0 Hub controllers Firmware Version 013704
replace the firmware version in this download with the new one from raspberry pi

Oh yes…I tried this link earlier & a newer version link but both weren’t working. There is nothing 2 download.

mm okay search the internet for a firmware flasher, or search the filename from the dead link

Searched for vl805 usb firmware…but nowhere to b found…the download file is missing.

You can download it from my server here
Let me know when you get it, i will remove it then.

1 Like

wow…thank you… but where is the firmware.bin file?? my firmware is 0x00013600

you have to download it from the link above in comment #raspberry-pi-4 https://github.com/raspberrypi/rpi-eeprom/raw/master/firmware/stable/vl805-000138a1.bin

Raspberry pi? Is it for this pcie usb3 card?

Flashed it successfully
But the usb card in not working in windows…device manager shows it but it says ‘windows has stopped this device because it has reported problems. (code 43)’

Do u have any old firmware?

got the firmware from here…everything is working again…have to check with linux

VIA VL805 chipset [niziak.spox.org]

Firmware Version is 0x00013704

Manjaro xfce kernel 5.10 iso with proprietary driver is stuck with ‘running MHWD script’…waited for 2 mins.