Virtual box: VM don't start

I got a problem with virtualbox starting a virtual machine.
I use Manjaro on two computers with the same versions (release 22.0.0, Sikaris, kernel linux 5.19.7-1) and the same installation procedure.

With one computer (HP Pavilion Laptop 14-dv1xxx), after a release of the virtualbox application, I’m unable to restart the virtual machine with the followig message, which don’t stop:


I need to kill both processes (VM and virtualbox) to reinitiate the system.
I tried to uninstall the full application and reinstall it without success and the same problem when starting the VM.

Then I made a fully new installation on the other computer (Dell OptiPlex 7050) and the same VM starts and works correctly.

I dont understand what is wrong whith the first computer. My hypothesis is that the reinstallation on the HP computer has not fully uninstalled virtualbox and the previous VM settings. But I’m not sure.

Any ideas to resolve this issue?

Thanks.
P.

VirtualBox machine can not start or freezes when using Linux Kernel 5.19 and Intel 11th Gen.

For using Grub bootloader:

  1. Edit /etc/default/grub to add the Kernel parameter ibt=off in GRUB_CMDLINE_LINUX_DEFAULT
  2. sudo update-grub
  3. Reboot
  4. Check VM if it starts
1 Like

Thanks for your suggestion.

I did it: same issue.
May-be I din’t correct conveniently the grub file:

GRUB_DEFAULT=saved
GRUB_TIMEOUT=5
GRUB_TIMEOUT_STYLE=hidden
GRUB_DISTRIBUTOR=“Manjaro”
GRUB_CMDLINE_LINUX_DEFAULT=“quiet apparmor=1 security=apparmor resume=UUID=b96f6933-7018-4d59-8ea1-60b1845db6d2 udev.log_priority=3”
ibt=off
GRUB_CMDLINE_LINUX=“”
(…)

P.

I noted that my first syntax was wrong and corrected it .
GRUB_CMDLINE_LINUX_DEFAULT=“quiet apparmor=1 security=apparmor resume=UUID=b96f6933-7018-4d59-8ea1-60b1845db6d2 udev.log_priority=3
ibt=off"

However it’s still not working…

P.

Did you run sudo update-grub then reboot?

yes I did it!

Here is the result (it’s in French, but not difficult to understand) :

[pierre@Crest ~]$ sudo update-grub
[sudo] Mot de passe de pierre :
Création du fichier de configuration GRUB…
Thème trouvé : /usr/share/grub/themes/manjaro/theme.txt
Image Linux trouvée : /boot/vmlinuz-5.19-x86_64
Image mémoire initiale trouvée : /boot/intel-ucode.img /boot/initramfs-5.19-x86_64.img
Found initrd fallback image: /boot/initramfs-5.19-x86_64-fallback.img
Image Linux trouvée : /boot/vmlinuz-5.15-x86_64
Image mémoire initiale trouvée : /boot/intel-ucode.img /boot/initramfs-5.15-x86_64.img
Found initrd fallback image: /boot/initramfs-5.15-x86_64-fallback.img
Attention : le sondeur de systèmes d’exploitation sera exécuté pour détecter d’autres partitions amorçables.
Sa sortie sera utilisée pour détecter les binaires amorçables qu’elles contiennent et créer de nouvelles entrées d’amorçage.
Ajout de l’entrée du menu d’amorçage pour les paramètres du firmware UEFI …
Found memtest86+ image: /boot/memtest86+/memtest.bin
/usr/bin/grub-probe : attention : type de périphérique nvme0n1 inconnu.
fait
[pierre@Crest ~]$

Try to run:

LC_ALL=C sudo update-grub

I did it: no success!

May-be its better to give up with the kernel 5.19 and run the LTS 5.15, waiting for a new release. What do you think ?

P.

If LTS has no issue with your device, then remove ibt=off.

1 Like

I move to the LTS 5.15 and now it works!

Thanks a lot for your help.
P

I know it works now with a different kernel, however
you made syntax error (typo) which you should still correct

You have now this in /etc/default/grub:

but the “ibt=off” parameter has to be inside the quotes - on the same line as the rest of the parameters

like this:

GRUB_CMDLINE_LINUX_DEFAULT=“quiet apparmor=1 security=apparmor resume=UUID=b96f6933-7018-4d59-8ea1-60b1845db6d2 udev.log_priority=3 ibt=off”

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.