Videos won't play with VLC

For some reason after the last update videos just close with VLC. Started the media player in the Terminal and get some error with libva

 vlc
VLC media player 3.0.18 Vetinari (revision 3.0.13-8-g41878ff4f2)
[00005575482945d0] main libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
[00005575483310d0] main playlist: playlist is empty
[00007efcf80073f0] gl gl: Initialized libplacebo v5.229.0 (API v229)
libva error: vaGetDriverNameByIndex() failed with unknown libva error, driver_name = (null)
[00007efcf80073f0] glconv_vaapi_x11 gl error: vaInitialize: unknown libva error
Segmentation fault (core dumped)
[william@william-pc ~]$ vlc
VLC media player 3.0.18 Vetinari (revision 3.0.13-8-g41878ff4f2)
[0000562c4b5e05d0] main libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
[0000562c4b67d0d0] main playlist: playlist is empty

So how do fix VLC to play videos with the video exiting? Some clips it will play,

Hi all!

Just registered to get help with the exact same issue…

    ~  vlc                                                                                                                         ✔  25s  
VLC media player 3.0.18 Vetinari (revision 3.0.13-8-g41878ff4f2)
[000055a6f12b75e0] main libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
[000055a6f13454f0] main playlist: playlist is empty
uint DBusMenuExporterDBus::GetLayout(int, int, const QStringList&, DBusMenuLayoutItem&): Condition failed: menu
uint DBusMenuExporterDBus::GetLayout(int, int, const QStringList&, DBusMenuLayoutItem&): Condition failed: menu
uint DBusMenuExporterDBus::GetLayout(int, int, const QStringList&, DBusMenuLayoutItem&): Condition failed: menu
[00007f3f20007420] gl gl: Initialized libplacebo v5.229.0 (API v229)
libva error: vaGetDriverNameByIndex() failed with unknown libva error, driver_name = (null)
[00007f3f20007420] glconv_vaapi_x11 gl error: vaInitialize: unknown libva error
zsh: segmentation fault (core dumped)  vlc

Just a simple search: Search results for 'vlc libva' - Manjaro Linux Forum

First result:

Same error after installing said package (not surprising, my pc has amd cpu and nvidia dgpu)…

Operating System: Manjaro Linux
KDE Plasma Version: 5.26.5
KDE Frameworks Version: 5.102.0
Qt Version: 5.15.8
Kernel Version: 5.15.89-1-MANJARO (64-bit)
Graphics Platform: X11
Processors: 8 × AMD Ryzen 5 1400 Quad-Core Processor
Memory: 15,6 GiB of RAM
Graphics Processor: NVIDIA GeForce GTX 1660/PCIe/SSE2
Manufacturer: NA
Product Name: ZBOX-ER51070

No idea… I used to use vlc back when I was on WinXP/7, but since then I use mplayer or mpv. It always works. Guess you have to increase the log by switching to debug to get hint what went wrong.

Check for a discussion regarding this issue in the Stable Updates Announcement.

Thanks, seems someone found a workaround:

(Cant insert link :confused: )

moderator edit: Done. Spend some time here and you will reach TL1 quickly. Then you can do it. Understanding Discourse Trust Levels

I had to use VLC-git from the AUR. While it works, not happy with it.

I installed the intel-media-driver and get the same error. Maybe I’ll try downgrading libva.

You mentioned you use nvidia. I had a simular issue with vlc awhile ago crashing when trying to play mkv files, and what fixed it for me was going into vlc video settings and changing the video output from automatic to VDPAU output.

1 Like

Same here. Updated today (stable) and now VLC opens then closes again. Video formats tried so far, MKV and MP4.

I believe there is a setting in vlc to turn off video acceleration. Just for testing, try turning it off and see what happens? It might become erratic and not play very well, but it might open at least.
“libva” has something to do with that.https://github.com/intel/libva

“[…] provides access to graphics hardware acceleration capabilities for video processing.”

Thank you. This works.

Presumably the libva problem is being worked on by someone? The VDPAU switch is just a workaround, not a solution.

Thanks, That fixed it for me (Nvidia).

@whm1974 please check whether this is your actual issue:

I had the exact same error as the OP; I fixed it with downgrade libvamore details here

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.