Videos sometimes freeze and only play frame by frame #2

Same issue as this one, different computer.

  • Manjaro XFCE
  • Firefox

All videos in firefox all of a sudden randomly stop playing. Press play again and the video plays one frame before freezing again.

$ inxi -Fxza --no-host
System:    Kernel: 5.4.148-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
           parameters: BOOT_IMAGE=/@/boot/vmlinuz-5.4-x86_64 root=UUID=034c95a9-ed9b-4074-809e-b7fc09d5ccbe rw
           rootflags=subvol=@ quiet
           root=/dev/mapper/luks-c2dc2956-eba0-46ed-bad1-27fdada91d8c apparmor=1 security=apparmor udev.log_priority=3
           Desktop: Xfce 4.16.0 tk: Gtk 3.24.29 info: xfce4-panel wm: xfwm 4.16.1 vt: 7 dm: LightDM 1.30.0
           Distro: Manjaro Linux base: Arch Linux
Machine:   Type: Desktop Mobo: ASRock model: J5040-ITX serial: <filter> UEFI: American Megatrends v: P1.60 date: 01/17/2020
CPU:       Info: Quad Core model: Intel Pentium Silver J5040 bits: 64 type: MCP arch: Goldmont Plus family: 6
           model-id: 7A (122) stepping: 8 microcode: 1A cache: L2: 4 MiB
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 15980
           Speed: 1205 MHz min/max: 800/3200 MHz Core speeds (MHz): 1: 1205 2: 974 3: 1255 4: 951
           Vulnerabilities: Type: itlb_multihit status: Not affected
           Type: l1tf status: Not affected
           Type: mds status: Not affected
           Type: meltdown status: Not affected
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
           Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
           Type: srbds status: Not affected
           Type: tsx_async_abort status: Not affected
Graphics:  Device-1: Intel GeminiLake [UHD Graphics 605] vendor: ASRock driver: i915 v: kernel bus-ID: 00:02.0
           chip-ID: 8086:3184 class-ID: 0300
           Display: x11 server: X.Org 1.20.13 compositor: xfwm4 v: 4.16.1 driver: loaded: modesetting alternate: fbdev,vesa
           display-ID: :0.0 screens: 1
           Screen-1: 0 s-res: 3840x1080 s-dpi: 96 s-size: 1016x285mm (40.0x11.2") s-diag: 1055mm (41.5")
           Monitor-1: HDMI-1 res: 1920x1080 hz: 60 dpi: 93 size: 527x296mm (20.7x11.7") diag: 604mm (23.8")
           Monitor-2: HDMI-2 res: 1920x1080 hz: 60 dpi: 93 size: 527x296mm (20.7x11.7") diag: 604mm (23.8")
           OpenGL: renderer: Mesa Intel UHD Graphics 605 (GLK 3) v: 4.6 Mesa 21.2.2 direct render: Yes
Audio:     Device-1: Intel Celeron/Pentium Silver Processor High Definition Audio vendor: ASRock driver: snd_hda_intel
           v: kernel alternate: snd_soc_skl,snd_sof_pci bus-ID: 00:0e.0 chip-ID: 8086:3198 class-ID: 0403
           Sound Server-1: ALSA v: k5.4.148-1-MANJARO running: yes
           Sound Server-2: sndio v: N/A running: no
           Sound Server-3: JACK v: 1.9.19 running: no
           Sound Server-4: PulseAudio v: 15.0 running: yes
           Sound Server-5: PipeWire v: 0.3.37 running: yes
Network:   Device-1: Intel Gemini Lake PCH CNVi WiFi driver: iwlwifi v: kernel port: f000 bus-ID: 00:0c.0 chip-ID: 8086:31dc
           class-ID: 0280
           IF: wlo2 state: down mac: <filter>
           Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: ASRock driver: r8169 v: kernel port: e000
           bus-ID: 03:00.0 chip-ID: 10ec:8168 class-ID: 0200
           IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter>
           IF-ID-1: virbr0 state: up speed: N/A duplex: N/A mac: <filter>
           IF-ID-2: virbr1 state: down mac: <filter>
           IF-ID-3: vnet5 state: unknown speed: 10 Mbps duplex: full mac: <filter>
Bluetooth: Device-1: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) type: USB driver: btusb v: 0.8 bus-ID: 1-9:4
           chip-ID: 8087:0aaa class-ID: e001
           Report: rfkill ID: hci0 rfk-id: 1 state: up address: see --recommends
Drives:    Local Storage: total: 461.57 GiB used: 136.77 GiB (29.6%)
           SMART Message: Required tool smartctl not installed. Check --recommends
           ID-1: /dev/sda maj-min: 8:0 vendor: Maxtor model: Z1 SSD 480GB size: 447.13 GiB block-size: physical: 512 B
           logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: D010 scheme: GPT
           ID-2: /dev/sdb maj-min: 8:16 type: USB vendor: SanDisk model: SDDR-B531 size: 14.44 GiB block-size: physical: 512 B
           logical: 512 B type: N/A serial: <filter> rev: 2920 scheme: GPT
Partition: ID-1: / raw-size: 446.63 GiB size: 446.63 GiB (100.00%) used: 135.78 GiB (30.4%) fs: btrfs dev: /dev/dm-0
           maj-min: 254:0 mapped: luks-c2dc2956-eba0-46ed-bad1-27fdada91d8c
           ID-2: /boot/efi raw-size: 512 MiB size: 511 MiB (99.80%) used: 696 KiB (0.1%) fs: vfat dev: /dev/sda2 maj-min: 8:2
           ID-3: /home raw-size: 446.63 GiB size: 446.63 GiB (100.00%) used: 135.78 GiB (30.4%) fs: btrfs dev: /dev/dm-0
           maj-min: 254:0 mapped: luks-c2dc2956-eba0-46ed-bad1-27fdada91d8c
Swap:      Kernel: swappiness: 10 (default 60) cache-pressure: 100 (default)
           ID-1: swap-1 type: file size: 16 GiB used: 94 MiB (0.6%) priority: -2 file: /swap/swapfile
Sensors:   System Temperatures: cpu: 58.0 C mobo: N/A
           Fan Speeds (RPM): N/A
Info:      Processes: 321 Uptime: 4d 37m wakeups: 0 Memory: 34.91 GiB used: 10.1 GiB (28.9%) Init: systemd v: 249
           tool: systemctl Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: pacman: 1638 lib: 453 flatpak: 0 Shell: Bash
           v: 5.1.8 running-in: alacritty inxi: 3.3.06

Why are you running 5.4 on such a recent machine? (I.E. Have you tried different kernels already? 5.10 LTS and 5.14 Stable would be high on my list)


I was told on this forum to just go back to 5.4 twice, after trying out 5.10 LTS twice
and got into an argument twice over saying that LTS should mean LTS and not buggy, but was told twice that 5.10 isn’t really LTS and that I should stick with the true LTS, 5.4.

I don’t have 5.10 LTS running as the screensaver freezes the computer.

And I like having a Linux LTS version.


I found the second time where someone from told me to go back to 5.4.
Being at a later date, it was less pressing than the first time.

And then I asked if this is how it is, I did not any clear answer saying, “no 5.10 is now Manjaro’s main LTS” and you telling me I won’t get any better answer than that and that’s final.
So I took that as 5.4 being the real LTS and I’ll have to ride it out until 5.15 appears.

The x y problem again, it seems.

Regarding the kernels: All the kernels provided trough repository can be used, that means they are maintained and are not EOL. Even tho some kernels are newer and LTS that doesn’t mean will perform better on all hardware. There is no definitve answer on what kernel to use, but rather what works best for your hardware and your needs. Opinions will differ based on each one experience on their hardware/workflow and so on.

Regarding the video freeze: My guess is the video driver and or the way the kernel module is set. Based on the discussion here [SOLVED] i915 & Intel UHD 630 / Kernel & Hardware / Arch Linux Forums you might want to try this AUR package AUR (en) - linux-drm-tip-git if nothing else works. Somebody else, with the same iGPU has posted this J5005 / UHD 605 Graphics: 4k Youtube playback choppy / Multimedia and Games / Arch Linux Forums

Your mentioned topic, while might be describing same symptom, is about a desktop with AMD GPU … The only valid “workaround” mentioned there is to try with the compositor turned off.

1 Like

Any apologies if I’m wrong, but I do not see how this applies to me.
My first reaction to this is: HOW!?

What is it?

The XY problem is asking about your attempted solution rather than your actual problem.

I did not offer any attempt that I know. When I open up a video, it freezes.
Pressing play again is not an attempted solution of mine. It’s just a further description of the problem.

User doesn’t know how to do X, but thinks they can fumble their way to a solution if they can just manage to do Y.

What does this have to do with ANYTHING I posted on my opening post?
Where is my attempt!?
What’s my Y?

User doesn’t know how to do Y either.
User asks for help with Y.

What is my Y?
What is my asking for help with Y?

Others try to help user with Y, but are confused because Y seems like a strange problem to want to solve.

Fabby asked why I was using kernel 5.4 and why I would not use kernel 5.10?
That’s not helping me with Y.
I never asked about changing kernels and why I can’t change kernels is a completely different issue.

After much interaction and wasted time, it finally becomes clear that the user really wants help with X, and that Y wasn’t even a suitable solution for X.

Okay, so what is it that I really want to get help with?
Is “all videos in firefox all of a sudden randomly stop playing” not the thing I want to get help with?

Like I said, the symptoms are the same, but the computer is different. It doesn’t have an AMD GPU.

$ lspci -vnn | grep VGA -A 12
00:02.0 VGA compatible controller [0300]: Intel Corporation GeminiLake [UHD Graphics 605] [8086:3184] (rev 06) (prog-if 00 [VGA controller])
	DeviceName: Onboard - Video
	Subsystem: ASRock Incorporation Device [1849:2212]
	Flags: bus master, fast devsel, latency 0, IRQ 137
	Memory at a0000000 (64-bit, non-prefetchable) [size=16M]
	Memory at 90000000 (64-bit, prefetchable) [size=256M]
	I/O ports at f000 [size=64]
	Expansion ROM at 000c0000 [virtual] [disabled] [size=128K]
	Capabilities: <access denied>
	Kernel driver in use: i915
	Kernel modules: i915

Anyway. It hasn’t happened in the last 27 days, so there must have been some update that has fixed this issue, or I’m just not triggering the issue somehow. And no, I did not upgrade my kernel. I’m still on 5.4.