VGA monitor resolution stuck at 640x480

Hi everyone, since I installed Manjaro in my new PC I haven’t been able to change my second monitor’s resolution, the maximum resolution reported by Manjaro is 960x540, but when I look at what’s my monitor reporting it says 640x480, I have tried many ways to set a custom resolution in xrandr, but I always get this message:

$ xrandr --addmode VGA-0 1600x900_60.00
X Error of failed request:  BadMatch (invalid parameter attributes)
  Major opcode of failed request:  140 (RANDR)
  Minor opcode of failed request:  18 (RRAddOutputMode)
  Serial number of failed request:  31
  Current serial number in output stream:  32

I have also tried other things, like Custom Screen Resolution, reinstalling Nvidia 390.xx drivers and arandr, with no success. I don’t know what else to do, I feel like I’ve tried everything.

Here’s what xrandr throws:

Screen 0: minimum 8 x 8, current 2880 x 1080, maximum 16384 x 16384
DVI-I-0 disconnected (normal left inverted right x axis y axis)
VGA-0 connected 960x540+1920+540 (normal left inverted right x axis y axis) 0mm x 0mm
   960x540       59.82*+
   864x486       59.92    59.57  
   640x480       59.94  
   480x270       59.82  
   432x243       59.92    59.57  
   320x240       60.05  
DVI-I-1 disconnected (normal left inverted right x axis y axis)
HDMI-0 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 160mm x 90mm
   1360x768      60.02 +
   1920x1080     59.94    50.00    29.97    25.00    23.98    60.05    60.00*   50.04  
   1280x720      60.00    59.94    50.00  
   1024x768      75.03    70.07    60.00  
   800x600       75.00    72.19    60.32  
   720x576       50.00  
   720x480       59.94  
   640x480       75.00    72.81    59.94  
  1600x900_60.00 (0x2ec) 118.250MHz -HSync +VSync
        h: width  1600 start 1696 end 1856 total 2112 skew    0 clock  55.99KHz
        v: height  900 start  903 end  908 total  934           clock  59.95Hz

Here’s my system info in inxi -Fazy:

  Kernel: 5.13.4-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.13-x86_64 
  root=UUID=786e8ca2-39b8-40a3-9c4f-79266abd9670 rw quiet 
  root=/dev/mapper/luks-5afe5bdd-1d96-4a9e-9140-c48da6b4878f apparmor=1 
  security=apparmor udev.log_priority=3 
  Desktop: KDE Plasma 5.22.3 tk: Qt 5.15.2 wm: kwin_x11 vt: 1 dm: SDDM 
  Distro: Manjaro Linux base: Arch Linux 
  Type: Desktop System: ASUS product: N/A v: N/A serial: <filter> 
  Mobo: ASUSTeK model: PRIME H410M-E v: Rev 1.xx serial: <filter> 
  UEFI: American Megatrends v: 1605 date: 04/07/2021 
  Info: Quad Core model: Intel Core i3-10100F bits: 64 type: MT MCP 
  arch: Comet Lake family: 6 model-id: A5 (165) stepping: 3 microcode: EA 
  cache: L2: 6 MiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 57616 
  Speed: 1369 MHz min/max: 800/4300 MHz Core speeds (MHz): 1: 1369 2: 3611 
  3: 4026 4: 2852 5: 3639 6: 1826 7: 1150 8: 2000 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
  Device-1: NVIDIA GF119 [GeForce GT 610] vendor: ASUSTeK driver: nvidia 
  v: 390.144 alternate: nouveau,nvidia_drm bus-ID: 01:00.0 chip-ID: 10de:104a 
  class-ID: 0300 
  Display: x11 server: X.Org 1.20.11 compositor: kwin_x11 driver: 
  loaded: nvidia display-ID: :0 screens: 1 
  Screen-1: 0 s-res: 2880x1080 s-dpi: 217 s-size: 337x126mm (13.3x5.0") 
  s-diag: 360mm (14.2") 
  Monitor-1: VGA-0 res: 960x540 hz: 60 
  Monitor-2: HDMI-0 res: 1920x1080 dpi: 305 size: 160x90mm (6.3x3.5") 
  diag: 184mm (7.2") 
  OpenGL: renderer: GeForce GT 610/PCIe/SSE2 v: 4.6.0 NVIDIA 390.144 
  direct render: Yes 
  Device-1: Intel vendor: ASUSTeK driver: snd_hda_intel v: kernel 
  alternate: snd_sof_pci_intel_cnl bus-ID: 00:1f.3 chip-ID: 8086:a3f0 
  class-ID: 0403 
  Device-2: NVIDIA GF119 HDMI Audio vendor: ASUSTeK driver: snd_hda_intel 
  v: kernel bus-ID: 01:00.1 chip-ID: 10de:0e08 class-ID: 0403 
  Sound Server-1: ALSA v: k5.13.4-1-MANJARO running: yes 
  Sound Server-2: JACK v: 0.125.0 running: no 
  Sound Server-3: PulseAudio v: 14.2 running: yes 
  Sound Server-4: PipeWire v: 0.3.32 running: no 
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: ASUSTeK PRIME B450M-A driver: r8169 v: kernel port: 3000 
  bus-ID: 03:00.0 chip-ID: 10ec:8168 class-ID: 0200 
  IF: enp3s0 state: up speed: 100 Mbps duplex: full mac: <filter> 
  Local Storage: total: 931.51 GiB used: 16.99 GiB (1.8%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: ST1000DM010-2EP102 
  size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  type: HDD rpm: 7200 serial: <filter> rev: CC46 scheme: GPT 
  ID-1: / raw-size: 465.45 GiB size: 457.07 GiB (98.20%) 
  used: 16.97 GiB (3.7%) fs: ext4 dev: /dev/dm-0 maj-min: 254:0 
  mapped: luks-5afe5bdd-1d96-4a9e-9140-c48da6b4878f 
  ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%) 
  used: 25.4 MiB (26.4%) fs: vfat dev: /dev/sda1 maj-min: 8:1 
  Alert: No swap data was found. 
  System Temperatures: cpu: 27.8 C mobo: N/A gpu: nvidia temp: 30 C 
  Fan Speeds (RPM): N/A 
  Processes: 230 Uptime: 28m wakeups: 0 Memory: 7.68 GiB 
  used: 2.35 GiB (30.6%) Init: systemd v: 248 tool: systemctl Compilers: 
  gcc: N/A Packages: 1315 pacman: 1311 lib: 387 flatpak: 0 snap: 4 Shell: Bash 
  v: 5.1.8 running-in: konsole inxi: 3.3.06 

Have you tried changing resolution from display settings in xfce4-settings-manager ?

Please, if you want to provide help, then pay attention to the OP information, and don’t suggest random stuff! The OP uses KDE Plasma.

Please provide the content of /etc/X11/mhwd.d/nvidia.conf

I’m sorry

Don’t worry about it, it’s ok :+1:

Here’s what nvidia.conf contains:

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 390.144  (dvs-builder@U64-P10-09)  Wed Jun  2 22:56:57 UTC 2021

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"

Section "Files"

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"

Section "InputClass"
    Identifier         "Keyboard Defaults"
    MatchIsKeyboard    "yes"
    Option         "XkbOptions" "terminate:ctrl_alt_bksp"

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "NoLogo" "1"
    Option         "Coolbits" "12"
    SubSection     "Display"
        Depth       24

Section "Extensions"
    Option         "COMPOSITE" "Enable"