Using older versions of Go on Manjaro

A couple of times I have run into some problems because of Manjaro being a rolling release, and always giving me the absolute latest version of Go (currently 1.15.3). The problem is usually not with Go in itself, but packages that do not fully support 1.15 yet.

What would be the recommended way to continue developing on Go 1.14 for a while? Would it be best to downgrade Go to 1.14 by doing something like described below? Or is it better to setup a non-rolling release VM and develop there? Or can I have multiple versions of Go installed at the same time on a rolling release distribution?:

You can have multiple versions of go installed.

Looking at:

You can just download and extract them into different directories.
When you run “go” it will execute the one that comes first in your PATH variable.
So just make sure the version you want to work with, is first.

You can check it then by running “go version”.

I think you mean Installing multiple Go versions?

1 Like

Ha, even better. :+1:

Thanks, both of you…I will check that out tomorrow…

Are anyone of you using GoLand? It seems like GoLand supports using different versions of Go, but I have not got it to work yet.

To clarify, I am pretty sure I got Go 1.14.11 to work through GoLand, it looks like it is compiling using Go 1.14. So the problem I asked for here is solved. But my problem with GoTK3 remains, even if I use an older version of GoTK3 (not the new one 0.5.0 that originally gave me problems). I am getting help from the GoTK3 team with that though.

I found your issue report on gotk3 github.

In your code sample there is no gtk.Init(nil)

This is working for me. Can you try (change image path of course):

package main

import (


func main() {
	imagePath := "/home/moson/Pictures/avatar.jpg"
	image, err := gtk.ImageNewFromFile(imagePath)
	if err != nil {

Oh My God! That was the answer…it works now.

I am so stupid, my only defense here, is that at least someone from the GoTK3 crew (at least, I think he was on the team) did the same mistake :slight_smile:

Thanks @Moson, you saved me again, for the n:th time :slight_smile:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.