User Selection in Login Screen does not show default user

Hi, today I encountered a problem after running the system maintenance from pacui. After the completed system maintenance, I was AFK, so my computer went into energy saver mode. I reawakened the PC and was prompted with a login screen, as usual. However my password did not work anymore.
I rebooted my computer and noticed, that the user selection does not show up, and instead I was prompted for a username to enter. The username of the default user didn’t work however, I can only log in with ‘root’ + root-psswd.
When attempting to the ‘useradd’ command, I get a “user already exists” message. Also, when using the ‘ls -la /home’ and the ‘less /etc/passwd’ commands, the correct home directory / user ID are display for my default user. But when using the ‘users’ command, only root is listed.
I would greatly appreciate any help in restoring my default user.


Well, if you dont tell us then we dont know what you did.
What exactly did you perform during this maintenance?

Also … I might have guesses about pacnews (ones related to logind, PAM, etc)?

To print them all:

pacdiff -o 

users should only print users that are logged in. So this is likely normal behavior (after having rebooted, logged in to only root).

1 Like

This is normal behavior, because user only shows users that are logged in at this time (see info user)

In managing your pacnew-files you may have changed an important file as:

  • /etc/shells
  • revert this change, and everything will be fine
  • or rollback with timeshift to a snapshot direct before your maintenance

Because Manjaro is a rolling release, Manjaro requires regular maintenance

System maintenance at manjaro is a responsible task. When pacnew files appear, it is necessary to edit them manually. This cannot be further automated because these files were created precisely because the update automation recognized that this file had already been changed locally.

It is therefore necessary to enter the changes manually. If there is any doubt about what to do,

  • Research the purpose of the file
  • Assess the purpose of the changes


  • Local settings in the current file should definitely be retained
  • Improved comments and formatting from the pacnew file should definitely be adopted
    (This is guaranteed to cover over 95% of the changes)
  • If other changes need to be made, it is advisable to inform yourself beforehand
    • in Arch Wiki
    • in Manjaro wiki

If that didn’t help,

  • Ask specifically about this one setting in the forum.
1 Like

IDK (I don’t know …) whether there is or should be such a thing as a default user.
If there actually is only one - like on many desktop systems - I could understand that.
But: what would the default user be on a system with multiple (even hundreds) of users?

fun fact:
someone else recently complained that this exact thing annoyed him/her
He/she wanted to get rid of that “the default user name is always shown, along with it’s actual system user name”.

I was referring to the user I normally log in as as the default user, so simply not the root account, sorry for my unclear communication.

Thank you for your reply, I am new to linux and dont really have a grasp on what to look out for when maintaining the OS, so I was happy to find out that pacui has a maintain system function, that seemed to do it all for me. I guess there is more to look out for and I will keep an eye open in the future.

Is there a way, that I can look up, what changes were made?

I used pacui’s System Maintenance. I used all the default settings when prompted for input, as I am very inexperienced with Manjaro and Linux in general. I do recall at one point being asked about a file to be merged, overridden or discarded, where the default answer did not work, so I chose override instead of merge. I think that that was the cause of it all.

Also I have since tried running the

Command, but this does not give me any output.

I see, thank you for the clarification.


if your filesystem is btrfs, and you used snapper or timeshift to make snapshots :footprints:

Please have a close look at /etc/shells :footprints:

Congratulations, you just overwrote /etc/passwd. (probably)

1 Like

I did not take any snapshots.

Is there something I need to look out for in /etc/shells?
Here is what it shows me:

# Pathnames of valid login shells.
# See shells(5) for details.


Ok, that sounds like something that can only be solved by deleting the user account in question and creating a new one, am I correct?

First post what’s in your passwd file.

My cat /etc/shells

# Pathnames of valid login shells.
# See shells(5) for details.


You are missing zsh !

This is the cat of my /etc/passwd

nobody:x:65534:65534:Kernel Overflow User:/:/usr/bin/nologin
dbus:x:81:81:System Message Bus:/:/usr/bin/nologin
systemd-coredump:x:981:981:systemd Core Dumper:/:/usr/bin/nologin
systemd-network:x:980:980:systemd Network Management:/:/usr/bin/nologin
systemd-oom:x:979:979:systemd Userspace OOM Killer:/:/usr/bin/nologin
systemd-journal-remote:x:978:978:systemd Journal Remote:/:/usr/bin/nologin
systemd-resolve:x:977:977:systemd Resolver:/:/usr/bin/nologin
systemd-timesync:x:976:976:systemd Time Synchronization:/:/usr/bin/nologin
tss:x:975:975:tss user for tpm2:/:/usr/bin/nologin
dhcpcd:x:974:974:dhcpcd privilege separation:/:/usr/bin/nologin
dnsmasq:x:973:973:dnsmasq daemon:/:/usr/bin/nologin
polkitd:x:102:102:PolicyKit daemon:/:/usr/bin/nologin
rpc:x:32:32:Rpcbind Daemon:/var/lib/rpcbind:/usr/bin/nologin
rpcuser:x:34:34:RPC Service User:/var/lib/nfs:/usr/bin/nologin
avahi:x:972:972:Avahi mDNS/DNS-SD daemon:/:/usr/bin/nologin
colord:x:971:971:Color management daemon:/var/lib/colord:/usr/bin/nologin
cups:x:209:209:cups helper user:/:/usr/bin/nologin
flatpak:x:970:970:Flatpak system helper:/:/usr/bin/nologin
gdm:x:120:120:Gnome Display Manager:/var/lib/gdm:/usr/bin/nologin
geoclue:x:969:969:Geoinformation service:/var/lib/geoclue:/usr/bin/nologin
git:x:968:968:git daemon user:/:/usr/bin/git-shell
nm-openconnect:x:967:967:NetworkManager OpenConnect:/:/usr/bin/nologin
nm-openvpn:x:966:966:NetworkManager OpenVPN:/:/usr/bin/nologin
saned:x:964:964:SANE daemon user:/:/usr/bin/nologin
transmission:x:169:169:Transmission BitTorrent Daemon:/var/lib/transmission:/usr/bin/nologin
usbmux:x:140:140:usbmux user:/:/usr/bin/nologin
eliass:x:1000:1000:Elias S:/home/eliass:/bin/zsh
fwupd:x:962:962:Firmware update daemon:/var/lib/fwupd:/usr/bin/nologin
_talkd:x:961:961:User for legacy talkd server:/:/usr/bin/nologin
passim:x:960:960:Local Caching Server:/usr/share/empty:/usr/bin/nologin
lightdm:x:959:959:Light Display Manager:/var/lib/lightdm:/usr/bin/nologin

My user account is listed here, and it seems to need a login via zsh if I piece this together correctly?

But as andreas85 pointed out here, zsh is missing in my /etc/shells:

Can I just add the paths manually into /etc/shells?


:footprints: (But don’t make any typos :wink: )

Alright, this fixed it for me. Thank you for your patience, everybody.

I would strongly recommend (from my own experience) to think about

  • snapper / timeshift and
  • snapshots
    Then you always have a file in the snapshot that you can compare with. (Not to mention the possibility of a rollback)


Yes, I will definitely look into these and make a snap shot before running updates again.

1 Like

I guess you overwrote shells then.

Just dont blindly overwrite files.
pacnews are created for a reason.
If they could all just be overwritten with the upstream file then … what would be the point of stopping it and requiring manual intervention?

Please see any of the many many threads where people have been hand-held and walked-through the process, despite there being guides and previous threads doing the same.

For all the infos:

I changed the solve post to the first one pointing to the exact pacnew files, and a decently verbose explanation of them.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.