Usb & ethernet : problem after boot completion - must wait +- 30"


I have installed Manjaro cinnamon on a new machine, and after boot, I have to wait up to 30" to be able to use my mouse and get ethernet connected.

I have tried another mouse, another usb hub.
No problem under Windows on same machine.
No problem with the Manjaro usb key.
I did copy usb files on a Nvme partition; if I boot it using SuperGrubDisk2, it is fast, and no mouse /ethernet delay…

I did reinstall from scratch : same problem, even before updating (sudo pacman -Syu)

I cannot really see what happens using journalctl.
I did try another kernel … same problem.

Thanks in advance for any help.

Welcome to the forum! :wave:

Sorry, no one knows what “boot pb” is. Please refer to: How to Post and edit your topic title accordingly.

Please see [HowTo] Make support easier and post your system details along with the output of lsusb.

Hello Yochanan
Boot pb is a boot problem _ Linux is loaded, Cinnamon desktop is displayed.
But I mus twait 20 to 30 seconds before beiing able to use my mouse and the ethernet connection.

USB problem solved using default parameters (apps started on boot, cinnamon parameter GUI)

Today, I still do not understand why my Ethernet needs so much time to get connected.
I changed DHCP mode to fixed IP → same problem.

My problem is not solved. Ethernet, and mouse often need several seconds (±30) to be available.
Any help will be really appreciated.

No such problem on my older desktop !
Windows 11 is running fine.

My current desktop

  Kernel: 5.15.59-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.1.1
    Desktop: Cinnamon v: 5.4.9 tk: GTK v: 3.24.34 vt: 7 dm: LightDM v: 1.30.0
    Distro: Manjaro Linux base: Arch Linux
  Type: Desktop Mobo: Micro-Star model: MPG Z690 FORCE WIFI (MS-7D30) v: 2.0
    serial: <superuser required> UEFI: American Megatrends LLC. v: A.70
    date: 06/29/2022
  Info: 16-core (8-mt/8-st) model: 12th Gen Intel Core i9-12900KS bits: 64
    type: MST AMCP smt: enabled arch: Alder Lake rev: 2 cache: L1: 1.4 MiB
    L2: 14 MiB L3: 30 MiB
  Speed (MHz): avg: 837 high: 1297 min/max: 800/5298:5500:4000 cores:
    1: 800 2: 801 3: 800 4: 800 5: 800 6: 800 7: 1297 8: 801 9: 800 10: 800
    11: 1157 12: 673 13: 800 14: 800 15: 801 16: 801 17: 800 18: 800 19: 801
    20: 961 21: 799 22: 800 23: 800 24: 800 bogomips: 164088
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Device-1: Intel AlderLake-S GT1 vendor: Micro-Star MSI driver: i915
    v: kernel ports: active: none empty: DP-1, DP-2, HDMI-A-1, HDMI-A-2,
    HDMI-A-3, HDMI-A-4 bus-ID: 00:02.0 chip-ID: 8086:4680 class-ID: 0380
  Device-2: NVIDIA GA102 [GeForce RTX 3080 Ti] vendor: Micro-Star MSI
    driver: nvidia v: 515.65.01 arch: Ampere pcie: speed: 2.5 GT/s lanes: 16
    bus-ID: 01:00.0 chip-ID: 10de:2208 class-ID: 0300
  Display: x11 server: X.Org v: 21.1.4 driver: X: loaded: nvidia
    gpu: i915,nvidia display-ID: :0 screens: 1
  Screen-1: 0 s-res: 5120x1440 s-dpi: 96 s-size: 1355x381mm (53.35x15.00")
    s-diag: 1408mm (55.42")
  Monitor-1: DP-4 res: 5120x1440 dpi: 130048 size: 1x1mm (0.04x0.04")
    diag: 1mm (0.06") modes: N/A
  OpenGL: renderer: NVIDIA GeForce RTX 3080 Ti/PCIe/SSE2 v: 4.6.0 NVIDIA
    515.65.01 direct render: Yes
  Device-1: Intel Alder Lake-S HD Audio vendor: Micro-Star MSI
    driver: snd_hda_intel v: kernel bus-ID: 1-3:2 bus-ID: 00:1f.3
    chip-ID: 0db0:005a class-ID: 0300 chip-ID: 8086:7ad0 class-ID: 0403
  Device-2: NVIDIA GA102 High Definition Audio vendor: Micro-Star MSI
    driver: snd_hda_intel v: kernel pcie: speed: 16 GT/s lanes: 16
    bus-ID: 01:00.1 chip-ID: 10de:1aef class-ID: 0403
  Device-3: Micro Star USB Audio type: USB
    driver: hid-generic,snd-usb-audio,usbhid
  Sound Server-1: ALSA v: k5.15.59-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.21 running: no
  Sound Server-3: PulseAudio v: 16.1 running: yes
  Sound Server-4: PipeWire v: 0.3.56 running: yes
  Device-1: Intel Ethernet I225-V vendor: Micro-Star MSI driver: igc
    v: kernel pcie: speed: 5 GT/s lanes: 1 port: N/A bus-ID: 07:00.0
    chip-ID: 8086:15f3 class-ID: 0200
  IF: enp7s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Device-1: Intel AX210 Bluetooth type: USB driver: btusb v: 0.8
    bus-ID: 1-14:6 chip-ID: 8087:0032 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
  Local Storage: total: 3.18 TiB used: 1.19 TiB (37.2%)
  ID-1: /dev/nvme0n1 vendor: MSI model: M480 2TB size: 1.82 TiB
    speed: 63.2 Gb/s lanes: 4 type: SSD serial: <filter> rev: EIFM21.2
    temp: 37.9 C scheme: GPT
  ID-2: /dev/nvme1n1 vendor: Kingston model: SA2000M8500G size: 465.76 GiB
    speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: S5Z42105
    temp: 38.9 C scheme: GPT
  ID-3: /dev/nvme2n1 vendor: Samsung model: SSD 970 EVO Plus 1TB
    size: 931.51 GiB speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: 2B2QEXM7 temp: 48.9 C scheme: GPT
  ID-1: / size: 71.54 GiB used: 27.97 GiB (39.1%) fs: ext4
    dev: /dev/nvme0n1p2
  ID-2: /boot/efi size: 499 MiB used: 27.8 MiB (5.6%) fs: vfat
    dev: /dev/nvme0n1p1
  ID-3: /home size: 114.79 GiB used: 39.52 GiB (34.4%) fs: ext4
    dev: /dev/nvme0n1p4
  ID-1: swap-1 type: partition size: 41.02 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/nvme0n1p3
  System Temperatures: cpu: 26.0 C mobo: N/A gpu: nvidia temp: 48 C
  Fan Speeds (RPM): N/A gpu: nvidia fan: 0%
  Processes: 423 Uptime: 22m wakeups: 284 Memory: 31.14 GiB used: 2.36 GiB
  (7.6%) Init: systemd v: 251 default: graphical Compilers: gcc: 12.1.1
  clang: 14.0.6 Packages: pacman: 1531 Shell: Bash v: 5.1.16
  running-in: gnome-terminal inxi: 3.3.20

I did find a problem : Nvidia driver.

No problem using video-modesetting driver, but login fails on 1st attempt.
Long Ethernet connection + mouse using video-nvidia driver, but login succeeds on 1st try !

I would like both login and fast Ethernet connection with my video driver !
Any idea ?

My video card is an RTX3080 Ti

Problem solved with KDE (Plasma).
I was using Cinnamon.

It seems Nvidia drivers are only supported by Nvidia on X11 servers.
Kde uses X11, Cinnamon does not !

1 Like

KDE can use either X11 or Wayland and Cinnamon only uses X11. You can check with: