USB devices not accessible if not present at boot

@bogdancovaciu , could this be an issue related to udev :thinking:

That’s normal because it needs to access the ports for initialization…

Not sure, going trough this GPD Pocket - ArchWiki i see not much about the USB, but maybe i’m missing something …

He mentioned using an USB-hub…

So it might be related to the initialization of the USB ports on the external hub

@MattMcHackit Could you perhaps give some info on that external hub you plugin?

I can certainly look up the details of that hub after work, but I should say I get the same results with different hubs (I’ve tried 3, all from different manufacturers) or with devices connected directly to the laptop’s USB ports.

That could be because all 3 could be using the same chip-set…

That part makes me wonder why though :thinking:

but no hurry, we will comback in due time (i hope), plus that person the staff member pinged would need to notice his ping also :wink:

Good point about the chipsets – just checked the hub; it’s a Lionwei LIUC2904.

What strikes me as really strange is that all the ports of either type (USB A or C) work if one port of that type is in use at boot – including being PnP – I can connect/disconnect/reconnect any devices I like provided that’s the case. Presumably this is because all the ports of a given type are connected through one internal hub/chip. :person_shrugging:

Just noticed, any USB device that has a light on it (USB drives that have a power or write indicator, backlit keyboards etc) light up for a fraction of a second when connected, then go out almost immediately. I don’t know if that’s important?

That’s most likely cause of hardware reset/init of the hub itself internally, until it gets properly initialized by the driver of the OS.

This still has me puzzled, because that would indicate it is not the external hub after-all :woman_shrugging:
Lets just wait and sink it in, maybe someones brains in background has new ideas…

I also have an external multi-port hub with HDMI/ethernet/etc (WiWu something) which has problems with devices when they are connected to it before i connect the hub.
Which i don’t use often (just when i want to use my KB/Mouse/Monitor with my Phone) :smiley:
Those things are nice but have their problems :woman_shrugging:

Edit: Mine is an “Alpha 11 in1” from WiWu…

Please advice on how I can reproduce this issue.

Have you upgraded your bios to latest version? If not then please do that first .

There was an irq bug in bios firmware which would stop usb keyboard on some 6.0 kernels.

So best is to get the latest firmware from gpd and that should resolve all your problem.
I use win max2 regularly to test manjaro images.

Hi @spikerguy

Steps to reproduce:

  1. Boot Manjaro with a kernel version between 5.15 and 6.10 on GPD Win Max 2 (AMD/6800U version), ensure no USB devices are connected to the device’s ports during boot process.
  2. Once logged into an account on Manjaro, attempt to connect a USB device of any kind to the laptop – the device will not be detected or functional until sudo lsusb -v command is run.

If any USB device is connected to a USB type A port at boot, all USB A ports behave as they should. Similarly, connecting a USB type C device prior to boot results in both USB type C ports behaving properly. Having only USB type A ports connected to a device a boot will not cause USB type C ports to work correctly and vice-versa.

I’m already running BIOS version 1.04 with build date 27th October 2022 and EC FW version 1.02, which I believe is the latest?

It’s the AMD 6800U version of the Win Max 2, if that makes a difference?

I’ve tried kernels 5.15-6.08 and the issues are the same on all of them.

Can you please advise how I should proceed? Are there any BIOS settings I should try changing, for example?

Thank you!

I just tried resetting the BIOS back to defaults in case I’d inadvertently caused the problem by some change I’d made, but that had no impact on the issue.

Contacted GPD, and they advised advanced settings can be enabled in the BIOS by entering it, hitting Alt+F5 and re-entering. A lot of USB options have been unlocked, so hopefully the solution will be in there somewhere!

1 Like

Can anyone suggest settings it might be helpful to experiment with? Either in the BIOS or Manjaro? I think I may be a little out of my depth. I’m pretty confident there’s nothing physically wrong with the laptop as the ports worked in Windows before I wiped the drive and function properly either if devices are connected at boot or after running sudo lsusb -v
Any suggestions gratefully tried!

Perhaps a power management issue ?

1 Like

@freggel.doe – looks like this was the right track!

I installed tlp and tlpui and rebooted. All USB ports then behaved correctly when on AC power, but the problem persisted when on battery. I then added the internal USB hubs (IDs 1d6b:0002 and 1d6b:0003) to the USB_DENYLIST using TLP-UI and rebooted again…

This seems to have worked!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.