Updating unstable (KDE version) this week broke Xvnc

Updating unstable (KDE version) this week broke Xvnc. vncserver started, then Xvnc segment fault and core dumped.

Dec 29 16:07:31 delta2 systemd-coredump[3057]: [🡕] Process 3055 (Xvnc) of user 1001 dumped core.
                                               Stack trace of thread 3055:
                                               #0  0x00007fda4d2ac83c n/a (libc.so.6 + 0x8e83c)
                                               #1  0x00007fda4d25c668 raise (libc.so.6 + 0x3e668)
                                               #2  0x00007fda4d2444b8 abort (libc.so.6 + 0x264b8)
                                               #3  0x00005590291be363 OsAbort (Xvnc + 0x1c2363)
                                               #4  0x00005590291cb5ba AbortServer (Xvnc + 0x1cf5ba)
                                               #5  0x00005590291cb6e1 FatalError (Xvnc + 0x1cf6e1)
                                               #6  0x00005590291c05fe n/a (Xvnc + 0x1c45fe)
                                               #7  0x00007fda4d25c710 n/a (libc.so.6 + 0x3e710)
                                               #8  0x000055902a0a76e0 n/a (n/a + 0x0)
                                               ELF object binary architecture: AMD x86-64
Dec 29 16:07:31 delta2 systemd[1]: systemd-coredump@1-3056-0.service: Deactivated successfully.

Reverting to stable fixed it.

Moderator edit: In the future, please use proper formatting: [HowTo] Post command output and file content as formatted text

1 Like

On KDE plasma here.

Not sure what you mean by xvnc, Do you mean x11vnc?
I use tigervnc and that works.

:wink: :point_down:

❯ pacman -F Xvnc
extra/tigervnc 1.13.1-2

Note: One should always run sudo pacman -Fy after sudo pacman -Syu to update the local database for accurate info

Yes, that is my point, I dont think its xvnc causing trouble and nothing the USER ever selected to install, but rather a package, the question is witch.

Or maybe it is ONLY tigervnc relying on it, idk. But in both cases, there is something strange going on since it is working for me. xD

Happy new year! :partying_face: :partying_face:

Oh I see what you say now, I should have asked for that command instead… Thank you. :smiley:

Both Xvnc and vncserver are binaries provided by the tigervnc package. He mentioned both. I don’t use it myself, however if it’s working fine for you then it must be something local to the OP’s system. :man_shrugging:

I’ll drop this here for consideration: RustDesk / GitHub.

E.g., “vncserver :1” crashed, as did the analogous systemctl command. Reinstalling tigervnc didn’t help. I used journalctl and scanned the x11 server logs, but I stopped searching after seeing that something was blocking Xvnc from starting an xserver component.

All 5 machines are AMD opteron or ryzen boxes with NVIDIA graphics. I found only one mention of the same problem somewhere in the googleverse, but no solutions. Changing pacman-mirrors to stable and reinstalling all stable packages via pacman -Syyuuu (or some string like that) fixed the problem on all the machines.

Happy New Year!

PS, all the machines are servers accessed via SSH and VNC tunneling.
PPS, x11vnc also crashed before reverting to stable. Both VNC flavors worked well before the update.

Sorry about the formatting.

Possibly related upstream issue:

AHA! It’s the mesa problem described in the December unstable thread.
And thanks for suggesting the pacman -Fy command. I typically use pacman -Syyu but didn’t know that it didn’t update the local database.

The mesa issue interacts with NVIDIA…

Only use one -y. Using it once refreshes the package database from the mirror servers. Using it twice forces a refresh even if they are already up to date. That wastes server bandwidth and resources unnecessarily.

Thank you.