Updated: Qonos upgrade breaks Samba - reproduced on two systems

Smb4K stopped working immediately after reboot following upgrade to Qonos. I’ve tried removing and reinstalling Smb4k but no effect. On starting Smb4K, the icon appears briefly in the system tray but then disappears without the shares being mounted. I am predominantly a GUI user but a few commands entered into Konsole suggest the problem may be that Samba is not running. e.g. sudo systemctl status smb shows that Samba is loaded but inactive (dead). Why?? All I did was update to Qonos and I can’t see any way to revert to Pavho. The Samba shares are essential to my use of my Manaro laptop so any assistance to get it working again would be greatly appreciated. Thank you.

Access to Google Drive via Dolphin and kio-gdrive has also been broken by Qonos upgrade.

How to increase your chances of solving your issue:

Please provide Information:

Please forgive me for not posting diagnostic information, although I did search for similar reports and problems before posting my report. I am new to Manaro, to Linux in general, and am predominantly a GUI user: that is why I chose Manjaro KDE, to avoid having to use a CLI. However, I have done so to provide this diagnostic information that I hope will help someone to help me. These are the result from systemctl status smb and nmb:

[Mando davidc]# systemctl status smb
○ smb.service - Samba SMB Daemon
     Loaded: loaded (/usr/lib/systemd/system/smb.service; disabled; vendor preset: disabled)
     Active: inactive (dead)
       Docs: man:smbd(8)
[Mando davidc]# systemctl status nmb
○ nmb.service - Samba NMB Daemon
     Loaded: loaded (/usr/lib/systemd/system/nmb.service; disabled; vendor preset: disabled)
     Active: inactive (dead)
       Docs: man:nmbd(8)

Results of inxi command:

  Kernel: 5.16.2-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.16-x86_64
    root=UUID=405ba13a-c95b-46f6-aaaa-691489833226 rw quiet apparmor=1
    security=apparmor udev.log_priority=3
  Desktop: KDE Plasma 5.23.5 tk: Qt 5.15.2 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: FUJITSU product: LIFEBOOK AH531 v: N/A serial: <filter>
    Chassis: type: 9 serial: <filter>
  Mobo: FUJITSU model: FJNBB0F serial: <filter>
    UEFI-[Legacy]: FUJITSU // Phoenix v: 1.30 date: 05/28/2012
  ID-1: BAT1 charge: 17.6 Wh (79.6%) condition: 22.1/47.5 Wh (46.6%)
    volts: 12.5 min: 10.8 model: SANYO AS10B73 type: Li-ion serial: <filter>
    status: Charging
  RAM: total: 3.74 GiB used: 1.43 GiB (38.3%)
  Array-1: capacity: 8 GiB slots: 2 EC: None max-module-size: 4 GiB
    note: est.
  Device-1: ChannelA-DIMM0 size: No Module Installed
  Device-2: ChannelB-DIMM0 size: 4 GiB speed: 1333 MT/s type: DDR3
    detail: synchronous bus-width: 64 bits total: 64 bits
    manufacturer: Hynix/Hyundai part-no: HMT351S6BFR8C-H9 serial: <filter>
  Info: model: Intel Pentium B950 bits: 64 type: MCP arch: Sandy Bridge
    family: 6 model-id: 0x2A (42) stepping: 7 microcode: 0x2F
  Topology: cpus: 1x cores: 2 smt: <unsupported> cache: L1: 128 KiB
    desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB L3: 2 MiB
    desc: 1x2 MiB
  Speed (MHz): avg: 1145 high: 1373 min/max: 800/2100 base/boost: 2100/2100
    scaling: driver: intel_cpufreq governor: schedutil volts: 1.2 V
    ext-clock: 100 MHz cores: 1: 1373 2: 917 bogomips: 8384
  Flags: acpi aperfmperf apic arat arch_perfmon bts clflush cmov
    constant_tsc cpuid cx16 cx8 de ds_cpl dtes64 dtherm dts epb est flush_l1d
    fpu fxsr ht ibpb ibrs lahf_lm lm mca mce md_clear mmx monitor msr mtrr
    nonstop_tsc nopl nx pae pat pbe pcid pclmulqdq pdcm pebs pge pln pni
    popcnt pse pse36 pti pts rdtscp sep ssbd sse sse2 sse4_1 sse4_2 ssse3
    stibp syscall tm tm2 tsc tsc_deadline_timer vme x2apic xsave xsaveopt
    xtopology xtpr
  Type: itlb_multihit status: KVM: VMX unsupported
  Type: l1tf mitigation: PTE Inversion
  Type: mds mitigation: Clear CPU buffers; SMT disabled
  Type: meltdown mitigation: PTI
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
    IBRS_FW, STIBP: disabled, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: Intel 2nd Generation Core Processor Family Integrated Graphics
    vendor: Fujitsu Limited. driver: i915 v: kernel bus-ID: 00:02.0
    chip-ID: 8086:0106 class-ID: 0300
  Device-2: Chicony Fujitsu Integrated Camera type: USB driver: uvcvideo
    bus-ID: 1-1.3:3 chip-ID: 04f2:b213 class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org compositor: kwin_x11 driver:
    loaded: modesetting alternate: fbdev,vesa display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.2x8.0")
    s-diag: 414mm (16.3")
  Monitor-1: LVDS-1 res: 1366x768 hz: 60 dpi: 101
    size: 344x193mm (13.5x7.6") diag: 394mm (15.5")
  Message: Unable to show advanced data. Required tool glxinfo missing.
  Device-1: Intel 6 Series/C200 Series Family High Definition Audio
    vendor: Fujitsu Limited. driver: snd_hda_intel v: kernel bus-ID: 00:1b.0
    chip-ID: 8086:1c20 class-ID: 0403
  Sound Server-1: ALSA v: k5.16.2-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.20 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.43 running: yes
  Device-1: Intel Centrino Wireless-N 1030 [Rainbow Peak] driver: iwlwifi
    v: kernel bus-ID: 01:00.0 chip-ID: 8086:008a class-ID: 0280
  IF: wlp1s0 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Fujitsu Limited. driver: r8169 v: kernel port: 2000 bus-ID: 07:00.0
    chip-ID: 10ec:8168 class-ID: 0200
  IF: enp7s0 state: down mac: <filter>
  WAN IP: <filter>
  Device-1: Intel Centrino Advanced-N 6230 Bluetooth adapter type: USB
    driver: btusb v: 0.8 bus-ID: 2-1.4:3 chip-ID: 8086:0189 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 1 state: up address: see --recommends
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 465.76 GiB used: 14.99 GiB (3.2%)
  ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: ST9500325AS
    family: Momentus 5400.6 size: 465.76 GiB block-size: physical: 512 B
    logical: 512 B sata: 2.6 speed: 3.0 Gb/s type: HDD rpm: 5400
    serial: <filter> rev: SDM1 temp: 25 C scheme: MBR
  SMART: yes state: enabled health: PASSED on: 80d 10h cycles: 2882 Old-Age:
    g-sense error rate: 418 Pre-Fail: reallocated sector: 100 threshold: 36
    attribute: Spin_Retry_Count value: 100 worst: 100 threshold: 97
  Optical-1: /dev/sr0 vendor: TSSTcorp model: CDDVDW SN-208AB rev: FC01
    dev-links: cdrom
  Features: speed: 24 multisession: yes audio: yes dvd: yes
    rw: cd-r,cd-rw,dvd-r,dvd-ram state: running
  ID-1: / raw-size: 465.76 GiB size: 457.38 GiB (98.20%)
    used: 14.99 GiB (3.3%) fs: ext4 block-size: 4096 B dev: /dev/sda1
    maj-min: 8:1 label: N/A uuid: 405ba13a-c95b-46f6-aaaa-691489833226
  Alert: No swap data was found.
  Message: No unmounted partitions found.
  Hub-1: 1-0:1 info: Full speed or root hub ports: 2 rev: 2.0 speed: 480 Mb/s
    chip-ID: 1d6b:0002 class-ID: 0900
  Hub-2: 1-1:2 info: Intel Integrated Rate Matching Hub ports: 6 rev: 2.0
    speed: 480 Mb/s chip-ID: 8087:0024 class-ID: 0900
  Device-1: 1-1.3:3 info: Chicony Fujitsu Integrated Camera type: Video
    driver: uvcvideo interfaces: 2 rev: 2.0 speed: 480 Mb/s power: 500mA
    chip-ID: 04f2:b213 class-ID: 0e02 serial: <filter>
  Hub-3: 2-0:1 info: Full speed or root hub ports: 2 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-4: 2-1:2 info: Intel Integrated Rate Matching Hub ports: 6 rev: 2.0
    speed: 480 Mb/s chip-ID: 8087:0024 class-ID: 0900
  Device-1: 2-1.4:3 info: Intel Centrino Advanced-N 6230 Bluetooth adapter
    type: Bluetooth driver: btusb interfaces: 2 rev: 2.0 speed: 12 Mb/s
    chip-ID: 8086:0189 class-ID: e001
  System Temperatures: cpu: 42.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 182 Uptime: 31m wakeups: 1 Init: systemd v: 250 tool: systemctl
  Compilers: gcc: 11.1.0 clang: 13.0.0 Packages: pacman: 1277 lib: 366
  flatpak: 0 Shell: Bash (su) v: 5.1.16 running-in: konsole inxi: 3.3.12

To reiterate samba, Smb4K and Google drive access were all working before Qonos upgrade. All I did was upgrade to Qonos, nothing else, reboot and these essential (for me) services had stopped working.

I found another command that may (or may not) yield useful diagnostics:

 systemctl status smb.service
× smb.service - Samba SMB Daemon
     Loaded: loaded (/usr/lib/systemd/system/smb.service; disabled; vendor preset: disabled)
     Active: failed (Result: exit-code) since Tue 2022-01-25 11:14:53 GMT; 33s ago
       Docs: man:smbd(8)
    Process: 1816 ExecStart=/usr/bin/smbd --foreground --no-process-group $SMBDOPTIONS (code=exited, status=1/FAILURE)
   Main PID: 1816 (code=exited, status=1/FAILURE)
        CPU: 199ms

Jan 25 11:14:51 Mando systemd[1]: Starting Samba SMB Daemon...
Jan 25 11:14:53 Mando systemd[1]: smb.service: Main process exited, code=exited, status=1/FAILURE
Jan 25 11:14:53 Mando systemd[1]: smb.service: Failed with result 'exit-code'.
Jan 25 11:14:53 Mando systemd[1]: Failed to start Samba SMB Daemon.

I have found that this problem is reproducible, which confirms that the Qonos upgrade breaks Samba. I borrowed my partner’s laptop, which also runs Manjaro, but is a different make, older and a different specification, ruling out any hardware problems. She does not use Samba so it didn’t matter if my test stopped it from working.

Before the upgrade, I set up some Samba shares to my NAS which worked perfectly. After performing the upgrade, and doing nothing else, Samba was not working with the same diagnostic results: Samba is inactive (dead).

I have therefore changed the title of this report because I am now certain that the problem is not with Smb4K, which does not run because Samba is inactive (dead). Instead I am confident that the problem is that Qonos breaks Samba.

Sadly, I have read that Manjaro has a track record of breaking things when new new versions are released, which can then take days, weeks or months to be fixed. I can’t wait months to get Samba working again so am wondering whether to switch to another KDE distro such as Qubuntu, which is widely reported to be more stable, despite the fact that I really like Manjaro, which I’ve now installed on three laptops, and the time it will take to set up from scratch again. It may be a case of short-term pain for long-term gain (stability).

Reports on smb.service failing after an update is present for many distributions out there, over the past years, same for smb4k

Check if you have the /etc/samba/smb.conf that is part of manjaro-settings-samba package that you can install … or if installed, check the configuration.

I highly recommend reading this [root tip] systemd mount unit samples

Your output is showing that smb.service is disabled. Have you tried to enable the service?

loaded (/usr/lib/systemd/system/smb.service; disabled; vendor preset: disabled)

Mine works here on Unstable (xfce), one laptop and on three xfce Stable laptops after the updates:

 Loaded: loaded (/usr/lib/systemd/system/smb.service; enabled; vendor prese>
     Active: active (running) since Thu 2022-01-27 05:55:51 EST; 32min ago

Your config file may also be the problem. When you run testparm in terminal, does it look okay?

As client? NAS is the one offering the shares?

If you are not sharing folders from your system you will be good with smbclient package - no smb or nmb service needed.

Client role

If you have problems with the machine connecting or finding shares as client then ensure you have a valid smb.conf


workgroup = WORKGROUP

Server role

If you are sharing folders from your computer you must add to the [general] section

server role = standalone

And you need to enable and start the service

systemctl enable --now smb

And it is possible to be both client and server at the same time.

1 Like

Thank you for your reply. I think you may have identified the problem: smb.conf is missing. But why did the upgrade delete it? Surely that is a bug? I’ve found another report of smb.conf missing after a previous version upgrade in 2020 (clearly a longstanding bug) and will try the solution identified there when I have time. Thanks again.

The upgrade didn’t delete it - /etc/samba/smb.conf - because the file is not installed by any packages. (unless of course you installed the manjaro-settings-samba package)

It is a manual addition to your configuration.

Perhaps smb4k provides a local smb.conf - I don’t know - but for samba either client or server - a valid smb.conf must exist.


Thanks for your reply, but I never knowingly installed an smb.conf file in the past. I never knew of its existence until jrichard326’s reply. Samba and Smb4K just worked out of the box. So smb.conf must have been present before the upgrade for it to have worked, and the Qonos upgrade must have deleted it, or moved it to a backup folder without replacing it or restoring the original.

No - as the file is never installed by any package (except the aforementioned package) there is no package which can remove the file as part of an upgrade process.

Samba - ArchWiki

Samba is configured in the /etc/samba/smb.conf configuration file, which is extensively documented in smb.conf(5).

Because the samba package does not provide this file, one needs to create it before starting smb.service.

A documented example as in smb.conf.default from the Samba git repository may be used to setup /etc/samba/smb.conf.

Smb4K: ChangeLog | Fossies

   53 - Do not read global options from smb.conf anymore. Use an SMB context
   54   to retrieve the required information.

According to the changelog - smb4k doesn’t require smb.conf - which contradicts statemenent on

Smb4K - KDE Applications

Smb4K is based on Samba’s client library.

From experience it is a hit and miss when connecting to smb shares if the smb.conf is not configured with a workgroup as mentioned above and troubleshooting starts with ensuring a valid smb.conf is present.

Installing manjaro-settings-samba in package manager, creating samba.info worked so that Samba/smb and Smb4K now work again, although access to Google Drive via kio-gdrive is still not working. Maybe another .info that disappeared during the upgrade but I haven’t been able to find any information on its dependencies. Thanks to those who helped so far.

I have never heard of that before - is this a file?

If it is - what content did you provide?

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.