Update response: error: partition / full

Hello and Hi,

So I have problems starting my PC.

Last thing I did before the problem occured was to try and update my system -Manjaro XFCE-, which I couldn’t because of “not enough space on the hdd”, something like that, I don’t recall the exact words. So I thought it’d be clever to delet the orphans packages, did that, nothing changed.

So I tried to restart. Lenovo logo apears, then:

/dev/sda2: recovering journal
/dev/sda2: clean, 335886/12811120 files, 4921342/5120000 blocks

and nothing more.

I read the forum, and change into TTY3, which works.
I try to update by

sudo pamac -Syyu

And the response I get is:

error: partition / is full: 0 blocks are free
error no packages were installed

Is there any possibility to work on that?
My partitions are all on one HDD: sda
And my system partition is:

Device        Start        End    Sectors                         Size       Type
/dev/sda1      2048    1026047    1024000             500M     EFI System
/dev/sda2  17000448   57960447   40960000     19,5G     Linux filesystem
/dev/sda3  57960448 1953520031 1895559584 903,9G  Linux filesystem
/dev/sda4   1026048   17000447   15974400       7,6G       Linux swap

probably sda2 shouldn’t be “filesystem”, I guess, but can I change that at this point?
Or do I simply have to reinstall?

I am not an expert and I thank everyone for his/her patience!
Thanks for any help :slight_smile:

from tty clean cache:
sudo pacman -Scc
and also clear journal:
sudo journalctl --rotate
sudo journalctl -m --vacuum-time=1s

if you have snapshot, you can clear them too…
also post output from:
pacman -Qm
to check for for foreign packages

1 Like

Thanks for the fast answer!

Output from

pacman -Qm

manjaro-documentation-en 20181009-1
manjaro-firmware 20160419-1

I did the rest.


sudo journalctl --rotate
I had no response.

delete also the 2 manjaro packages:

sudo pacman -Rs manjaro-documentation-en manjaro-firmware

systemctl reboot

1 Like

What else would it be? :stuck_out_tongue:

Is sda2 your root partition? If yes, it’s absolutely too small, especially when you have 900GB on sda3. Backup any important data and resize it.

1 Like

Re your screenshot:
:: Möchen Sie ALLE Dateien aus dem Zwischenspeicher entfernen? [j/N]

you hit ENTER
(did you?) -
which means the default answer, which is NO in this case.
Run it again and answer “y” this time.

possibly a lot of space can be gained here

1 Like

Okay, thanks!
I could boot just fine!

Now I tried to update again and the error is the same.

Yes, you are totally right, I did just hit enter.
Thanks for the note!

I will redo.

Oh I don’t know, just thought it would be at least a different type to the partition where all my private data is saved … :person_frowning:
So what would be an appropriate size?

Depends on what apps you plan to have. With your disk size I’d say at least 50, 60G.

1 Like

Thanks :slight_smile:
I guess I will change that then :sweat_smile:

Can I resize without reinstalling?

Yes, unless you screw up something. :stuck_out_tongue: (I’m also guessing you are using ext4)

Ha :smiley: I am 78% shure, there’s gonna be some screwup, but thats okay, thats how I learn best!

Yes, I use ext4.

You can simply reduce the size of the reserved space to 64 MiB. This will have an immediate effect on your free space for sda2, without resorting to resizing partitions or reformatting anything.

sudo tune2fs -r 16384 /dev/sda2

By default, a newly formatted Ext4 filesystem will reserve 5% space, which in your case is a waste of almost 1 GiB.

Other culprits include the use of Timeshift on the same filesystem, among other factors mentioned in this thread, such as your temporary files, pacman cache, and journals.

:point_right: Using Timeshift on the same filesystem is the single biggest factor, however. :point_left:

The number 16384 is for 16384 “blocks”. Your blocksize is very likely 4096-bytes, so 16384 blocks multiplied by 4096 bytes equals 67108864 bytes, which equals 64 MiB.

1 Like

Yes, the block size is 4096 bytes. (juhu)
And what I am reducing by

sudo tune2fs -r 16384 /dev/sda2

is the ‘reserved block count’? I can just do that without consequences?

And no, I just checked, Timeshift is used on sda3. :+1:
Cache and journal I will have in mind in the future.

thx for your help!!

Yes, pretty much. Heck, you can even go lower and set it to 32 MiB if you’d like. (That is, -r 8192)

It’s the “superuser” reserved space, which cannot be written to. It’s more of a legacy spillover from the older days of filesystems, in which you would need even a tiny bit of free space that the “superuser” can use to recover a full (and read-only) filesystem.

64 (or even just 32) MiB of reserved space should be fine for most modern systems.

How is your root filesystem so full, without using Timeshift on it? How much stuff do you have installed?

:question: What are your cache settings configured as under the Pamac GUI?

Pamac → Preferences → General → Cache section

:question: The /usr directory is likely taking up the bulk of space, as it naturally will, and increases as you install more applications.

:question: Hopefully you’re not also using a swapfile in addition to a swap partition.

:question: There’s of course /var, and then /opt which is used by some third-party applications.

[quote=“winnie, post:16, topic:128353”]
What are your cache settings configured as under the Pamac GUI?

Pamac → Preferences → General → Cache section

Changed from
Number of versions of each package to keep: “3”
to “0”
Which makes 1,2GB

All of this is just postponing the inevitable. Partition is too small and it will be full again. If not today, then in 3 months.

1 Like

Keep things lean, clear that cache as well. :+1:

The OP already said they will resize their partition (which does carry its risks), but it’s not mutually exclusive with running a leaner system that isn’t filled with excessive cruft and cache, as well as the (pointless) default 5% space reservation for Ext4 filesystems.

[ruiliri@lenovoiris ~]$ sudo du -sh /usr/*
466M	/usr/bin
8,0K	/usr/etc
293M	/usr/include
4,0G	/usr/lib
436M	/usr/lib32
0	/usr/lib64
40K	/usr/local
28K	/usr/man
0	/usr/sbin
2,5G	/usr/share
4,0K	/usr/src
[ruiliri@lenovoiris ~]$ sudo du -sh /var/*
492M	/var/cache
24K	/var/db
4,0K	/var/empty
4,0K	/var/games
20G	/var/lib
4,0K	/var/local
0	/var/lock
33M	/var/log
0	/var/mail
4,0K	/var/opt
0	/var/run
6,7M	/var/snap
812K	/var/spool
72M	/var/tmp
[ruiliri@lenovoiris ~]$ sudo du -sh /opt/*
766M	/opt/onlyoffice

And actually I don’t know if I’m using a swapfile. :grimacing:
How do I find out?