Update requests for packages imported from Arch Linux

Could we get a quick update for geogebra? The current version is broken (saving a construction is impossible, I just spent half an hour doing a construction which I then wasn’t able to save…): FS#72846 : [geogebra] electron15 breaks sign-in function

The updated package just uses electron14 when building geogebra, otherwise no changes, so no breakage beyond what is already broken should occur: Use electron14 (FS#72846) · archlinux/svntogit-community@4ce8c45 · GitHub

geogebra 6.0.676.0-2 is now available in all branches.

1 Like

That was real quick, thanks a lot! Looks like the issue is still not fixed but I will comment upstream about it.

mediathekview 13.8.1 contains a security fix to patch CVE-2021-44228 (log4j)

13.8.1-2 contains the patch and is available in the unstable branch.

dbeaver to current version 21.3.1

thank for contribution, but please, read first message, it’s not a manjaro package :wink: (read “Packager”)

And is updated in testing

1 Like

rebuild-detector 4.3.0 includes bugfix that will help with python 3.10 updates. Please fast-track so stable branch skips 4.2.0 (contains regression, currently in testing)


A post was split to a new topic: Blender is missing compression options when exporting to glTF

lynis 3.0.7-1 is available in arch repo. We have in manjaro unstable.

So just wait for the next sync?

Yes, of course. However, since this is a security auditing tool, I would like to ask for it to be fast tracked directly to stable, if possible.

2 posts were split to a new topic: Libspeechd: signature is unknown trust

2 posts were split to a new topic: Is there anywhere to track the progress of a package?

Hey guys, could someone please update fcitx5-mozc if possible? I tried to do it myself but I’m stuck and I think my approach is not the best one anyway (I tried to force building using python 3.7).

# Maintainer: Jiachen Yang <farseerfc@archlinux.org>
# Contributor: Felix Yan <felixonmars@archlinux.org>
# Contributor: ponsfoot <cabezon dot hashimoto at gmail dot com>
# Contributor: UTUMI Hirosi <utuhiro78 at yahoo dot co dot jp>

## Mozc compile option

## follow the submodule commits in https://github.com/fcitx/mozc/tree/fcitx/src/third_party

## the latest release from https://osdn.net/projects/ponsfoot-aur/storage/mozc/

pkgdesc="Fcitx5 Module of A Japanese Input Method for Chromium OS, Windows, Mac and Linux (the Open Source Edition of Google Japanese Input)"
depends=('qt5-base' 'fcitx5')
makedepends=('pkg-config' 'python' 'curl' 'gtk2' 'mesa' 'subversion' 'ninja' 'git' 'clang' 'python-six')
conflicts=('mozc' 'mozc-server' 'mozc-utils-gui' 'mozc-fcitx' 'fcitx-mozc')
validpgpkeys=('2CC8A0609AD2A479C65B6D5C8E8B898CBF2412F9')  # Weng Xuetian

  cd mozc
  # change pkgver is OK because we fixed commit
  # parse major.minor.buildid from version template, revision is fixed to 102 for Linux
  _bzr_ver=$(sed 's/ //g;$ a echo $MAJOR.$MINOR.$BUILD.102' src/data/version/mozc_version_template.bzl | source /dev/stdin)
  printf "%s.g%s" "${_bzr_ver}" "${_mozc_commit}"

prepare() {
  cd "$srcdir/mozc"
  git submodule init
  git config submodule.src/third_party/breakpad.url "$srcdir/breakpad"
  git config submodule.src/third_party/gtest.url "$srcdir/googletest"
  git config submodule.src/third_party/gyp.url "$srcdir/gyp"
  git config submodule.src/third_party/japanese_usage_dictionary.url "$srcdir/japanese-usage-dictionary"
  git config submodule.src/third_party/jsoncpp.url "$srcdir/jsoncpp"
  git config submodule.src/third_party/protobuf.url "$srcdir/protobuf"
  git config submodule.src/third_party/abseil-cpp.url "$srcdir/abseil-cpp"
  git submodule update

  cd src
  # Generate zip code seed
  echo "Generating zip code seed..."
  PYTHONPATH="$PWD:$PYTHONPATH" python dictionary/gen_zip_code_seed.py --zip_code="${srcdir}/x-ken-all.csv" --jigyosyo="${srcdir}/JIGYOSYO.CSV" >> data/dictionary_oss/dictionary09.txt
  echo "Done."

  # disable fcitx4 target
  #rm unix/fcitx/fcitx.gyp
  ## use libstdc++ instead of libc++
  sed "/stdlib=libc++/d;/-lc++/d" -i gyp/common.gypi

build() {
  # Fix compatibility with google-glog 0.3.3 (symbol conflict)
  CFLAGS="${CFLAGS} -fvisibility=hidden"
  CXXFLAGS="${CXXFLAGS} -fvisibility=hidden"

  cd mozc/src

  _targets="server/server.gyp:mozc_server gui/gui.gyp:mozc_tool unix/fcitx5/fcitx5.gyp:fcitx5-mozc"

  QTDIR=/usr GYP_DEFINES="document_dir=/usr/share/licenses/$pkgname use_libzinnia=1" python3.7 build_mozc.py gyp
  python3.7 build_mozc.py build -c $_bldtype $_targets

  # Extract license part of mozc
  head -n 29 server/mozc_server.cc > LICENSE

package() {
  cd mozc/src
  export PREFIX="${pkgdir}/usr"
  export _bldtype

  install -d "${pkgdir}/usr/share/licenses/$pkgname/"
  install -m 644 LICENSE data/installer/*.html "${pkgdir}/usr/share/licenses/${pkgname}/"

  install -d "${PREFIX}/share/fcitx5/addon"
  install -d "${PREFIX}/share/fcitx5/inputmethod"
  install -d "${PREFIX}/lib/fcitx5"

there is new version for wlroots (0.15.0). They have migrated to GitLab (gitlab-wlroots), so maybe this is the reason manjaro team haven’t been able to pick up on this version release.

wlroots is an Arch community package. 0.15 is currently in Arch Community-Staging.

fcitx5-mozc is on the Task Todo List GTK 2 EOL so Arch may be waiting to be able to build it with Gtk 3.

1 Like

stable : 3.0.10-6 → cannot be installed due to invalid PGP signature
testing : 3.0.10-7 → works
Please update ?

A few packages including shntool were missed when rebuilding the maintainer’s packages when the key was revoked.

For now just download shntool 3.0.10-7 and mcomix 1.3.0.dev0-6 from one of our mirrors like this one: Index of /testing/community/x86_64/